PDA

View Full Version : Pbasic 2.5 ?


n[ate]vw
01-13-2003, 06:53 PM
I downloaded the 2.5alpha editor off of InnovationFirst.

However, it doesn't seem to be PBasic 2.5

I tried something like this:

if vari > 25 then vari=30

If I am not mistaken, PBASIC 2.5 was supposed to allow commands like this. However, I still get "Expected a label" when I check syntax. Same thing with a multiline command. I "Expected a little different" from this editor. The program version under "Help>About" reads "2.0 Alpha (c) 1998-2003". This is a very recent release, but is it still not what we hoped for?

GMitchell
01-13-2003, 08:00 PM
I tried exactly the same command and had no errors - are you sure you're using 2.5 code? When I drag FIRST's 2.5 code into a 2.0 editor, the commented line " ' {$PBASIC 2.5} " caused an error - could it be that you need that to jump into V. 2.5? I can't think of any reason why that would actually make any sort of difference, but it's worth a try if you don't have FIRST's commented initialization at the top of your code.

Greg Ross
01-13-2003, 08:00 PM
Did you add the {$PBASIC 2.5} directive?

Greg McCoy
01-13-2003, 08:04 PM
Originally posted by gwross
Did you add the {$PBASIC 2.5} directive?

Yeah, I think he's right. If you are using the newest software but it thinks that you are using an old stamp it should keep you from using the newer commands.

n[ate]vw
01-13-2003, 08:19 PM
*Sheepish grin* ....no.

Thanks alot!


Update: I added the directive and now it works!! *now-excited grin*