PDA

View Full Version : 2009 Control System: is it compatible?


Straberrie
11-10-2010, 04:52 PM
Hey everyone!

My team is trying to program a newly purchased crio for a presentation and we need to use the 2009 driver station.

Is the 2009 driver station compatible with this year's software?

Would we have to image the crio using 2010 format?

Do we need to update the driver station using this year's updates?

Thank you!

Mark McLeod
11-10-2010, 05:09 PM
Treat the new cRIO as you do your existing cRIO.
Format it with the latest 2010 image, so your code will work correctly on it.

The 2009 driver station will work fine without any changes.
We cannot apply 2010 updates to the '09 driver station anyway.

You can also use any PC laptop to run the 2010 Driver Station application (http://ftp.ni.com/support/labview/FIRST/DSUpdate1.1for2010.zip) if that's easier.
The Driver Station installer will work on any PC.

(http://joule.ni.com/nidu/cds/view/p/lang/en/id/1535)

Straberrie
11-10-2010, 05:14 PM
Treat the new cRIO as you do your existing cRIO.
Format it with the latest 2010 image, so your code will work correctly on it.

The 2009 driver station will work fine without any changes.
We cannot apply 2010 updates to the '09 driver station anyway.

You can also use any PC laptop to run the 2010 Driver Station application (http://joule.ni.com/nidu/cds/view/p/lang/en/id/1535) if that's easier.

Thank you! This clears it all up!