PDA

View Full Version : Require assistance for imaging Classmate 2GO Netbook (2011)


winglerw28
01-08-2011, 01:57 PM
After about an hour of frustration, I am seeking help with the new USB key provided for the 2010 Netbook that images it. I booted from it and it formats my HD and then fails with the error 'arithmetic exceeded 32 bits'.

I then tried the 2010 restore key and it gives me the error that claims restoreds doesn't exist!

Please help!

Thank you very much,
William Wingler

Garten Haeska
01-08-2011, 04:38 PM
IM also having trouble but i cant get even close to the progress that you are seeming to be at. How do we even start the reimage?

Sawyer
01-08-2011, 05:01 PM
After about an hour of frustration, I am seeking help with the new USB key provided for the 2010 Netbook that images it. I booted from it and it formats my HD and then fails with the error 'arithmetic exceeded 32 bits'.

I then tried the 2010 restore key and it gives me the error that claims restoreds doesn't exist!

Please help!

Thank you very much,
William Wingler

I'm not exactly sure what the problem is, the 32-bit error normally only occurs if you have an incompatible 64-bit program on a 32-bit system, and that shouldn't be the case here.

IM also having trouble but i cant get even close to the progress that you are seeming to be at. How do we even start the reimage?

As for this you must insert the usb in the classmate before you start it up, and then on start up the computer should boot into the reflashing process, it'll take a while so make sure you have your classmate plugged in =D. I hope that helped.

Mark McLeod
01-08-2011, 05:01 PM
IM also having trouble but i cant get even close to the progress that you are seeming to be at. How do we even start the reimage?
There should be a readme file on the memory stick that gives directions on how to boot from the stick and start the reimaging.

Garten Haeska
01-08-2011, 05:08 PM
thanks to the both of you! Im going to try that idea right now!

Garten Haeska
01-08-2011, 05:15 PM
When i try to put the new image on the classmate, The junk drive doesnt light up is this a problem?

Da Kid
01-08-2011, 05:27 PM
Could someone please post a link to the readme.txt file that is supposed to be in the flashdrive with the new image on it?

2829ron
01-08-2011, 05:58 PM
Could someone please post a link to the readme.txt file that is supposed to be in the flashdrive with the new image on it?
I find no file titled readme.txt. Can't find it. Here is the text from the file called HIDERECOVERY:
select disk 0
select volume 0
set ID=27 override
exit

Don't know if that helps. Imaging was a piece a cake for us. Maybe we got lucky.

David
Team #2829

Mark McLeod
01-08-2011, 06:06 PM
See if this helps:

Instructions:

1. With the Classmate powered OFF, insert the bootable USB Key into an available USB port. Do not use a USB hub, plug the Key directly into the Classmate.
2. Power on the Classmate and when you see the 2Go PC screen, repeatedly press F11 until a small window appears entitled “Please Select Boot Device”.
3. Using the cursor keys, select the USB Key. It will likely be the second item in the list, beginning with USB:xxxx. Do not select the USB:Generic device, this is not your USB Key. If two identical looking USB items show up, don’t worry. Select the first of the two.
4. Press Enter and allow the Classmate to boot from the USB Key. Be patient, it can take a minute or more for wpeinit to finish.
5. Follow the on-screen instructions

Da Kid
01-08-2011, 08:10 PM
Thanks! That worked for us.

winglerw28
01-08-2011, 10:14 PM
Ok, I've fixed one problem - the old restore disk was on a U3 drive and first set the .Bat to point to D: instead of F: (U3 adds a partition, and therefore all drives are a letter off after it.)

I liked the old rescueds system so I backed up my 2011 and used the files from 2010 and updated essentials, using the INSTALL.WIN file instead of the old version in 2010. I can format the HDD, but I still get an error trying to flash the .WIN to the drive. It's always the arithmetic error.

I get to the stage where I can follow onscreen instructions fine, wpeinit runs fine. It's when actually using the image. Perhaps I have a bad image? Can anyone link me to where I can download the 2011 flash drive contents?

darrellt
01-10-2011, 11:02 PM
We succeeded in re-imaging the 2GO Netbook, but i keeps asking to to "Activate Windows"

We select "Activate now" and then "Active Windows online now" but then we get an Error Code 0x8007232B "DNS Name does not exist"

When I ping the DNS IP address, though, it responds.

Any ideas? Is there supposed to be a new code that we use to activate?

Mark McLeod
01-11-2011, 06:23 AM
You need to install an additional Classmate update (http://www.usfirst.org/uploadedFiles/Robotics_Programs/FRC/Game_and_Season__Info/2011_Assets/Kit_of_Parts/Classmate_Update.zip).
The Classmate needs to be connected to the Internet for Windows activation to complete.

Described in the setup directions How To Setup Your 2011 Driver Station (http://www.usfirst.org/uploadedFiles/Robotics_Programs/FRC/Game_and_Season__Info/2011_Assets/Kit_of_Parts/How_to_Set_Up_Your_2011_Driver_Station.pdf).

All found on the Kit of Parts Website (http://www.usfirst.org/WorkArea/linkit.aspx?LinkIdentifier=id&ItemID=18530)

Team#2057-Vegas
01-11-2011, 09:52 AM
if you go to start > search > system it says it will activate automatically in 3 days but you can activate it already.. im getting the same error as everyone else though if i press activate now.. this doesnt make sense.. anyone have a solution? I did the classmate updating of the batch file.. otherwise im just going to wait a few days and see what happens.

Team3337_mentor
01-11-2011, 11:14 AM
Thank you very much Mark McLeod

I was going crazy trying to remember where I had seen the link to all of the configuration files.

Team 3337 Pathrobotics
Ms. Amanda Salom - Mentor

Birdlives
01-11-2011, 06:32 PM
I'm having a problem in the reimaging process, too. After the disk is reimaged, and a success message is displayed, the classmate crashes while trying to boot windows. We restarted the classmate and started it in safe mode, but there was a boot hangup at "CLASSPNP.sys" and the classmate subsequently crashed. We've tried to reimage the classmate a number of times, but this happens every time.

Many thanks in advance!!

winglerw28
01-11-2011, 06:54 PM
I still have not been able to get a working image at all so I, in my infinite frustrations, gave the classmate to another team member to play with.

It has been replaced by an IBM Thinkpad R40, which is quite sluggish being a P4 2.2GHz with 512mb of RAM. It is still better then the small and low-powered classmate. I just need to be able to program in LabView.

If anyone figures out solutions to these problems, please let me know, it would be immensely appreciated.

Thank you very much,
Will