Go to Post In 2012, we built our best machine ever. Some visitors to our pit were visibly disappointed to find that our machine was a pile of extruded aluminum and urethane belting, just cleverly arranged and programmed. - OZ_341 [more]
Home
Go Back   Chief Delphi > Technical > Programming
CD-Events   CD-Media   CD-Spy   FRC-Spy  
portal register members calendar search Today's Posts Mark Forums Read FAQ rules

 
Closed Thread
 
Thread Tools Rate Thread Display Modes
  #1   Spotlight this post!  
Unread 01-27-2005, 04:46 PM
d.courtney's Avatar
d.courtney d.courtney is offline
Registered User
AKA: David
FRC #0781 (Kinetic Knights)
Team Role: Alumni
 
Join Date: Jan 2005
Rookie Year: 2003
Location: Kincardine, Ontario
Posts: 196
d.courtney has much to be proud ofd.courtney has much to be proud ofd.courtney has much to be proud ofd.courtney has much to be proud ofd.courtney has much to be proud ofd.courtney has much to be proud ofd.courtney has much to be proud ofd.courtney has much to be proud ofd.courtney has much to be proud ofd.courtney has much to be proud of
Problem with MPLAB

how do you export MVS projects as hex files
  #2   Spotlight this post!  
Unread 01-27-2005, 05:45 PM
AIBob's Avatar
AIBob AIBob is offline
AI Programmer
AKA: Bob Frank DOT org
FRC #0358 (Hauppauge Robotic Eagles)
Team Role: Alumni
 
Join Date: Jan 2005
Rookie Year: 2003
Location: Long Island, NY (in Binghamton now)
Posts: 297
AIBob is a splendid one to beholdAIBob is a splendid one to beholdAIBob is a splendid one to beholdAIBob is a splendid one to beholdAIBob is a splendid one to beholdAIBob is a splendid one to beholdAIBob is a splendid one to behold
Send a message via ICQ to AIBob Send a message via AIM to AIBob Send a message via MSN to AIBob Send a message via Yahoo to AIBob
Re: Problem with MPLAB

In the toolbar:
Project -> Build All
or Ctrl+F10
if that does not work, then make sure that mcc18 is inside..
By going to (in the toolbar):
Project -> Select Language Toolsuite...
__________________
- from B B frank

  #3   Spotlight this post!  
Unread 01-29-2005, 02:22 PM
d.courtney's Avatar
d.courtney d.courtney is offline
Registered User
AKA: David
FRC #0781 (Kinetic Knights)
Team Role: Alumni
 
Join Date: Jan 2005
Rookie Year: 2003
Location: Kincardine, Ontario
Posts: 196
d.courtney has much to be proud ofd.courtney has much to be proud ofd.courtney has much to be proud ofd.courtney has much to be proud ofd.courtney has much to be proud ofd.courtney has much to be proud ofd.courtney has much to be proud ofd.courtney has much to be proud ofd.courtney has much to be proud ofd.courtney has much to be proud of
Re: Problem with MPLAB

Yah i tryed that still dosen't work. when i go to build it says:

Executing: "c:\mcc18\bin\mcc18.exe" -p=18F452 "user_SerialDrv.c" -fo="user_SerialDrv.o" -Ou- -Ot- -Ob- -Op- -Or- -Od- -Opa-
This version of the compiler supports only the PIC18F8520 processor.
Halting build on first failure as requested.
BUILD FAILED: Sat Jan 29 15:21:31 2005

Help please
  #4   Spotlight this post!  
Unread 01-29-2005, 02:31 PM
AIBob's Avatar
AIBob AIBob is offline
AI Programmer
AKA: Bob Frank DOT org
FRC #0358 (Hauppauge Robotic Eagles)
Team Role: Alumni
 
Join Date: Jan 2005
Rookie Year: 2003
Location: Long Island, NY (in Binghamton now)
Posts: 297
AIBob is a splendid one to beholdAIBob is a splendid one to beholdAIBob is a splendid one to beholdAIBob is a splendid one to beholdAIBob is a splendid one to beholdAIBob is a splendid one to beholdAIBob is a splendid one to behold
Send a message via ICQ to AIBob Send a message via AIM to AIBob Send a message via MSN to AIBob Send a message via Yahoo to AIBob
Re: Problem with MPLAB

Try re-installing mcc18,
or if that does not work, than perhaps you have the wrong PIC setup in the workspace by going to "Configure -> Select Device" and set it to PIC18F8520
__________________
- from B B frank


Last edited by AIBob : 01-29-2005 at 03:24 PM.
  #5   Spotlight this post!  
Unread 02-02-2005, 03:22 PM
d.courtney's Avatar
d.courtney d.courtney is offline
Registered User
AKA: David
FRC #0781 (Kinetic Knights)
Team Role: Alumni
 
Join Date: Jan 2005
Rookie Year: 2003
Location: Kincardine, Ontario
Posts: 196
d.courtney has much to be proud ofd.courtney has much to be proud ofd.courtney has much to be proud ofd.courtney has much to be proud ofd.courtney has much to be proud ofd.courtney has much to be proud ofd.courtney has much to be proud ofd.courtney has much to be proud ofd.courtney has much to be proud ofd.courtney has much to be proud of
Re: Problem with MPLAB

Ok I did all that now it says:

Executing: "c:\mcc18\bin\mcc18.exe" -p=18F8520 "user_SerialDrv.c" -fo="user_SerialDrv.o" -Ou- -Ot- -Ob- -Op- -Or- -Od- -Opa-
C:\mcc18\h\p18f8520.h:169:Error [1109] type mismatch in redeclaration of 'PORTBbits'
C:\mcc18\h\p18f8520.h:201:Error [1109] type mismatch in redeclaration of 'PORTCbits'
Halting build on first failure as requested.
BUILD FAILED: Wed Feb 02 16:20:53 2005
  #6   Spotlight this post!  
Unread 02-02-2005, 08:42 PM
Mark McLeod's Avatar
Mark McLeod Mark McLeod is offline
Itinerant Programmer
AKA: Hey dad...Father...MARK
FRC #0358 (Robotic Eagles)
Team Role: Engineer
 
Join Date: Mar 2003
Rookie Year: 2002
Location: Hauppauge, Long Island, NY
Posts: 7,189
Mark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond repute
Re: Problem with MPLAB

Quote:
Originally Posted by d.courtney
C:\mcc18\h\p18f8520.h:169:Error [1109] type mismatch in redeclaration of 'PORTBbits'
Rickertsen2 just cleared this up over here:
http://www.chiefdelphi.com/forums/sh...690#post330690
__________________
"A child of five could understand this. Fetch me a child of five." - Groucho Marx

Last edited by Mark McLeod : 02-02-2005 at 08:49 PM.
Closed Thread


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Programming Problem: Extremely Frustrating chantilly_team Programming 19 02-12-2005 10:00 PM
MPLAB Variable Simulator? Chris_Elston Programming 3 02-18-2004 11:08 AM
using the MPLAB IDE MPLAB SIM simulator WizardOfAz Programming 1 11-03-2003 12:24 AM
The problem with scouting... archiver 2001 10 06-23-2002 10:49 PM
Major problem with chipphua motors aka Scott White Motors 18 03-19-2002 06:44 PM


All times are GMT -5. The time now is 05:43 AM.

The Chief Delphi Forums are sponsored by Innovation First International, Inc.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright © Chief Delphi