Go to Post A Red Ryder 200-shot carbine Range model air rifle!!! - dlavery [more]
Home
Go Back   Chief Delphi > Technical > Control System
CD-Events   CD-Media   CD-Spy   FRC-Spy  
portal register members calendar search Today's Posts Mark Forums Read FAQ rules

 
Reply
 
Thread Tools Rate Thread Display Modes
  #1   Spotlight this post!  
Unread 01-22-2010, 09:41 AM
EricWilliams EricWilliams is offline
Registered User
FRC #2039 (Rockford Robotics)
Team Role: Mentor
 
Join Date: Mar 2005
Rookie Year: 2001
Location: Rockford, IL
Posts: 100
EricWilliams is a glorious beacon of lightEricWilliams is a glorious beacon of lightEricWilliams is a glorious beacon of lightEricWilliams is a glorious beacon of lightEricWilliams is a glorious beacon of lightEricWilliams is a glorious beacon of light
Unhappy 2009 Driver Station Issue

We're trying to fire up the old '09 robot for a demo, and having some trouble. With the DS (2009) tethered directly to the cRIO, we get a strange assortment of "#" signs on the bottom line of the DS screen. The "Status" line changes from "Enabled" to "Teloperated" to "Watchdog" rapidly, spending most of it's time in "Teleoperated". We're getting good communications and a battery voltage readback, but we have no control whatsoever.

Using a laptop, we can ping the cRIO and have reset the team number on the DS to work with the cRIO configuration (10.1.25.2 for cRIO, Team Number 125 for the DS). With a laptop plugged into the DS, we get no response pinging 10.1.25.4, even after setting the team number correctly.

Finally, there is a red light on the PD board at a terminal pair to which there is no load attached or breaker installed. According to the datasheets, the red light only comes on when there is a load connected and the break is not installed. Could this be a related issue?

Does anyone have any suggestions? Due to some personnel change and inherent loss of documentation/code, re-imagining the cRIO or dropping new code on it has to be the final last resort.

As a corallary question, does anyone have a copy of the DS firmware that was handed out during inspection at the regional?
Reply With Quote
  #2   Spotlight this post!  
Unread 01-22-2010, 10:06 AM
Mark McLeod's Avatar
Mark McLeod Mark McLeod is offline
Itinerant Programmer
AKA: Hey dad...Father...MARK
FRC #0358 (Robotic Eagles)
Team Role: Engineer
 
Join Date: Mar 2003
Rookie Year: 2002
Location: Hauppauge, Long Island, NY
Posts: 7,188
Mark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond repute
Re: 2009 Driver Station Issue

I assume this robot has remained untouched from last season?
No cRIO image updates, etc.?
Do you remember the last time someone downloaded code to it at the end of the season, and was it run afterwards in competition?

Tethered directly, the DS-to-cRIO needs to use a crossover Ethernet cable, not a normal straight cable.

Are the DS Ethernet status lights coming on?
Did you try both ports with your laptop ping test?
Is your PC Ethernet port auto sensing?

I do have the DS firmware here
__________________
"A child of five could understand this. Fetch me a child of five." - Groucho Marx

Last edited by Mark McLeod : 01-22-2010 at 10:10 AM.
Reply With Quote
  #3   Spotlight this post!  
Unread 01-22-2010, 10:22 AM
EricWilliams EricWilliams is offline
Registered User
FRC #2039 (Rockford Robotics)
Team Role: Mentor
 
Join Date: Mar 2005
Rookie Year: 2001
Location: Rockford, IL
Posts: 100
EricWilliams is a glorious beacon of lightEricWilliams is a glorious beacon of lightEricWilliams is a glorious beacon of lightEricWilliams is a glorious beacon of lightEricWilliams is a glorious beacon of lightEricWilliams is a glorious beacon of light
Re: 2009 Driver Station Issue

The ethernet cable we were using might not have been a cross-over. The cRIO should not have been touched since the last time it was running, which would have been mid-fall 2009. The DS Ethernet ports do light up with both connections, and we have used both ports. We were using the Classmate PC to ping the DS, but I'm under the impression that is not auto-sensing.

I will check the details when we get back to the lab, and also reflash the driver station. Thanks for the link and the help.
Reply With Quote
  #4   Spotlight this post!  
Unread 01-22-2010, 10:33 AM
Mark McLeod's Avatar
Mark McLeod Mark McLeod is offline
Itinerant Programmer
AKA: Hey dad...Father...MARK
FRC #0358 (Robotic Eagles)
Team Role: Engineer
 
Join Date: Mar 2003
Rookie Year: 2002
Location: Hauppauge, Long Island, NY
Posts: 7,188
Mark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond repute
Re: 2009 Driver Station Issue

The classmate is actually auto-sensing, so no worries there.
Ping wouldn't have worked otherwise, so my question about that was unnecessary.

The 2010 Control System documentation is misleading in the case of the Classmate auto-sensing.
__________________
"A child of five could understand this. Fetch me a child of five." - Groucho Marx
Reply With Quote
  #5   Spotlight this post!  
Unread 01-22-2010, 01:42 PM
Greg McKaskle Greg McKaskle is offline
Registered User
no team (Team NI)
 
Join Date: Apr 2008
Rookie Year: 2008
Location: Austin, TX
Posts: 3,895
Greg McKaskle has a reputation beyond reputeGreg McKaskle has a reputation beyond reputeGreg McKaskle has a reputation beyond reputeGreg McKaskle has a reputation beyond reputeGreg McKaskle has a reputation beyond reputeGreg McKaskle has a reputation beyond reputeGreg McKaskle has a reputation beyond reputeGreg McKaskle has a reputation beyond reputeGreg McKaskle has a reputation beyond reputeGreg McKaskle has a reputation beyond reputeGreg McKaskle has a reputation beyond repute
Re: 2009 Driver Station Issue

The 2009 and 2010 driver stations are largely interchangeable. You may as well hook the 2010 to the cRIO and see if the diagnostics tab gives you any more indication of where the fault is.

Greg McKaskle
Reply With Quote
  #6   Spotlight this post!  
Unread 01-22-2010, 01:59 PM
EricWilliams EricWilliams is offline
Registered User
FRC #2039 (Rockford Robotics)
Team Role: Mentor
 
Join Date: Mar 2005
Rookie Year: 2001
Location: Rockford, IL
Posts: 100
EricWilliams is a glorious beacon of lightEricWilliams is a glorious beacon of lightEricWilliams is a glorious beacon of lightEricWilliams is a glorious beacon of lightEricWilliams is a glorious beacon of lightEricWilliams is a glorious beacon of light
Re: 2009 Driver Station Issue

Quote:
Originally Posted by Greg McKaskle View Post
The 2009 and 2010 driver stations are largely interchangeable. You may as well hook the 2010 to the cRIO and see if the diagnostics tab gives you any more indication of where the fault is.

Greg McKaskle
Thanks for the tip, we will do that ASAP.
Reply With Quote
Reply


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2010 Driver Station Netbook Driver Account and Java joshholat FRC Control System 2 01-10-2010 02:04 PM
Driver Station Firmware Update 2009-01-22c1 Mark McLeod FRC Control System 4 02-09-2009 10:52 AM
2009 Driver station schematics Japper FRC Control System 3 01-24-2009 09:30 AM
Driver Station Watch Dog / Motor Won't Spin Issue RMiller FRC Control System 5 01-20-2009 08:58 AM
2009 Driver Station Dimensions noxryan FRC Control System 5 11-27-2008 08:02 PM


All times are GMT -5. The time now is 02:03 PM.

The Chief Delphi Forums are sponsored by Innovation First International, Inc.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright © Chief Delphi