Go to Post remember to keep this simple but yet complex everyone - Team#2057-Vegas [more]
Home
Go Back   Chief Delphi > Technical > Electrical > CAN
CD-Events   CD-Media   CD-Spy   FRC-Spy  
portal register members calendar search Today's Posts Mark Forums Read FAQ rules

 
Reply
Thread Tools Rate Thread Display Modes
  #1   Spotlight this post!  
Unread 02-09-2012, 11:27 PM
lemonzap lemonzap is offline
Head Programmer
FRC #2928 (Viking Robotics)
Team Role: Programmer
 
Join Date: Jan 2012
Rookie Year: 2010
Location: United States
Posts: 33
lemonzap is on a distinguished road
no response from jags in CAN

We have updated our firmware on the jags, and we believe we have wired it up correctly but the driver station says we are not getting a response from the jags, and the lights on the jags are flashing. the jags work fine when we run the jag software while directly connected to the computers. is there an update for the crio image? anyone know whats wrong?
Reply With Quote
  #2   Spotlight this post!  
Unread 02-09-2012, 11:41 PM
Levansic's Avatar
Levansic Levansic is offline
Registered User
AKA: Len Evansic
FRC #0585 (Cyber Penguins)
Team Role: Mentor
 
Join Date: Jan 2012
Rookie Year: 2008
Location: Tehachapi, CA
Posts: 146
Levansic has much to be proud ofLevansic has much to be proud ofLevansic has much to be proud ofLevansic has much to be proud ofLevansic has much to be proud ofLevansic has much to be proud ofLevansic has much to be proud ofLevansic has much to be proud ofLevansic has much to be proud ofLevansic has much to be proud of
Re: no response from jags in CAN

How are you connecting the cRIO to the jaguars?

If you are using the serial port, make sure that you re-image the cRIO with the appropriate Serial CAN Jaguar option. Also make sure that the jaguar initializers in the Begin.vi, are set-up for CAN Jaguar. Verify that the correct CAN addresses are specified.

If that doesn't help, then load up the CAN Jaguar example code, and see if you can make that work.

Last edited by Levansic : 02-09-2012 at 11:45 PM.
Reply With Quote
  #3   Spotlight this post!  
Unread 02-11-2012, 01:59 PM
lemonzap lemonzap is offline
Head Programmer
FRC #2928 (Viking Robotics)
Team Role: Programmer
 
Join Date: Jan 2012
Rookie Year: 2010
Location: United States
Posts: 33
lemonzap is on a distinguished road
Re: no response from jags in CAN

we have tried the example code and all of the things you mentioned but it still will not work. any more ideas?
Reply With Quote
  #4   Spotlight this post!  
Unread 02-11-2012, 11:26 PM
Levansic's Avatar
Levansic Levansic is offline
Registered User
AKA: Len Evansic
FRC #0585 (Cyber Penguins)
Team Role: Mentor
 
Join Date: Jan 2012
Rookie Year: 2008
Location: Tehachapi, CA
Posts: 146
Levansic has much to be proud ofLevansic has much to be proud ofLevansic has much to be proud ofLevansic has much to be proud ofLevansic has much to be proud ofLevansic has much to be proud ofLevansic has much to be proud ofLevansic has much to be proud ofLevansic has much to be proud ofLevansic has much to be proud of
Re: no response from jags in CAN

Which examples are you using? If you are using a speed control example, you need an encoder hooked up to the Jaguars.
Reply With Quote
  #5   Spotlight this post!  
Unread 02-11-2012, 11:30 PM
Levansic's Avatar
Levansic Levansic is offline
Registered User
AKA: Len Evansic
FRC #0585 (Cyber Penguins)
Team Role: Mentor
 
Join Date: Jan 2012
Rookie Year: 2008
Location: Tehachapi, CA
Posts: 146
Levansic has much to be proud ofLevansic has much to be proud ofLevansic has much to be proud ofLevansic has much to be proud ofLevansic has much to be proud ofLevansic has much to be proud ofLevansic has much to be proud ofLevansic has much to be proud ofLevansic has much to be proud ofLevansic has much to be proud of
Re: no response from jags in CAN

When you say you aren't getting a response from the jaguars, are you meaning motor output, or are you querying the status of one or more of them?
Reply With Quote
  #6   Spotlight this post!  
Unread 02-13-2012, 03:58 PM
alancop's Avatar
alancop alancop is offline
200mph club member
AKA: Alan Copeland
FRC #1716 (Redbird Robotics)
Team Role: Electrical
 
Join Date: Dec 2009
Rookie Year: 2009
Location: De Pere WI
Posts: 6
alancop is an unknown quantity at this point
Re: no response from jags in CAN

We are having the exact same problem, We are using the 4 slot cRio, we have not tried to get can working on the old cRio, however we are going to pretty soon. If anyone has any thoughts they would be appreciated.
Reply With Quote
  #7   Spotlight this post!  
Unread 02-14-2012, 12:03 AM
Levansic's Avatar
Levansic Levansic is offline
Registered User
AKA: Len Evansic
FRC #0585 (Cyber Penguins)
Team Role: Mentor
 
Join Date: Jan 2012
Rookie Year: 2008
Location: Tehachapi, CA
Posts: 146
Levansic has much to be proud ofLevansic has much to be proud ofLevansic has much to be proud ofLevansic has much to be proud ofLevansic has much to be proud ofLevansic has much to be proud ofLevansic has much to be proud ofLevansic has much to be proud ofLevansic has much to be proud ofLevansic has much to be proud of
Re: no response from jags in CAN

Alan, I'll ask the same question. Which examples are you having trouble with? What exactly is the problem you are seeing? The experienced people could give much more helpful suggestions, if you provide more information.

For our team, we just hit a roadblock this weekend, when our voltage regulator quit on our analog breakout board. The problem somehow masqueraded as a CAN problem, because the LabView program wouldn't drive our omni-wheels, when it couldn't get the gyro input. That problem had nothing to do with CAN, but it made it look like there was a CAN/cRio issue because we could drive any of the Jaguars via BDC-Comm.

We replaced the analog breakout board, and now that robot is spinning three times faster than our gyro can track. This is our test robot, and it is giving us more confidence in going down the CAN path.
Reply With Quote
Reply


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:31 AM.

The Chief Delphi Forums are sponsored by Innovation First International, Inc.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright © Chief Delphi