OCCRA
Go to Post 1. Build a robot. 2. Donít let it get destroyed. - B-Bot [more]
Home
Go Back   Chief Delphi > Technical > Programming
CD-Events   CD-Media   CD-Spy   FRC-Spy  
portal register members calendar search Today's Posts Mark Forums Read FAQ rules

 
Closed Thread
Thread Tools Rate Thread Display Modes
  #1   Spotlight this post!  
Unread 02-24-2009, 04:19 PM
chinckley chinckley is offline
Winner 2009 West Michigan District
FRC #1254 (Entropy)
Team Role: Teacher
 
Join Date: Jan 2005
Rookie Year: 2003
Location: Lawrence, Michigan
Posts: 204
chinckley is a name known to allchinckley is a name known to allchinckley is a name known to allchinckley is a name known to allchinckley is a name known to allchinckley is a name known to all
Programming Error

Help, We are getting the following error when attempting to run our code (which was made in Labview).

We have update it with version 3

It says on our DS 2009-10a3
Attached Thumbnails
Click image for larger version

Name:	download_error_1.JPG
Views:	99
Size:	108.3 KB
ID:	7555  
__________________
2009 West Michigan District Winner
Thanks to Team 216 and Team 1918

2009 Traverse City Semifinalist
Thanks to Team 1596 and Team 47
2009 Traverse City UL Safety Award Winners

Attending 2009: West Michigan, Traverse City, & State

Last edited by chinckley : 02-24-2009 at 04:21 PM. Reason: version #
  #2   Spotlight this post!  
Unread 02-24-2009, 04:29 PM
Vikesrock's Avatar
Vikesrock Vikesrock is offline
Team 2175 Founder
AKA: Kevin O'Connor
no team
Team Role: Engineer
 
Join Date: Mar 2006
Rookie Year: 2007
Location: Manchester, NH
Posts: 3,305
Vikesrock has a reputation beyond reputeVikesrock has a reputation beyond reputeVikesrock has a reputation beyond reputeVikesrock has a reputation beyond reputeVikesrock has a reputation beyond reputeVikesrock has a reputation beyond reputeVikesrock has a reputation beyond reputeVikesrock has a reputation beyond reputeVikesrock has a reputation beyond reputeVikesrock has a reputation beyond reputeVikesrock has a reputation beyond repute
Send a message via AIM to Vikesrock Send a message via MSN to Vikesrock Send a message via Yahoo to Vikesrock
Re: Programming Error

You likely need to reimage your cRIO with the image installed with Labview Update 3. As I recall the image should be v11.zip

You also should upgrade your DS firmware to the latest version which can be found (along with instructions for updating) here
__________________


2007 Wisconsin Regional Highest Rookie Seed & Regional Finalists (Thanks 930 & 2039)
2008 MN Regional Semifinalists (Thanks 2472 & 1756)
2009 Northstar Regional Semifinalists (Thanks 171 & 525)
  #3   Spotlight this post!  
Unread 02-24-2009, 05:39 PM
chinckley chinckley is offline
Winner 2009 West Michigan District
FRC #1254 (Entropy)
Team Role: Teacher
 
Join Date: Jan 2005
Rookie Year: 2003
Location: Lawrence, Michigan
Posts: 204
chinckley is a name known to allchinckley is a name known to allchinckley is a name known to allchinckley is a name known to allchinckley is a name known to allchinckley is a name known to all
Re: Programming Error

Quote:
Originally Posted by Vikesrock View Post
You likely need to reimage your cRIO with the image installed with Labview Update 3. As I recall the image should be v11.zip

You also should upgrade your DS firmware to the latest version which can be found (along with instructions for updating) here
We have 2009-10a3 on our DS.
Our first program works just fine - just using the joysticks to move the wheels.

When we try to RUN the new version we get this error. We did not want to put the new program on as run at startup because we want to test it for errors.
__________________
2009 West Michigan District Winner
Thanks to Team 216 and Team 1918

2009 Traverse City Semifinalist
Thanks to Team 1596 and Team 47
2009 Traverse City UL Safety Award Winners

Attending 2009: West Michigan, Traverse City, & State
  #4   Spotlight this post!  
Unread 02-24-2009, 05:56 PM
Vikesrock's Avatar
Vikesrock Vikesrock is offline
Team 2175 Founder
AKA: Kevin O'Connor
no team
Team Role: Engineer
 
Join Date: Mar 2006
Rookie Year: 2007
Location: Manchester, NH
Posts: 3,305
Vikesrock has a reputation beyond reputeVikesrock has a reputation beyond reputeVikesrock has a reputation beyond reputeVikesrock has a reputation beyond reputeVikesrock has a reputation beyond reputeVikesrock has a reputation beyond reputeVikesrock has a reputation beyond reputeVikesrock has a reputation beyond reputeVikesrock has a reputation beyond reputeVikesrock has a reputation beyond reputeVikesrock has a reputation beyond repute
Send a message via AIM to Vikesrock Send a message via MSN to Vikesrock Send a message via Yahoo to Vikesrock
Re: Programming Error

The cRIO and the DS have independent firmware. I apologize for suggesting you update your DS, I did not examine the number you posted closely enough.

The latest version of the cRIO firmware is FRC_2009_v11.zip. You can update your cRIO by running the FRC cRIO Imaging Tool. This tool should detect the cRIO automatically and show it in the small window at the top of the tool. If it does do the following to update your cRIO firmware:

1. Select Labview as the "Development Environment". I recommend checking the box to always run deployed code at startup. This will not affect the code that you Run with the white arrow, only code that is deployed.
2. Click the "Format Controller" checkbox.
3. Select FRC_2009_v11.zip as the image.
4. In the Device name box enter "FRC-cRIO-1254" without the quotes
5. Enter your team number in the "Team ID" box.
6. Click Apply. This will start the firmware update, the process will take 5 or more minutes to complete. When it completes it will say that it is successfully updated and you may then click "Close".
7. Turn your robot off, wait ~15 sec., then turn it back on to load the new firmware into the cRIO.

After the cRIO is updated try opening Labview and running your code again. Post back on whether the error is resolved or not.
__________________


2007 Wisconsin Regional Highest Rookie Seed & Regional Finalists (Thanks 930 & 2039)
2008 MN Regional Semifinalists (Thanks 2472 & 1756)
2009 Northstar Regional Semifinalists (Thanks 171 & 525)
  #5   Spotlight this post!  
Unread 02-24-2009, 07:19 PM
Alan Anderson's Avatar
Alan Anderson Alan Anderson is offline
Software Architect
FRC #0045 (TechnoKats)
Team Role: Mentor
 
Join Date: Feb 2004
Rookie Year: 2004
Location: Kokomo, Indiana
Posts: 7,894
Alan Anderson has a reputation beyond reputeAlan Anderson has a reputation beyond reputeAlan Anderson has a reputation beyond reputeAlan Anderson has a reputation beyond reputeAlan Anderson has a reputation beyond reputeAlan Anderson has a reputation beyond reputeAlan Anderson has a reputation beyond reputeAlan Anderson has a reputation beyond reputeAlan Anderson has a reputation beyond reputeAlan Anderson has a reputation beyond reputeAlan Anderson has a reputation beyond repute
Send a message via AIM to Alan Anderson
Re: Programming Error

You're not accidentally trying to run the code on your PC rather than on the cRIO, are you? Make sure the VI is under the correct target in your project.
  #6   Spotlight this post!  
Unread 02-25-2009, 10:35 AM
chinckley chinckley is offline
Winner 2009 West Michigan District
FRC #1254 (Entropy)
Team Role: Teacher
 
Join Date: Jan 2005
Rookie Year: 2003
Location: Lawrence, Michigan
Posts: 204
chinckley is a name known to allchinckley is a name known to allchinckley is a name known to allchinckley is a name known to allchinckley is a name known to allchinckley is a name known to all
Question Re: Programming Error

Okay, so now we are having more trouble.

We reimaged the cRIO and that had no effect. The behavior was the same as before.

Then we loaded a different VI it deployed, but then nothing worked.
When we power cycle the robot the previous program does not come up.
Isn't there supposed to be a default code?

By deploying a VI is it possible to overwrite the non-volitile memory?

Help, we leave for TC tomorrow AM.



UPDATE: 11:02 am

We got it back so it runs the code we had in there that just uses 2 joystick to
run the wheels in tank mode.

We cannot get it to accept the new program which does that as well as runs
our chain and dumper.

HELP? Please.
__________________
2009 West Michigan District Winner
Thanks to Team 216 and Team 1918

2009 Traverse City Semifinalist
Thanks to Team 1596 and Team 47
2009 Traverse City UL Safety Award Winners

Attending 2009: West Michigan, Traverse City, & State

Last edited by chinckley : 02-25-2009 at 11:04 AM. Reason: typos & update
  #7   Spotlight this post!  
Unread 02-25-2009, 11:28 AM
chinckley chinckley is offline
Winner 2009 West Michigan District
FRC #1254 (Entropy)
Team Role: Teacher
 
Join Date: Jan 2005
Rookie Year: 2003
Location: Lawrence, Michigan
Posts: 204
chinckley is a name known to allchinckley is a name known to allchinckley is a name known to allchinckley is a name known to allchinckley is a name known to allchinckley is a name known to all
Re: Programming Error

We are able we think to deploy another program -
it gives many pages of output and the last line it gives us is:

deploy send images to PC.vi

Did it finish?

The orange light and the jaguars are still flashing and we cannot run the joysticks.
__________________
2009 West Michigan District Winner
Thanks to Team 216 and Team 1918

2009 Traverse City Semifinalist
Thanks to Team 1596 and Team 47
2009 Traverse City UL Safety Award Winners

Attending 2009: West Michigan, Traverse City, & State
  #8   Spotlight this post!  
Unread 02-25-2009, 11:36 AM
Mark McLeod's Avatar
Mark McLeod Mark McLeod is online now
Itinerant Programmer
AKA: Hey dad...Father...MARK
FRC #0358 (Robotic Eagles)
Team Role: Engineer
 
Join Date: Mar 2003
Rookie Year: 2002
Location: Hauppauge, Long Island, NY
Posts: 7,404
Mark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond repute
Re: Programming Error

Not enough information to tell.
What is PC.vi for instance? Are you streaming camera video back to your PC?
What is the many pages of output?
How do the pages of output differ from downloading your first program that just has the joysticks?

What are the buttons and menu choices you are making to download your program?
Are you using "run as startup" from the Project Explorer Build Specifications?

If you post a zip of your project that fails to download we might be able to help.
__________________
Deduction is limited by knowledge, and knowledge is limited by preconceptions
358 Beta notes & results

Last edited by Mark McLeod : 02-25-2009 at 11:44 AM.
  #9   Spotlight this post!  
Unread 02-25-2009, 11:53 AM
chinckley chinckley is offline
Winner 2009 West Michigan District
FRC #1254 (Entropy)
Team Role: Teacher
 
Join Date: Jan 2005
Rookie Year: 2003
Location: Lawrence, Michigan
Posts: 204
chinckley is a name known to allchinckley is a name known to allchinckley is a name known to allchinckley is a name known to allchinckley is a name known to allchinckley is a name known to all
Re: Programming Error

Quote:
Originally Posted by Mark McLeod View Post
Not enough information to tell.
What is PC.vi for instance? Are you streaming camera video back to your PC?
What is the many pages of output?
How do the pages of output differ from downloading your first program that just has the joysticks?

What are the buttons and menu choices you are making to download your program?
Are you using "run as startup" from the Project Explorer Build Specifications?

If you post a zip of your project that fails to download we might be able to help.

See error file:
We get this and then it goes through and it loads 100’s of vi’s.
We press okay and then it appears to have deployed but then the robot is not responsive.

This is just joystick tank drive only, but we get the same error when we run the
program with the dumper.

All we are doing is trying to get a program onto the cRIO.

We have followed the directions step by step

We have reimaged the cRIO also and it did not change the behavior.
Attached Files
File Type: doc error 2-25-09 a.doc (103.0 KB, 51 views)
__________________
2009 West Michigan District Winner
Thanks to Team 216 and Team 1918

2009 Traverse City Semifinalist
Thanks to Team 1596 and Team 47
2009 Traverse City UL Safety Award Winners

Attending 2009: West Michigan, Traverse City, & State

Last edited by chinckley : 02-25-2009 at 12:07 PM.
  #10   Spotlight this post!  
Unread 02-25-2009, 11:57 AM
chinckley chinckley is offline
Winner 2009 West Michigan District
FRC #1254 (Entropy)
Team Role: Teacher
 
Join Date: Jan 2005
Rookie Year: 2003
Location: Lawrence, Michigan
Posts: 204
chinckley is a name known to allchinckley is a name known to allchinckley is a name known to allchinckley is a name known to allchinckley is a name known to allchinckley is a name known to all
Re: Programming Error

If you "run as startup" and it does not work can you get back to the one that worked or has it overwritten non-volitile memory?
__________________
2009 West Michigan District Winner
Thanks to Team 216 and Team 1918

2009 Traverse City Semifinalist
Thanks to Team 1596 and Team 47
2009 Traverse City UL Safety Award Winners

Attending 2009: West Michigan, Traverse City, & State

Last edited by chinckley : 02-25-2009 at 12:19 PM.
  #11   Spotlight this post!  
Unread 02-25-2009, 12:20 PM
chinckley chinckley is offline
Winner 2009 West Michigan District
FRC #1254 (Entropy)
Team Role: Teacher
 
Join Date: Jan 2005
Rookie Year: 2003
Location: Lawrence, Michigan
Posts: 204
chinckley is a name known to allchinckley is a name known to allchinckley is a name known to allchinckley is a name known to allchinckley is a name known to allchinckley is a name known to all
Re: Programming Error

Here is the step by step process we used and where the error appeared.
Attached Files
File Type: doc Procedure followed to deploy VI.doc (738.0 KB, 33 views)
__________________
2009 West Michigan District Winner
Thanks to Team 216 and Team 1918

2009 Traverse City Semifinalist
Thanks to Team 1596 and Team 47
2009 Traverse City UL Safety Award Winners

Attending 2009: West Michigan, Traverse City, & State
  #12   Spotlight this post!  
Unread 02-25-2009, 12:21 PM
Mark McLeod's Avatar
Mark McLeod Mark McLeod is online now
Itinerant Programmer
AKA: Hey dad...Father...MARK
FRC #0358 (Robotic Eagles)
Team Role: Engineer
 
Join Date: Mar 2003
Rookie Year: 2002
Location: Hauppauge, Long Island, NY
Posts: 7,404
Mark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond repute
Re: Programming Error

I see you're just using the Tank Drive Example project.
Did you create a new project after the last Update 3a was installed?

P.S. I note that in the second procedure you're using the Basic Framework.

The pop-up window with the warning messages is normal and can be ignored. Every LabVIEW program will download 100's of vi's, so that's normal too.

"run as startup" means this is the program that will run when the robot is turned on. So it would replace the default project.

Just pushing the "Run" or "Run Continuous" arrows on the top-level vi will only be temporary and won't be around after the robot gets reset or power cycled. I assume this is what you want to do, so that's okay.

So using "Run" you get "No Code" displayed on the Driver Station?
Do you let it sit for a few minutes after you see "No code"?
You will get "No code" for a brief period after the cRIO resets or is started, but then if you're restarting the cRIO then you wouldn't get to see your program running anyway.
__________________
Deduction is limited by knowledge, and knowledge is limited by preconceptions
358 Beta notes & results

Last edited by Mark McLeod : 02-25-2009 at 12:28 PM.
  #13   Spotlight this post!  
Unread 02-25-2009, 12:27 PM
chinckley chinckley is offline
Winner 2009 West Michigan District
FRC #1254 (Entropy)
Team Role: Teacher
 
Join Date: Jan 2005
Rookie Year: 2003
Location: Lawrence, Michigan
Posts: 204
chinckley is a name known to allchinckley is a name known to allchinckley is a name known to allchinckley is a name known to allchinckley is a name known to allchinckley is a name known to all
Re: Programming Error

Quote:
Originally Posted by Mark McLeod View Post
I see you're just using the Tank Drive Example project.
Did you create a new project after the last Update 3a was installed?
We did create one, but we get the same thing. We get the deployment conflict warning and if you proceed past that by pressing the OK button then it deploys 100's of vi's and the robot no longer works.

The pop-up window with the warning messages is normal and can be ignored. Every LabVIEW program will download 100's of vi's, so that's normal too.

"run as startup" means this is the program that will run when the robot is turned on. So it would replace the default project.

Just pushing the "Run" or "Run Continuous" arrows on the top-level vi will only be temporary and on't be around after the robot gets reset or power cycled. I assume this is what you want to do, so that's okay. YES

So using "Run" you get "No Code" displayed on the Driver Station?
Do you let it sit for a few minutes after you see "No code"? yes
You will get "No code" for a brief period after the cRIO resets or is started, but then if you're restarting the cRIO then you wouldn't get to see your program running anyway.
Thanks
__________________
2009 West Michigan District Winner
Thanks to Team 216 and Team 1918

2009 Traverse City Semifinalist
Thanks to Team 1596 and Team 47
2009 Traverse City UL Safety Award Winners

Attending 2009: West Michigan, Traverse City, & State
  #14   Spotlight this post!  
Unread 02-25-2009, 12:38 PM
Mark McLeod's Avatar
Mark McLeod Mark McLeod is online now
Itinerant Programmer
AKA: Hey dad...Father...MARK
FRC #0358 (Robotic Eagles)
Team Role: Engineer
 
Join Date: Mar 2003
Rookie Year: 2002
Location: Hauppauge, Long Island, NY
Posts: 7,404
Mark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond repute
Re: Programming Error

The "Run" button turns black and stays that way?

Do the controls on your Robot Main.vi Front Panel respond?

I'll be back in a few minutes. I have to get a root canal done...
__________________
Deduction is limited by knowledge, and knowledge is limited by preconceptions
358 Beta notes & results
  #15   Spotlight this post!  
Unread 02-25-2009, 12:51 PM
chinckley chinckley is offline
Winner 2009 West Michigan District
FRC #1254 (Entropy)
Team Role: Teacher
 
Join Date: Jan 2005
Rookie Year: 2003
Location: Lawrence, Michigan
Posts: 204
chinckley is a name known to allchinckley is a name known to allchinckley is a name known to allchinckley is a name known to allchinckley is a name known to allchinckley is a name known to all
Re: Programming Error

Quote:
Originally Posted by Mark McLeod View Post
The "Run" button turns black and stays that way? No it does not stay that way.

Do the controls on your Robot Main.vi Front Panel respond? How do we tell?


I'll be back in a few minutes. I have to get a root canal done...

Yuck...
Thanks
__________________
2009 West Michigan District Winner
Thanks to Team 216 and Team 1918

2009 Traverse City Semifinalist
Thanks to Team 1596 and Team 47
2009 Traverse City UL Safety Award Winners

Attending 2009: West Michigan, Traverse City, & State

Last edited by chinckley : 02-25-2009 at 01:07 PM.
Closed Thread


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Code error causing robot to go into programming mode. MJD Programming 14 10-30-2007 02:21 PM
CMU / RC / programming error N7UJJ Programming 3 02-18-2005 05:05 PM
yet another programming error hawk_11 Programming 2 02-13-2005 03:57 PM
programming error agenova Programming 1 02-20-2002 01:00 PM


All times are GMT -5. The time now is 03:31 PM.

The Chief Delphi Forums are sponsored by Innovation First International, Inc.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright © Chief Delphi