Go to Post Designing for failure tends to encourage failure. Worrying about failure analysis during the competition can become a self fulfilling prophesy. Break your pots in the fall and learn how to keep them from breaking. - Mike Betts [more]
Home
Go Back   Chief Delphi > Technical > Programming
CD-Events   CD-Media   CD-Spy   FRC-Spy  
portal register members calendar search Today's Posts Mark Forums Read FAQ rules

 
Closed Thread
Thread Tools Rate Thread Display Modes
  #1   Spotlight this post!  
Unread 03-01-2004, 10:16 PM
JBabbie's Avatar
JBabbie JBabbie is offline
Registered User
#0201
 
Join Date: Mar 2004
Location: Michigan
Posts: 10
JBabbie is on a distinguished road
Question program light blinks red and green

I can upload my code just fine and everything works , but when the robot controller is turned off the program light of the robot controller blinks green and red and the robot will not work until I upload my code again... I thought it might have been a board problem , but my team has built 2 robots so we can practice prior to competition and I get the same problem and i have NO IDEA as to what could be causing the problem , could some one help me out please?
  #2   Spotlight this post!  
Unread 03-01-2004, 10:25 PM
Anthony Kesich's Avatar
Anthony Kesich Anthony Kesich is offline
Programmer Turned Engineer
AKA: SonKenshin
#1097 (Site 3 Engineernig)
Team Role: Leadership
 
Join Date: Jan 2003
Rookie Year: 2003
Location: Sacramento, CA
Posts: 186
Anthony Kesich has a spectacular aura aboutAnthony Kesich has a spectacular aura about
Send a message via AIM to Anthony Kesich
Re: program light blinks red and green

hrmm, strange. I'm assuming you have already tried the forced reset from update number 7 and loding the default code to see if it does the same thing and have updated the firmware. If not, try them, they do wonders. If that doesn't work, I don't know what to say. Is there anything tricky you're doing with the code? Try e-mailing FIRST with your problem and a copy of the source code, they might be able to help you out a lot more than I can. Sorry.

-Kesich
__________________
C is screwing up my English--I'm ending all my sentences in semi-colons;

Horray for most things! -George Carlin

"Sure, I'll play rugby. Besides, I have a lot of experience running from really big guys who want to cream me." -Me, Freshman year
  #3   Spotlight this post!  
Unread 03-02-2004, 06:34 AM
Astronouth7303's Avatar
Astronouth7303 Astronouth7303 is offline
An inspired alumnus
AKA: Jamie Bliss
no team (previously 904 (D-cubed) and 1227 (Techno-Gremlins))
Team Role: Alumni
 
Join Date: Jan 2004
Rookie Year: 2004
Location: Grand Rapids, MI
Posts: 2,071
Astronouth7303 has much to be proud ofAstronouth7303 has much to be proud ofAstronouth7303 has much to be proud ofAstronouth7303 has much to be proud ofAstronouth7303 has much to be proud ofAstronouth7303 has much to be proud ofAstronouth7303 has much to be proud ofAstronouth7303 has much to be proud ofAstronouth7303 has much to be proud ofAstronouth7303 has much to be proud of
Send a message via ICQ to Astronouth7303 Send a message via AIM to Astronouth7303 Send a message via MSN to Astronouth7303 Send a message via Yahoo to Astronouth7303
Re: program light blinks red and green

Not to mention the new IFI_Loader. Both of us got the same problem. Mine was related to an infinate loop.
  #4   Spotlight this post!  
Unread 03-02-2004, 08:19 AM
Ryan M. Ryan M. is offline
Programming User
FRC #1317 (Digital Fusion)
Team Role: Programmer
 
Join Date: Jan 2004
Rookie Year: 2004
Location: Ohio
Posts: 1,508
Ryan M. has much to be proud ofRyan M. has much to be proud ofRyan M. has much to be proud ofRyan M. has much to be proud ofRyan M. has much to be proud ofRyan M. has much to be proud ofRyan M. has much to be proud ofRyan M. has much to be proud ofRyan M. has much to be proud of
Re: program light blinks red and green

Quote:
Originally Posted by Astronouth7303
Not to mention the new IFI_Loader. Both of us got the same problem. Mine was related to an infinate loop.
Glad you solved your problem, Astronouth.

Try uploading the default code to see if it does the same thing. That will tell you if it is a problem with your code.
__________________

Closed Thread


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Red + Green LEDs on OI Ryan Cumings Control System 4 02-29-2004 05:50 PM
Red, Blue and Green Signs....HELP!!! ssjspawn Off-Season Events 3 11-17-2001 04:10 AM


All times are GMT -5. The time now is 04:38 AM.

The Chief Delphi Forums are sponsored by Innovation First International, Inc.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright © Chief Delphi