OCCRA
Go to Post A person is not defined by what mistakes they make, but more so by what they do after they realize their mistake. - Andy Baker [more]
Home
Go Back   Chief Delphi > Technical > Programming
CD-Events   CD-Media   CD-Spy   FRC-Spy  
portal register members calendar search Today's Posts Mark Forums Read FAQ rules

 
Closed Thread
Thread Tools Rate Thread Display Modes
  #1   Spotlight this post!  
Unread 12-08-2007, 09:45 PM
Robostang 548's Avatar
Robostang 548 Robostang 548 is offline
I can program the future...
AKA: Don
FRC #0548 (Robostangs)
Team Role: Programmer
 
Join Date: Jan 2007
Rookie Year: 2006
Location: Northville Mi
Posts: 69
Robostang 548 is on a distinguished road
Send a message via AIM to Robostang 548 Send a message via MSN to Robostang 548 Send a message via Yahoo to Robostang 548
IFI loader problems

Hi,

I have been having some trouble with the ifi_loader and the "No robot found" error. I took my teams 2006 controller home over the summer and used IFI_Loader on my old laptop (300mhz compaq presario) and had no problems. In the fall I bought my new laptop and got a usb to serial converter. I had only loaded about 2 .hex files on both our 2007 and 2006 controler. When I loaded those 2 .hex files, I noticed that the .hex files loaded a lot slower than on my old laptop (probably becuase of the converter). Today my team met to teach our new members programming and such. We went to program the robot using my laptop and the first time it loaded (incredibly slow though) but after that, even when we were sure that the cables were connected and that we were in program state, it refused to load the .hex file and kept raising the "No robot found" error. We pressed the reset button then opened a terminal window to find that we were indeed connected because we were reciving items we had set to printf to the program port. So we put it into program state but it kept raising the same error. We tried programming the 2006 controller to have it raise the error some of the time but we could get 1 or 2 .hex files to load. I havent tried loading the program from another pc or from one that has a built in serial port. I tried some of the methods in this thread http://www.chiefdelphi.com/forums/showthread.php?t=44024&highlight=ifi_loader+proble m. One method in the above thread about holding down the prog and reset buttons for a certain time did begin to work. But the resolution to the problem in the above thread was faulty soldering with the program port as determined by IFI, but I dont think that is the problem I have. Any Ideas would be greatly appreciated. My thory is that because I am using the converter and because the converter increases load time, maybe IFI_Loader is timing out when trying to establish a link with the RC.

-Don
__________________

Team 548:
Attending National Championship, Genesee District, Detroit District 2, West Michigan District, Michigan Championship?


  #2   Spotlight this post!  
Unread 12-09-2007, 04:44 AM
Unsung FIRST Hero
Mike Betts Mike Betts is offline
Electrical Engineer
no team
Team Role: Engineer
 
Join Date: Dec 2001
Rookie Year: 1995
Location: Homosassa, FL
Posts: 1,443
Mike Betts has a reputation beyond reputeMike Betts has a reputation beyond reputeMike Betts has a reputation beyond reputeMike Betts has a reputation beyond reputeMike Betts has a reputation beyond reputeMike Betts has a reputation beyond reputeMike Betts has a reputation beyond reputeMike Betts has a reputation beyond reputeMike Betts has a reputation beyond reputeMike Betts has a reputation beyond reputeMike Betts has a reputation beyond repute
Re: IFI loader problems

Don,

Because there are thousands of FRC and FTC teams out there downloading code, I'm going to go out on a limb and guess that the problem is with your converter or its drivers.

We use Bafo BF810 converters and have never had an issue. Also if you have a VEX team, the orange cable used to program the VEX controllers comes apart and one half is a USB/serial converter (sold separately by Radio Shack). In fact, since both converters use the same Prolific IC chip, they are interchangeable once either drivers are installed.

Mike
__________________
Mike Betts

Alumnus, Team 3518, Panthrobots, 2011
Alumnus, Team 177, Bobcat Robotics, 1995 - 2010
LRI, Connecticut Regional, 2007-2010
LRI, WPI Regional, 2009 - 2010
RI, South Florida Regional, 2012 - 2013

As easy as 355/113...
  #3   Spotlight this post!  
Unread 12-09-2007, 07:28 AM
Robostang 548's Avatar
Robostang 548 Robostang 548 is offline
I can program the future...
AKA: Don
FRC #0548 (Robostangs)
Team Role: Programmer
 
Join Date: Jan 2007
Rookie Year: 2006
Location: Northville Mi
Posts: 69
Robostang 548 is on a distinguished road
Send a message via AIM to Robostang 548 Send a message via MSN to Robostang 548 Send a message via Yahoo to Robostang 548
Re: IFI loader problems

Quote:
since both converters use the same Prolific IC chip, they are interchangeable once either drivers are installed.
The conveter I am using is just a generic made in china usb to serial converter but I know from looking at the manual and the driver that it uses the Prolific chip so it should be working the same as yours. Do you notice a slower download time when you use your converter?
__________________

Team 548:
Attending National Championship, Genesee District, Detroit District 2, West Michigan District, Michigan Championship?


  #4   Spotlight this post!  
Unread 12-09-2007, 09:26 AM
ebarker's Avatar
ebarker ebarker is online now
Registered User
AKA: Ed Barker
FRC #1311 (Kell Robotics)
Team Role: Mentor
 
Join Date: Jan 2006
Rookie Year: 2006
Location: Kennesaw GA
Posts: 1,331
ebarker has a reputation beyond reputeebarker has a reputation beyond reputeebarker has a reputation beyond reputeebarker has a reputation beyond reputeebarker has a reputation beyond reputeebarker has a reputation beyond reputeebarker has a reputation beyond reputeebarker has a reputation beyond reputeebarker has a reputation beyond reputeebarker has a reputation beyond reputeebarker has a reputation beyond repute
Re: IFI loader problems

I use usb-serial cables for software development all day every day and I pretty much refuse to use the ones with the Prolific chipset. It has too many issues, and can bust the usb protocol stack in the pc which requires rebooting to repair. Other issues are very slow code downloads and more.

The FTDI chipset seems to work like a charm. The cables using this chipset are little harder to find in the US but I did a quick google and came up with this.

http://compusb.stores.yahoo.net/usbtoseadfor.html

http://cgi.ebay.com/USB-to-Serial-Ad...QQcmdZViewItem
__________________
Ed Barker
  #5   Spotlight this post!  
Unread 12-10-2007, 05:01 PM
popo308's Avatar
popo308 popo308 is offline
Registered User
AKA: Brent
FRC #1625 (Winnovation)
Team Role: Alumni
 
Join Date: Jan 2007
Rookie Year: 2006
Location: Winnebago, IL
Posts: 312
popo308 is a name known to allpopo308 is a name known to allpopo308 is a name known to allpopo308 is a name known to allpopo308 is a name known to allpopo308 is a name known to all
Send a message via AIM to popo308
Re: IFI loader problems

Are team had the same issue and we had to hit the upload code button on the PC then while it is trying to upload/find the robot you need to hold down the program button on the robot.

If that does not work have you tried UBER-PROGRAM-MODE!!!!!!!!!

Before you power on the robot hold down the program button. Keep your program button pressed down and turn on you robot. Keep it held down for 5 seconds after that. You should have a main power light on and a program light on. It should be in UBER-PROGRAM-MODE!!! Try uploading the code again let me know if this works for you.
Closed Thread


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
IFI Loader problems Hieb Programming 3 01-18-2005 12:45 PM
IFI Loader problems billstu Programming 22 03-23-2004 10:39 AM
IFI Loader Problems lasindi Programming 6 02-05-2004 05:06 AM
IFI Loader Keys Programming 6 02-02-2004 01:37 PM
IFI Loader Problems BrendaB Programming 3 01-24-2004 09:45 PM


All times are GMT -5. The time now is 01:13 PM.

The Chief Delphi Forums are sponsored by Innovation First International, Inc.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright © Chief Delphi