Go to Post It moves so smoothly because it is magic. - dtengineering [more]
Home
Go Back   Chief Delphi > Technical > Programming > NI LabVIEW
CD-Events   CD-Media   CD-Spy   FRC-Spy  
portal register members calendar search Today's Posts Mark Forums Read FAQ rules

 
Reply
Thread Tools Rate Thread Display Modes
  #1   Spotlight this post!  
Unread 02-12-2010, 04:24 PM
3195mentor 3195mentor is offline
I'm the original L337 N1nj4!
AKA: Jason
FRC #3195 (RoboNinjas)
Team Role: Coach
 
Join Date: Jan 2010
Rookie Year: 2002
Location: San Diego
Posts: 23
3195mentor has a spectacular aura about3195mentor has a spectacular aura about3195mentor has a spectacular aura about
Thumbs up "No Robot Code" error? plus other issues... (Resolved)

we've tried uploading the program to our cRio, however whenever we go to the driver station, we still see the "Robot Code" LED as red. it's not detecting our robot code even after deployment, any idea why?

we followed the video tutorial here:
http://decibel.ni.com/content/docs/DOC-3014

also, i don't know if this is related to the coding problem, but our motor controllers are not responding what so ever. we've tried both the victor and jaguar motors and both are responding the same way (just blinking, no change in pattern).

any help on this is appreciated.

--- we are using Labview; already updated firmware / driver + labview to latest. ---


**UPDATE** Issue has been resolved. see below for our ("oh duh" moment) resolution

Last edited by 3195mentor : 02-12-2010 at 11:18 PM. Reason: issues were resolved! woohoo!
Reply With Quote
  #2   Spotlight this post!  
Unread 02-12-2010, 05:52 PM
Greg McKaskle Greg McKaskle is offline
Registered User
no team (Team NI)
 
Join Date: Apr 2008
Rookie Year: 2008
Location: Austin, TX
Posts: 3,896
Greg McKaskle has a reputation beyond reputeGreg McKaskle has a reputation beyond reputeGreg McKaskle has a reputation beyond reputeGreg McKaskle has a reputation beyond reputeGreg McKaskle has a reputation beyond reputeGreg McKaskle has a reputation beyond reputeGreg McKaskle has a reputation beyond reputeGreg McKaskle has a reputation beyond reputeGreg McKaskle has a reputation beyond reputeGreg McKaskle has a reputation beyond reputeGreg McKaskle has a reputation beyond repute
Re: "No Robot Code" error? plus other issues...

I didn't watch the tutorial, but there are two ways of getting code on the robot. For development, I'd recommend hitting the run arrow on the RobotMain VI. It will put up a dialog listing the work to do and any issues it runs into.

To put the code onto the robot for a competition, once you know your code works, you deploy and set the App as startup. You may not be doing the second step. Also, it should state that it needs to reboot the cRIO. You don't mention that step, so perhaps you are only deploying.

Greg McKaskle
Reply With Quote
  #3   Spotlight this post!  
Unread 02-12-2010, 11:17 PM
3195mentor 3195mentor is offline
I'm the original L337 N1nj4!
AKA: Jason
FRC #3195 (RoboNinjas)
Team Role: Coach
 
Join Date: Jan 2010
Rookie Year: 2002
Location: San Diego
Posts: 23
3195mentor has a spectacular aura about3195mentor has a spectacular aura about3195mentor has a spectacular aura about
Lightbulb Re: "No Robot Code" error? plus other issues... (RESOLVED)

Apparently the issue was the driver station...

nowhere in the documentation (at least that i could find) did it state that you had to run the driver station program along side the debugger/compiler... (start / all programs / FRC driver station). i was under the impression it would work by just hitting the little arrow button in the compiler when hooked directly to the cRio (little did i know...)

everything works now. got the code working (with a few changes between the tutorial's beta version and the most recent version). it's a very VERY basic program for just tank-drive movement... if any other rookie teams (who are still struggling with the coding in labview) want a copy of our template, just email me (see below) and i'll post a copy on here and / or email it to you.

Last edited by 3195mentor : 02-12-2010 at 11:19 PM.
Reply With Quote
  #4   Spotlight this post!  
Unread 02-13-2010, 07:20 AM
Alan Anderson's Avatar
Alan Anderson Alan Anderson is offline
Software Architect
FRC #0045 (TechnoKats)
Team Role: Mentor
 
Join Date: Feb 2004
Rookie Year: 2004
Location: Kokomo, Indiana
Posts: 7,734
Alan Anderson has a reputation beyond reputeAlan Anderson has a reputation beyond reputeAlan Anderson has a reputation beyond reputeAlan Anderson has a reputation beyond reputeAlan Anderson has a reputation beyond reputeAlan Anderson has a reputation beyond reputeAlan Anderson has a reputation beyond reputeAlan Anderson has a reputation beyond reputeAlan Anderson has a reputation beyond reputeAlan Anderson has a reputation beyond reputeAlan Anderson has a reputation beyond repute
Send a message via AIM to Alan Anderson
Re: "No Robot Code" error? plus other issues...

Your original post said the "Robot Code" LED was red, so we naturally assumed you were running the Driver Station application. If you hadn't given that indication, you would quickly have been advised to run it exactly the way you figured out.
Reply With Quote
Reply


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Error "IFI>Master Code Version: 8 " mecanumbot Programming 0 01-24-2010 12:30 AM
"Code Error" with RegisterRepeatingTimer d235j Programming 4 02-27-2008 08:51 PM
Persistent "no robot controller found" error 1594code Programming 12 02-20-2006 07:59 PM
Screenshot of "code not understood" or similar error needed! Elgin Clock Programming 3 02-17-2006 09:06 PM
Code error on RC after downloading "bells and whistles" version of Kevins camera code DanDon Programming 6 01-10-2006 05:07 PM


All times are GMT -5. The time now is 09:02 PM.

The Chief Delphi Forums are sponsored by Innovation First International, Inc.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright © Chief Delphi