View Full Version : Jerking Motors-Wireless Issues

02-15-2012, 05:05 PM
We have been having a problem with our Black Jaguar motors. When we move the controller forward the motors turn on and spin the wheels but whenever the motors move it is as if the signal is sporadic and constantly turning on and off. We think it might be the wireless because we connected our classmate (laptop) with an Ethernet cable straight to the C-Rio and there were no issues.

Mark McLeod
02-15-2012, 05:37 PM
A radio reset takes a full minute, so if it's cutting in and out quickly, then it isn't the radio power.
I'd suspect that the wireless is intermittent because of conflicts and collisions with other wireless networks in the area.

You can try setting the DLink to different channels to see if that clears it up.

Tom Line
02-15-2012, 08:20 PM
Another thing to check is the diagnostics tab on your driver station. Look at the error messages being generated. You may have improperly programmed your robot and the loops may be running too slowly.

02-15-2012, 11:16 PM
What colors are the Jaguar LEDs turning when the motors stop moving?

You could be triggering the built in over current protection, which will shut off current if the motors are drawing too much of it.

02-16-2012, 10:06 AM
One issue you might have is in the program if you are using else statements and have the same motors in different ones than it will cause these sporadic readings you are talking about.

02-16-2012, 10:12 AM
yeah depending on how much CPU the rio is using

02-16-2012, 11:57 AM
When one of my teams first got their drivetrain going it worked flawlessly. When they powered down the robot and switched the victors into brake mode, it powered back up and we had a similar problem as described. We powered it down and switched the victors back into coast and the problem dissappeared. Then we left the system powered on and switched back to brake mode and the problem dissapeared. We have never had a problem since. No idea what it was but this is how we fixed it?

02-16-2012, 12:23 PM
We saw something similar. Turned out that the converter for the DLink was not plugged into the clean power outlet on the Power Distribution board. When the motors are running the 12 volt on the PD gets enough noise on it to cause problems with the radio.
Hope this helps.