View Full Version : Basic Init Error

12-13-2002, 06:52 AM
We slightly changed our code and tried to download it to the robot controller. However, the "Basic Init Error Indicator" light is on after I press the "reset" button. When we tried to download our original code and the default one (obtained from the web), the light is still on. I don't know what .

The laptop we are using is a replacement of the one we used before, with OS changing from Win 95 to Win 2000. I am wondering if this is the problem.

Please advise what we should do....


Matt Reiland
12-13-2002, 07:16 AM
I am thinking back here to memory but I thought that the basic init error had to do with you not having the correct variables declared for transmission matching the Serin command, for further help maybe you could either post your file or at least the section up until the user area and we should be able to help.

I use both Windows 2000 and 95/98 and that never had any problems.

12-13-2002, 07:19 AM
Check the SERIN and SEROUT commands to make sure they're set up properly. There is a long list of constants immediately before the SERIN command that tell the processor which inputs to grab. Set them to 1 if you want to use them, 0 if you don't. The SERIN command should only include the variables that have the corresponding constant set to 1, in the order specified in the code comments.

So make sure that the SERIN command has the same number of parameters as config constants that have been set to 1. Yeah, its confusing.

Joe Ross
12-13-2002, 07:31 AM
First of all, is this on the EDU bot or a previous year's robot?

In my (and most people's experience), the basic init error is caused by an error either in the serout or serin command, and the initialization section. However, you say that you have used the default code too. That makes me think that there is something else that is the problem.

Like Matt, I've used Windows 2000 before with no problems.

12-13-2002, 12:31 PM
I have also found with the Edubot that the motherboard can become slightly separated from the black box with the processor in it. In my case simply pushing the two back together made the basic Init error go away.


12-14-2002, 12:10 PM
I remember a similar problem. We were short a serial cable, and had to use a tether for programming, and sometimes we also got a Basic Init Error. All we did was turn off the robot, turn off the OI, push the cables in a little harder, turn both on, and pray. If it didn't work, rinse and repeat. When we went back to using the radios, everything was just fine.