View Full Version : Downloading Code with new Editor

01-16-2003, 11:01 PM
Has anyone had problems downloading code from the new editor to the 2003 controller. About 80% of the time the computer does not find the BS2SX. We have tried swapping the cables, rebooting the computer and power cycling the RC before downloading. Nothing seems to help. It seems to randomly work about 20% of the time. Anyone have any ideas?

01-16-2003, 11:20 PM
I've only had one opportunity to try to use the new editor with any actual hardware, and it never failed to alert me to the painful fact that it couldn't find a Basic Stamp...

I should start troubleshooting this, but if anyone has any specific solutions, I'd be much grateful, as well.

Kevin Watson
01-16-2003, 11:39 PM
I've seen this with BASIC stamps before. The problem was with the type of RS-232 transceiver the computer had. Some newer computers (especially laptops) have transceivers that don't swing the minimum voltage range of 10 volts that the RS-232 specification specifies. You might try a different (older) computer to get it to work (this is what I did).


01-16-2003, 11:48 PM
While I am using a laptop, it is by no means new (75 Mhz 486) :(

I never had a problem last year. When I first downloaded the new editor, I tried it on a 2001 controller that we use for our prototyping. It did not recognize the controller that I prototyped with all last year and this fall. I figured that the new editor and the old controller were incompatible. The first time I downloaded the 2003 controller from the new editor it worked. Since then it has been 20% success at best :(

01-17-2003, 12:10 AM
I used to have this problem when I had the 2002 RC tethered... it would never detect the RC properly. The problem seemed to go away when I removed the tether when attempting to upload the program.