View Full Version : BrickOS problems

02-11-2006, 10:35 PM
Hey, i don't know if this is the right spot for this so if it is feel free to move it. but heres my delima. i'm operating off of a linux system (Ubuntu 5.04 Hoary Hedgehog) and i downloaded BrickOS-0.9.0 and all of the stuff it needs (gcc-h8300-hms- and i was able to download the firmware using
$ firmdl3 /usr/local/lib/brickos/brickOS.srec
but then i try to use dll and it doesn't work, so heres everything that i typed and the result from dll in verbose mode

$ cd /programs/BrickOS/brickos-0.9.0/demo
$ make
$ dll -v helloworld.lx

C.P. Chan & Tyler Akins - USB IR Tower Mode for Linux.
opening tty...

LNP Initialized...
loader hostaddr=0x00 hostmask=0xf0 portmask=0x00

#time 2939359759 00 try 0: ack:0
try 1: ack:0
try 2: ack:0
try 3: ack:0
try 4: ack:0
error deleting program

when i do this the light turns on on the IR tower but i don't see anything happening on the RCX. and i was able to download the firmware so i know that it isn't a hardware problem

i've looked all over the forums and haven't found my answer, so i decided to post one. i would greatly appriciate your input.

02-12-2006, 12:43 AM
It has been a year since I have worked with BrickOS so I don't know the exact details. You may want to check the flags you can set on the dll program there may be some options there which can help. I noticed you already use the -v flag which is helpful. Another flag I remember helping us was the speed or rate of transer. Sometimes the baud rate you are running at could cause a problem if you are running too fast for your tower.

Another issue I barely remember has something to do with BrickOS and when you install it if the options are slightly wrong you won't be able to communicate with it through the tower. I hope this information helps.

02-12-2006, 08:59 PM
ok thanks for the input, i also followed the instructions in the readme.usb file and entered in

$ sudo mknod /dev/usb/legotower0 c 180 160
$ sudo chmod 666 /dev/usb/legotower0

and it made it so that the time was there (#time 2939359759 00 try 0: ack:0) before i used those commands all i got was #deletetry 0: ack:0 but the system recognized the tower it said that it was /dev/usb/legousbtower0 where as after i typed in $ sudo mknod /dev/usb.... then i had two legotower0 and legousbtower0

so i'll play around with it a little more and will look into changing the baud rate.

03-02-2006, 10:41 PM
Man I wish you could help you out here. But my knowledge is center more on the design of a lego bot. Have you tried Robo lab by any chance? I may not be a programer but I have heard many recomendations on Robolab.

03-02-2006, 11:08 PM
ya i looked into that, but my problem is that i need an OS that can support decimals, and i'm pretty sure that robolab doesn't. BrickOS was the only one i could find taht supported decimals. you see, i need decimals because i'm trying to make the robot ballance an inverted pendulum, and to do this you need to find velocitys, which most of the time are decimals. and i just can't multiply the velocity by 100 because once it devides D/T it already rounds it. so thats why i need to go with BrickOS.

11-12-2006, 02:20 PM
Brickos works great for me. Attached is the makefile that I use to compile and download. To download the code, I type:
make load
To download and run the code, I type:
make run