View Full Version : Driver Station firmware update failure

01-05-2009, 03:59 PM
This problem updating the DS firmware seems to be unique:

We tried to change the team number and, not having updated the firmware it didn't work. So we loaded a Kingston DataTraveler 2.0 (2GB) with dsud_pkg.bin (also tried DSUD_PKG.BIN and DSUD_PKG.bin), with file extension hiding off. We reformatted the drive as FAT32 before placing the file on it (it was the correct size - 2250kb). We're pretty sure there are no autoruns, since we reformatted it. Anyways, we tried to update it following, and got through pressing all four button combos. Additionally we tried it in all modes of disabled/enabled, tele/auto, hotplugged/plugged in before boot. At the end though, where it should have said "DO NOT TURN OFF" etc. it always flashed something (very much unreadable/unrecognizable, who knows) and returned to the default "Team: 00000... etc."

Has anybody else had this problem, or know how to fix it?

Overclocked (246)

01-05-2009, 05:09 PM
We had this problem.

1) Make sure your USB stick is completely clean, except for the update file (this may not be necessary, but ours was clean, so it may have had a hand in our success)
2) Make sure your DS is in AUTO mode
3) Make sure the USB stick is in and it is in AUTO mode when you boot it.
4) Reboot the DS
5) Run the flash update process.

The last thing we did before it worked was trying a power cycle with everything plugged in and the DS in auto mode. Previously we had just tried flashing with it in teleoperated mode, then switching to auto. The mode switch apparently didn't take. Finally, we did a power cycle with the USB stick in beforehand. The documentation notes that it doesn't take hotplugging.

Hope this helps.

01-06-2009, 02:15 PM
The drive was reformatted and then just the update file was added, so I don't think it can get any more clean. I rebooted with the drive in and in auto, no luck. Anybody else?

Robert Cawthon
01-08-2009, 10:04 AM
Try a different flash drive. Ours wouldn't boot up with mine (a generic 1 gig stick) but did with another mentor's SanDisk. We didn't clean the stick, but did put the file in the root directory. Don't know why and, after it worked, I didn't pursue the cause of mine not working.

01-08-2009, 10:44 AM
We seem to be having the same problem. I've tried 3 separate flash drives, one was clean, the other two had things on them, but they shouldn't have conflicted. I've tried both all caps and all lower case for the file name, and I don't have the double extension problem (by default windows hides the file abbreviations for known types, so you run the risk of naming it whatever.bin.bin where the 2nd .bin is the file type. You can show them though, which i did to ensure that wasnt a problem), but whenever I get past the "Hold 'Select' Button" stage it just defaults to the main page and the version is still 'OTB'

01-12-2009, 10:31 AM
Hate to double bump a thread, but has anyone found a solution to this?
We can't get any further in our setup without the DS being updated, and we can't even set the team number. It's the start of week 2 and the control system being down is not really what we need right now.

01-12-2009, 03:33 PM
It looks like you are doing all the right things. We had all the same problems but the second USB drive worked. We had a beta unit and now the release version and they both appeared to not read one device and read the other.

The things I know have been problems are:
Copying the Windows shortcut file instead of the actual data (should be 2.79mb on the drive).
Name not right (Making sure the name is DSUD_PKG.BIN on the drive.)
Having auto-loading software on the drive.
Not puting the drive in USB port 1
Not powering up with the drive in place.
Not trying multiple USB drives.

The last one may be all you have left to keep trying. The one that worked for us was a no-name 1gb give-away.

Let us know if anything helps.

Mr. E
01-12-2009, 05:23 PM
we just got ours to work...third or fourth flash drive. the crazy thing is that the usb stick that worked has an autoloading U3 drive. It was a sanddisk.

01-13-2009, 10:35 AM
I have tried, lets see... upwards of 10 different drives, including Sandisk and U3 drives, and some generics, all produced the same result. At this point I'm thinking its the drivers station itself because I have checked things time after time after time after time and I'm doing everything correctly, correct order, correct naming, its not the shortcut, and EVERYTHING. I'm starting to get VERY frustrated with all of this.