View Full Version : Control System Meltdown

01-14-2009, 07:40 PM
I am a programmer for team 1569. We recieved our control system late and I was not able to get it put together and booted up until yesterday. I followed the first instructions to the letter in updating the firmware and configuring the switch and the bridge. When I came to the step where you unplug the bridge from the router and then attempt to access it the I couldn't see the bridge. I checked that the security settings were all disabled. I even restarted the process from the beginning of the bridge configuration and did it again. I still had the same issue. This time however, after I disabled the wireless security on the switch, I could no longer connect to the bridge at all. Whether by direct connect or through the driver station and switch I can no longer access the bridge. I have tried a hard reset and that failed as well.

Programmer in need of aid,
Team 1569

01-14-2009, 08:25 PM
I have managed to solve part of my own problem with some help from some mentors. We did a reset to factory defaults and broadened our subnet mask. We can now speak to them both. I still cannot connect to the gaming adapter without a wired connection. I have followed the directions exactly and they still will not speak.

Jim E
01-14-2009, 10:35 PM
CAn you talk to each component separately through a WIRED connection to the PC?

You may still have the LinkSys router configured improperly.

Check the router settings as descibed in the FIRST documents. Read them again too. They bounce around a lot like moon rocks on a lunar surface.

Good Luck! It took me a couple days to make sure I was doing it right too. Do not get discouraged.

01-15-2009, 06:55 PM
With each plugged into a separate PC I can speak to each. When they are connected to each other and a PC I can speak to both. When the gaming adapter is unplugged from the router I can no longer speak to it. However, when I plug the gaming adapter into a PC it still sees the switch. The switch does not see it. I have reset both to factory defaults several times and started the FIRST instructions from square one. I still persists in the same issue. It seems like the issue is with the switch but I'm not possitive. I have manipulated every setting in both and still get no change at all. I am beggining to run out of ideas. Any insight at all would be appreciated.

01-15-2009, 07:14 PM
For some strange reason without any act of ours the controler has begun to work. We were saving a setting on the gaming adapter and it was rebooting when someone accidently unplugged it. When we plugged it back in and it booted up it worked! Anyone know why? It wasn't the setting we changed I know that.

01-15-2009, 07:27 PM
It might have simply been glitching and acting out on you. We got the system early and had some issues as well but some seemed to auto-correct in time. Don't know for certain, but it may have been since you got the system later it has some different coding on it that was disabled or changed.

01-16-2009, 12:29 AM
If you have a wireless network in the area you're working with it could have been sending connect request to that instead of the network you had setup. I had this happen around my home network. Unplugging the game adapter, waiting a min then plugging it back in made it re-look for the desired network. I don't know the real tech behind why this happens just that a software restart is not the same as a hard (unplug) restart. Mistakenly, when we were setting up the next day we turned the DS and router on last (after the game adapter). This problem occurred again and remained until we did a hard reset. The school also has a local network so I'd guess the game adapter looks for the first available network after it looks for the network its setup for.

Its now procedure to turn the robot on last (which you're supposed to do for safety reasons anyway).

01-17-2009, 02:59 PM
Team 2839 here, we have a similar problem. We changed our IP addresses for each of the control system parts to the correct numbers. We updated the components also. We can talk to the bridge only when it is hard-wired into the computer. When we disconnect it we cannot. After reading your posts i am going to try to connect to the bridge when there are no wireless networks around. There seems to be like 50 here at charter.:p