View Full Version : Cannot connect to the Real-time target

Mr. E
01-20-2009, 05:32 PM
This is probably an easily fixed problem, but we have a small team and are at a loss. The cRio is connected properly to the wireless router, and all the connections seem correct, however, when I try to deploy the RobotMain.vi to the cRio, it says: cannot connect to the Real-Time target. I'm almost positive that there aren't any problems with the code, (done in LabView.) We can't figure out what's going wrong. Any help would really be appreciated. Thanks.

Mark McLeod
01-20-2009, 10:35 PM
I can offer things to verify and check.
I assume you have applied LabVIEW Update 2, and imaged the cRIO with v7. If in doubt there are ways to verify the versions of each.

Verify your LabVIEW project is using the correct IP address for the cRIO target ( The IP address is displayed in the LabVIEW Project Explorer window as: RT CompactRIO Target ( If it is not correct you can fix it with a right click to get Properties.

Verify your communications:
I wasn't sure what you meant by the cRIO is connected to the router, since it shouldn't be physically connected to it, but only in contact via wireless.
Do the Driver Station and cRIO communicate and run properly with the default code?
i.e., does Enabling the Driver Station give you a solid status light on the cRIO's Digital Sidecar? And does Disabling the DS make the Digital Sidecar status light blink?
This should confirm that your comm wiring is correct, except for the PC and that should be plugged into the Driver Station ETH2 port.

Check your PC:
Verify the PC's IP address (, Subnet mask(, and Default gateway( are as they should be.
Disable any PC firewall.
Disable any wireless network card.
Test communications to the cRIO by:
-- Start -> Run
-- then type cmd and OK
-- then in the window that pops-up type: ping
If you get a message "Request timed out." then your PC truely cannot see the cRIO.

Mr. E
01-21-2009, 05:30 PM
Thanks a bunch Mark! It successfully deploys to the cRio now. I have some new problem that's preventing it from working still, but it's either a programing or connection error. The main problem was not being able to deploy it, so thanks again.

01-24-2009, 03:07 PM
We are having the same problem and when we went to ping it, it timed out. V . V;;;;; Our laptop can't send our code to the cRIO and doesn't even see the Real Time thing.... We've tried pretty much everything we can think of and it still doesn't see it. (The wireless definitely isn't the problem; the joysticks can drive the robot with the base code that is already in there.... so pretty sure that's not wired incorrectly.) Uhmmm.... it was re-imaged properly and all. The IP addresses are right... ( and whatnot.) the firewall is killed... and the wireless card on the laptop is disabled as well so it wouldn't interfere when we connected the laptop to the driver station.

*sigh* Anything else we can do to get this thing to work?

Alan Anderson
01-24-2009, 08:19 PM
We are having the same problem and when we went to ping it, it timed out...The IP addresses are right... ( and whatnot.) the firewall is killed... and the wireless card on the laptop is disabled as well so it wouldn't interfere when we connected the laptop to the driver station.

If you can't ping, there is a problem with either the network wiring or the IP settings.

Is your laptop set to a static IP address of, with a subnet mask of (or and a gateway address of

Mark McLeod
01-24-2009, 08:41 PM
Gateway address should be (router)

Andy Brockway
01-28-2009, 09:10 AM
I have problems connecting to the cRIO also. Last night I retraced my steps using the process described above. When this did not work I did update 3 for labview and Windriver and reflashed the cRIO for windriver. I have followed the manual for all inputs to screen set ups.

The default works wirelessly, I can ping but I cannot get my computer to connect. It time outs and removes dead something, sorry I forgot to write it down, Could my Vxworks be bad?

Mark McLeod
01-28-2009, 01:53 PM
I doubt your Vxworks is bad.
Your PC can ping the cRIO and apply the update patches.

A little more detail on what doesn't connect and where it stops working...
Does WindRiver (I remember that's what you're using) startup and work okay on the PC side?
Can you attach to the cRIO Remote System?
Does it fail when you attempt to Deploy or Debug?

Andy Brockway
01-29-2009, 06:55 AM
I am using Wind River.
I can program and build an .out file.
The remote system does not connect.

The remote connection is VxWorks6x_10.7.16.2 (Wind River VxWorks 6.3)
The error I receive is - Possibly caused by: Back end not connected

I did not have access to the cRIO last night but the Target Server log said:
WTX Library version
Tgtsvr core version
error: rpccore backend client RPC: unable to send

I can check to see if I get the same messages when I am connected. Is there any where else I can pull information to help?

Mark McLeod
01-30-2009, 08:41 AM
Sorry to take so long Andy.

I was successfully(?) able to recreate your connect problem.
(Although there may be other ways to cause the issue...)

I want you to try this specific sequence of steps:
1) Start Wind River
2) Try to connect (and get the error message)
3) Leave Wind River running
4) Start the FRC cRIO Imaging Tool
5) Choose the Development Environment Wind River and Apply (don't reformat the controller)
6) Return to Wind River and try to connect again

I got the same message you did when I had my environment set to LabVIEW, and was able to switch development environments to get Wind River working. However, it can go back to having trouble connecting when Wind River is stopped altogether and restarted (not always though). Wind River can then disconnect and connect repeatedly without trouble as long as it isn't exited. Switching the development environments while Wind River is running seems to work, but I'll try to ferret out the underlying issue if this turns out to be the same problem you're having.

I'll look for other ways to cause a failure to connect...

01-30-2009, 03:45 PM
We're getting the same problem. I applied update 3, and while using WindRiver appears to work properly, Labview is giving me a number of different complaints. Sometimes it "cannot connect to the real-time target", other times, it fails to deploy certain VIs. It's very weird. If it successfully deploys, the servo's don't work, and it doesn't appear (although I haven't confirmed this) that the jaguars work either.

I'm also seeing some errors when I try to switch between WindRiver and Labview, where it complains that it couldn't send the reboot command.

I have noticed issues sometimes with being able to ping the cRIO but the network settings aren't changing between times where it works and times where it doesn't. I think part of the problem is due to power issues where the battery is low.

Andy Brockway
02-02-2009, 12:04 PM

I tried your suggestions and the target server log now does not have any errors.

It may be my computer as I have been getting a WIND_REGISTRY error now and then when I try to connect. I removed and reloaded Wind River with no change to this error. It is an older computer with XP sp1 and I have been hesitant to upgrade to sp2.

02-02-2009, 06:15 PM
Hey I seem to be having a similar problem with Labview. I have made my program, in the labview. However when I go to deploy it I get a box saying

( Waiting for Real-Time target(RT CompactRIO Target)to respond)

Mark McLeod
02-02-2009, 07:47 PM
( Waiting for Real-Time target(RT CompactRIO Target)to respond)
That message is normal, just be patient and leave it alone. A couple of minutes later it will disappear on it's own and the code download will continue.