View Full Version : Help getting C++ program to load

01-24-2009, 12:06 PM
I have been trying to get the SimpleTemplate example project to run on the cRio with no luck. I can ping and connect to the cRio and see a list of running tasks, so it's out there. However, when I attempt to debug the program it gives a LONG list of unresolved symbols (about 40 visible on screen of nFPGA methods, the window truncates so I have no idea how many more). Something isn't setup correctly.

I'm told the cRio has been updated properly, but have also been unable to verify this. So specific questions:

I tried undeploy on the chance something was loaded and is interfering. I get an immediate error message:

"Unable to delete the UserProgram from the robot."

Does this mean there's nothing loaded or that it isn't talking correctly?

Is there a way to tell what version of cRio software is running and whether it is set for C++ or Labview?

I have tried to re-image the cRio to make sure the correct image is loaded, but the re-image utility cannot find the cRio. It's at the correct address I can ping it, and my firewall is off. Does the re-image utility require that the cRio be set to the default IP address or is there something else I need to do?

Thomas Wicklund
Team 2261

01-24-2009, 12:27 PM
Make sure that the cRIO is updated. If it was imaged after you got the kit, it should be fine. Make sure that you have the right file set in Window->Preferences->FIRST Downloader.

If you can connect to the cRIO in WindRiver, then it should be updated correctly. Make sure your computer has the right Static IP (

That should work. Are you getting the errors when trying to build the program?

01-24-2009, 12:32 PM
How do I make sure the cRio is updated? The re-image utility can't find it and I don't see anything saying the version of code when I connect in WindRiver.

I don't get errors compiling, only when trying to run it via "debug kernel task". I'm not worried about deploying at this point.

Thomas Wicklund

Mark McLeod
01-24-2009, 05:19 PM
A couple of ways to check your cRIO software version.

1) Hookup a null modem cable to the cRIO serial port, turn on the cRIO dip switch for "Console out", and use Hyperterminal or similar tool to watch the cRIO console dump when it boots up. You'll see these lines buried in all the others:
FRC_NetworkCommunication was compiled from SVN revision 1510
FPGA Hardware Version: 2009
FPGA Software Version: 2009
FPGA Hardware Revision: 0.1.11
FPGA Software Revision: 0.1.11

2) use the LabVIEW program at: http://thinktank.wpi.edu/article/138
On the far right of this screen are displayed the cRIO version numbers.
The latest v7 version numbers are:
FPGA Firmware Revision: 0.1.11
Network Comm Version: 1510

02-02-2009, 10:24 PM
This seems resolved, finally got the cRIO imaging tool to recognize the cRIO through the wireless interface.

The WindRiver environment still seems fragile and it doesn't always operate as I'd expect, but at least I can load code.