OCCRA
Go to Post Who says girls can't be cute, fun AND SMART?!? - Marisa Russo [more]
Home
Go Back   Chief Delphi > Technical > Programming > Python
CD-Media   CD-Spy  
portal register members calendar search Today's Posts Mark Forums Read FAQ rules

 
Reply
Thread Tools Rate Thread Display Modes
  #1   Spotlight this post!  
Unread 02-01-2018, 11:43 AM
Mr.Robby's Avatar
Mr.Robby Mr.Robby is offline
Team 4480 Head Coach
FRC #4480 (UC-Botics)
Team Role: Coach
 
Join Date: Jan 2016
Rookie Year: 2009
Location: Upsala, MN
Posts: 38
Mr.Robby will become famous soon enough
Deploy Errors

well... New problem now for us... We just got to the 2018 Image for the Roborio - (see other problem)

We are trying to deploy our Robot.py code, and it is coming back with this error:

https://drive.google.com/file/d/1rZM...ew?usp=sharing

The Image of the Rio is 2018V16 - We have two rios with differing Firmware (2.0 and 5.0) both do not deploy and experience similar error. We have all of the robotpy, pyfrc, etc downloads in and ready. Deployed both over the USB-B and also Wifi, and LAN (Still no avail).

Thanks!
__________________
Team 4480 Lead Mentor
2017 Innovation in Control Award Recipient- Lake Superior Regional

Last edited by Mr.Robby : 02-01-2018 at 11:46 AM. Reason: (Edited for Details)
Reply With Quote
  #2   Spotlight this post!  
Unread 02-01-2018, 06:26 PM
loveshark's Avatar
loveshark loveshark is offline
Registered User
FRC #3145 (Teraviks)
Team Role: Programmer
 
Join Date: Jan 2015
Rookie Year: 2013
Location: Coeur d'alene Idaho
Posts: 12
loveshark is an unknown quantity at this point
Re: Deploy Errors

I've gotten a similar error before while trying to deploy over wifi. Have you tried using a printer cable to connect to your roborio?
Reply With Quote
  #3   Spotlight this post!  
Unread 02-02-2018, 07:57 AM
Mr.Robby's Avatar
Mr.Robby Mr.Robby is offline
Team 4480 Head Coach
FRC #4480 (UC-Botics)
Team Role: Coach
 
Join Date: Jan 2016
Rookie Year: 2009
Location: Upsala, MN
Posts: 38
Mr.Robby will become famous soon enough
Re: Deploy Errors

We have only been trying over USB-B Due to the issue of our LAN/Wifi not accepting a Connection.

**Issue Resolved**

Apparently the RIO got stuck into a Read only Mode, We tried to Image it once more and it wasn't accepting the newest 2018_v17 Image. Hard Reset the Rio (using the cfg) and it ended up accepting the new v17 image.

Installing the Image we were able download/redo all of the pyFRC and robotpy installs. Then our Deploy works (finally!)

Finished Updating Firmware on our Talon SRX devices as well (We were not received control from them, but Firmware was out of date).

So we are good now!
__________________
Team 4480 Lead Mentor
2017 Innovation in Control Award Recipient- Lake Superior Regional
Reply With Quote
Reply


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:34 AM.

The Chief Delphi Forums are sponsored by Innovation First International, Inc.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright © Chief Delphi