OCCRA
Go to Post At least I can appreciate the humor in this LOLCODE; it isn't funny when our our robot goes backwards in hybrid mode - sgreco [more]
Home
Go Back   Chief Delphi > Technical > Programming > NI LabVIEW
CD-Media  
portal register members calendar search Today's Posts Mark Forums Read FAQ rules

 
Reply
Thread Tools Rate Thread Display Modes
  #1   Spotlight this post!  
Unread 02-20-2016, 08:27 PM
emvela5814 emvela5814 is offline
Registered User
AKA: Edgar
FRC #5814 (ROBOTA)
Team Role: Mentor
 
Join Date: Feb 2016
Rookie Year: 2016
Location: Ecuador
Posts: 4
emvela5814 is an unknown quantity at this point
ERROR -44003

Hi. I'm new to FRC.
My team is 5814 and we are from Ecuador.
I've set up the bridge to 10.58.14.1 and the AXIS camera is on 10.58.14.16 by DHCP. Laptop is on wifi to the bridge.
I've got this when running the default Robotmain.vi
ERROR -44003 FRC: Operation failed due to a communication failure with the camera. WPI_CameraIssue HTTP Request with Authentication.vi

On Vision Processing.vi, the Select block is set on False cause I'm ussing IP camera.

I want to see the IP camera streamming on dashboard but I can't
Please Help
Reply With Quote
  #2   Spotlight this post!  
Unread 02-20-2016, 08:34 PM
Mark McLeod's Avatar
Mark McLeod Mark McLeod is online now
Just Itinerant
AKA: Hey dad...Father...MARK
FRC #0358 (Robotic Eagles)
Team Role: Engineer
 
Join Date: Mar 2003
Rookie Year: 2001
Location: Hauppauge, Long Island, NY
Posts: 9,719
Mark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond repute
Re: ERROR -44003

The default Dashboard is looking for an IP camera with the mDNS name of "axis-camera"

To set that up you need to browse to the camera, find the TCP/IP advance settings and give it that name.
__________________
We are what we repeatedly do. Excellence, then, is not an act, but a habit. -Aristotle
Reply With Quote
  #3   Spotlight this post!  
Unread 02-20-2016, 10:57 PM
emvela5814 emvela5814 is offline
Registered User
AKA: Edgar
FRC #5814 (ROBOTA)
Team Role: Mentor
 
Join Date: Feb 2016
Rookie Year: 2016
Location: Ecuador
Posts: 4
emvela5814 is an unknown quantity at this point
Re: ERROR -44003

I have done what you said, but still the problem.
Attached Thumbnails
Click image for larger version

Name:	1.PNG
Views:	26
Size:	29.3 KB
ID:	20132  Click image for larger version

Name:	2.PNG
Views:	19
Size:	51.8 KB
ID:	20133  
Reply With Quote
  #4   Spotlight this post!  
Unread 02-21-2016, 10:14 AM
Greg McKaskle Greg McKaskle is offline
Registered User
FRC #2468 (Team NI & Appreciate)
 
Join Date: Apr 2008
Rookie Year: 2008
Location: Austin, TX
Posts: 4,864
Greg McKaskle has a reputation beyond reputeGreg McKaskle has a reputation beyond reputeGreg McKaskle has a reputation beyond reputeGreg McKaskle has a reputation beyond reputeGreg McKaskle has a reputation beyond reputeGreg McKaskle has a reputation beyond reputeGreg McKaskle has a reputation beyond reputeGreg McKaskle has a reputation beyond reputeGreg McKaskle has a reputation beyond reputeGreg McKaskle has a reputation beyond reputeGreg McKaskle has a reputation beyond repute
Re: ERROR -44003

The Axis camera implements client authentication. If you use the config tool, it will create an account called FRC with a password of FRC. You can also do this by hand in the web config. I believe it may also work if you turn on the checkbox of anonymous access. But I don't think anonymous viewers are allowed to set certain properties, so the FRC/FRC approach is recommended.

Greg McKaskle
Reply With Quote
  #5   Spotlight this post!  
Unread 02-21-2016, 10:43 AM
emvela5814 emvela5814 is offline
Registered User
AKA: Edgar
FRC #5814 (ROBOTA)
Team Role: Mentor
 
Join Date: Feb 2016
Rookie Year: 2016
Location: Ecuador
Posts: 4
emvela5814 is an unknown quantity at this point
Re: ERROR -44003

I have set the User and Password on the cametra as you said.
I have also configured camera's IP on vision processing and on dashboard and deployed.
When running the robot main, I select IP Camera on dashboard and NT Connection indicator turns green.
Dashboard does'n return any problem but image is still not showing.

Any other suggestion?
Attached Thumbnails
Click image for larger version

Name:	1.PNG
Views:	22
Size:	29.0 KB
ID:	20136  Click image for larger version

Name:	2.PNG
Views:	22
Size:	13.1 KB
ID:	20137  Click image for larger version

Name:	3.PNG
Views:	19
Size:	4.9 KB
ID:	20138  
Reply With Quote
  #6   Spotlight this post!  
Unread 02-22-2016, 08:01 AM
Greg McKaskle Greg McKaskle is offline
Registered User
FRC #2468 (Team NI & Appreciate)
 
Join Date: Apr 2008
Rookie Year: 2008
Location: Austin, TX
Posts: 4,864
Greg McKaskle has a reputation beyond reputeGreg McKaskle has a reputation beyond reputeGreg McKaskle has a reputation beyond reputeGreg McKaskle has a reputation beyond reputeGreg McKaskle has a reputation beyond reputeGreg McKaskle has a reputation beyond reputeGreg McKaskle has a reputation beyond reputeGreg McKaskle has a reputation beyond reputeGreg McKaskle has a reputation beyond reputeGreg McKaskle has a reputation beyond reputeGreg McKaskle has a reputation beyond repute
Re: ERROR -44003

To help with debugging, please open a web browser and enter axis-camera.local as the URL to see if this is the device name of the camera and to see that the name is resolved. Your diagrams look correct, so it seems like the camera configuration is not quite there.

The camera pages are not the same for different cameras, but there is an advanced TCP page where you can set the device name. It is sometimes set to axis-#######, using the serial number for the digits. See if you can find the camera name in the advanced tab and change it.

Greg McKaskle
Reply With Quote
  #7   Spotlight this post!  
Unread 02-22-2016, 09:35 AM
Mark McLeod's Avatar
Mark McLeod Mark McLeod is online now
Just Itinerant
AKA: Hey dad...Father...MARK
FRC #0358 (Robotic Eagles)
Team Role: Engineer
 
Join Date: Mar 2003
Rookie Year: 2001
Location: Hauppauge, Long Island, NY
Posts: 9,719
Mark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond repute
Re: ERROR -44003

Change the name you hardcoded in Dashboard Main from axis-camera.local to axis-camera.lan
__________________
We are what we repeatedly do. Excellence, then, is not an act, but a habit. -Aristotle
Reply With Quote
  #8   Spotlight this post!  
Unread 03-07-2018, 10:28 AM
Jack Gillespie's Avatar
Jack Gillespie Jack Gillespie is offline
Registered User
FRC #5430 (Pirate Robolution)
Team Role: Teacher
 
Join Date: Nov 2008
Rookie Year: 2009
Location: Pittsburg California
Posts: 56
Jack Gillespie is an unknown quantity at this point
Re: ERROR -44003

Mark Mcleod,

We are having the same problem.
How do we open dashboard main to change axis-camera.local to lan??
Reply With Quote
Reply


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:31 PM.

The Chief Delphi Forums are sponsored by Innovation First International, Inc.


Powered by vBulletin®
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright © Chief Delphi