Go to Post Never underestimate the power of human ingenuity. - Wetzel [more]
Home
Go Back   Chief Delphi > Technical > Programming
CD-Media   CD-Spy  
portal register members calendar search Today's Posts Mark Forums Read FAQ rules

 
Reply
Thread Tools Rate Thread Display Modes
  #1   Spotlight this post!  
Unread 05-25-2018, 08:08 PM
Zem's Avatar
Zem Zem is offline
Registered User
AKA: Braeden
FRC #3461 (Operation P.E.A.C.C.E.)
Team Role: College Student
 
Join Date: May 2018
Rookie Year: 2010
Location: CT
Posts: 12
Zem is an unknown quantity at this point
Help getting c-rio and code working

Hello CD,
I am trying to get an old 8 slot c-rio working. When I went to up load it only got this far:

ant -f C:\\Users\\Braeden\\Documents\\NetBeansProjects\\M yRobot deploy run
clean:
Deleting directory C:\Users\Braeden\Documents\NetBeansProjects\MyRobo t\build
Created dir: C:\Users\Braeden\Documents\NetBeansProjects\MyRobo t\build
Created dir: C:\Users\Braeden\Documents\NetBeansProjects\MyRobo t\build\classes
[crio-compile] ./src, C:/Users/Braeden/sunspotfrcsdk\lib\wpilibj.jar;C:/Users/Braeden/sunspotfrcsdk\lib\networktables-crio.jar, C:/Users/Braeden/sunspotfrcsdk\lib\squawk.jar -> ./build/classes
Compiling 10 source files to C:\Users\Braeden\Documents\NetBeansProjects\MyRobo t\build\classes
warning: [options] source value 1.3 is obsolete and will be removed in a future release
warning: [options] target value 1.2 is obsolete and will be removed in a future release
warning: [options] To suppress warnings about obsolete options, use -Xlint:-options.
3 warnings
compile:
preverify:
Created dir: C:\Users\Braeden\Documents\NetBeansProjects\MyRobo t\build\preverify
Created dir: C:\Users\Braeden\Documents\NetBeansProjects\MyRobo t\build\preverify.raw.util
[crio-preverify] ./build/classes, , C:/Users/Braeden/sunspotfrcsdk\lib\wpilibj.jar;C:/Users/Braeden/sunspotfrcsdk\lib\networktables-crio.jar, C:/Users/Braeden/sunspotfrcsdk\lib\squawk.jar -> ./build/preverify
Expanding: C:\Users\Braeden\sunspotfrcsdk\lib\wpilibj.jar into C:\Users\Braeden\Documents\NetBeansProjects\MyRobo t\build\preverify
Expanding: C:\Users\Braeden\sunspotfrcsdk\lib\networktables-crio.jar into C:\Users\Braeden\Documents\NetBeansProjects\MyRobo t\build\preverify
jar:
[crio-jar] ./build/preverify, ./resources -> ./build/app.jar
Building jar: C:\Users\Braeden\Documents\NetBeansProjects\MyRobo t\build\app.jar
suite:
Created dir: C:\Users\Braeden\Documents\NetBeansProjects\MyRobo t\build\suite
[crio-suite] ./build/app.jar -> ./build/suite/image
CompilerOracle: exclude com/sun/squawk/Method.getParameterTypes
CompilerOracle: exclude com/sun/squawk/SymbolParser.getSignatureTypeAt
CompilerOracle: exclude com/sun/squawk/SymbolParser.stripMethods
[translating suite image [closed: false, parent: squawk] ...]
### Excluding compile: com.sun.squawk.SymbolParser::getSignatureTypeAt
### Excluding compile: com.sun.squawk.Method::getParameterTypes
[Including resource: META-INF/MANIFEST.MF]
[Including resource: META-INF/maven/edu.wpi.first.wpilib.networktables.java/NetworkTablesAzalea/pom.properties]
[Including resource: META-INF/maven/edu.wpi.first.wpilib.networktables.java/NetworkTablesAzalea/pom.xml]
Romizer processed 397 classes and generated 4 files.
Expanding: C:\Users\Braeden\Documents\NetBeansProjects\MyRobo t\build\app.jar into C:\Users\Braeden\Documents\NetBeansProjects\MyRobo t\build\suite
Moving 1 file to C:\Users\Braeden\Documents\NetBeansProjects\MyRobo t\build\suite
Moving 1 file to C:\Users\Braeden\Documents\NetBeansProjects\MyRobo t\build\suite
Moving 1 file to C:\Users\Braeden\Documents\NetBeansProjects\MyRobo t\build\suite
Deleting: C:\Users\Braeden\Documents\NetBeansProjects\MyRobo t\image.suite.api
deploy:
[crio-configure] Configuration files not included in this version of the sdk
[crio-configure] Checking that crio is configured for Java
Host OS: Windows 10 10.0, 10.0
Host JVM: Java HotSpot(TM) 64-Bit Server VM 25.171-b11
Target IP: 10.34.61.2
Network interfaces on host:
Realtek PCIe GBE Family Controller: address: 10.34.61.77 netmask: 255.255.255.0 <--- on robot's subnet
Connecting FTP @10.34.61.2


Can someone please help me?

thank you
Reply With Quote
  #2   Spotlight this post!  
Unread 05-25-2018, 08:57 PM
Alan Anderson's Avatar
Alan Anderson Alan Anderson is offline
Software Architect
FRC #0045 (TechnoKats)
Team Role: Mentor
 
Join Date: Feb 2004
Rookie Year: 2004
Location: Kokomo, Indiana
Posts: 9,163
Alan Anderson has a reputation beyond reputeAlan Anderson has a reputation beyond reputeAlan Anderson has a reputation beyond reputeAlan Anderson has a reputation beyond reputeAlan Anderson has a reputation beyond reputeAlan Anderson has a reputation beyond reputeAlan Anderson has a reputation beyond reputeAlan Anderson has a reputation beyond reputeAlan Anderson has a reputation beyond reputeAlan Anderson has a reputation beyond reputeAlan Anderson has a reputation beyond repute
Re: Help getting c-rio and code working

I think 2014 was the last year the 8-slot cRIO was supported. You can find the appropriate LabVIEW software at the bottom of this page: https://forums.ni.com/t5/FIRST-Robot...e/ta-p/3734559

I don't know where to find the old C++ or Java programming environments and WPI libraries.
Reply With Quote
  #3   Spotlight this post!  
Unread 05-25-2018, 11:39 PM
snoman's Avatar
snoman snoman is offline
Registered User
FRC #3275 (Accelerators 3134 & Regulators 3275)
Team Role: Coach
 
Join Date: Jan 2014
Rookie Year: 2012
Location: Minnesota
Posts: 515
snoman is a glorious beacon of lightsnoman is a glorious beacon of lightsnoman is a glorious beacon of lightsnoman is a glorious beacon of lightsnoman is a glorious beacon of lightsnoman is a glorious beacon of light
Re: Help getting c-rio and code working

This is the archived 2014 WPI Library
https://wpilib.screenstepslive.com/s/3120
__________________
Coach of the Cass Lake Bena Regulators 3275 (Boys)and mentor Accelerators 3134(Girls)
President of the NMRC (Northern Minnesota Robotics Conference )
www.nmrconference.org
https://www.facebook.com/accerleratorsandregulators/
https://www.youtube.com/channel/UCQU...Cr8I4wezAbMefA



Reply With Quote
  #4   Spotlight this post!  
Unread 05-26-2018, 10:13 AM
virtuald's Avatar
virtuald virtuald is offline
RobotPy Guy
AKA: Dustin Spicuzza
FRC #6367 (), FRC #7240 ()
Team Role: Mentor
 
Join Date: Dec 2008
Rookie Year: 2003
Location: Boston, MA
Posts: 1,382
virtuald has a brilliant futurevirtuald has a brilliant futurevirtuald has a brilliant futurevirtuald has a brilliant futurevirtuald has a brilliant futurevirtuald has a brilliant futurevirtuald has a brilliant futurevirtuald has a brilliant futurevirtuald has a brilliant futurevirtuald has a brilliant futurevirtuald has a brilliant future
Re: Help getting c-rio and code working

Older versions of RobotPy can still be deployed on the cRIO: https://github.com/robotpy/robotpy-crio/releases
__________________
Maintainer of RobotPy (Python for FRC) & WPILib Contributor
Creator of pyfrc (Robot Simulator + utilities for Python), pynetworktables/pynetworktables2js (NetworkTables for Python & Javascript), and lots more...

Team #1418 (remote mentor): Newton Quarterfinalists, 2016 Chesapeake District Champion, 2x Innovation in Control award, 2x district event winner
Team #1418: 2015 DC Regional Innovation In Control Award, #2 seed; 2014 VA Industrial Design Award; 2014 Finalists in DC & VA
Team #2423: 2012 & 2013 Boston Regional Innovation in Control Award


Resources: FIRSTWiki (relaunched!) | My Software Stuff
Reply With Quote
  #5   Spotlight this post!  
Unread 05-26-2018, 02:03 PM
Zem's Avatar
Zem Zem is offline
Registered User
AKA: Braeden
FRC #3461 (Operation P.E.A.C.C.E.)
Team Role: College Student
 
Join Date: May 2018
Rookie Year: 2010
Location: CT
Posts: 12
Zem is an unknown quantity at this point
Re: Help getting c-rio and code working

I know the c-rio's are no longer supported but I thought the all the software still worked.
Reply With Quote
  #6   Spotlight this post!  
Unread 05-26-2018, 06:28 PM
gixxy's Avatar
gixxy gixxy is offline
Programming Mentor
AKA: Gustave Michel III
FRC #3946 (Tiger Robotics)
Team Role: Mentor
 
Join Date: Nov 2011
Rookie Year: 2012
Location: Ruston, LA
Posts: 233
gixxy is on a distinguished road
Re: Help getting c-rio and code working

The RoboRIO's underlying architecture is very different and incompatible with the cRIO. This is why FRC made a clean break to the RoboRIO in 2015 instead of having a crossover period of supporting both.

In your case of using Java, the cRIO used a custom version of JavaME (Micro Edition), whereas the roboRIO uses JavaSE (Standard Edition), meaning the WPILIB libraries would be incompatible near the lower Hardware Abstraction Layer level.

In order to program/use a cRIO, you'd need to install the 2014 or previous software packages that would still support the cRIO architecture.
__________________
Programmer - A creature known for converting Caffeine into Code.
Studying Computer Science @ Louisiana Tech University
Associate Consultant @ Fenway Group

2012-13: 3946 - Head of Programming, Electrical and Web
2014, 2018 - 3468 - Programming Mentor
2014 - Present - 3946 - Programming Mentor
Reply With Quote
  #7   Spotlight this post!  
Unread 05-26-2018, 07:23 PM
Thad House Thad House is offline
Volunteer, WPILib Contributor
no team (Waiting for 2021)
Team Role: Mentor
 
Join Date: Feb 2011
Rookie Year: 2010
Location: Thousand Oaks, California
Posts: 1,198
Thad House has a reputation beyond reputeThad House has a reputation beyond reputeThad House has a reputation beyond reputeThad House has a reputation beyond reputeThad House has a reputation beyond reputeThad House has a reputation beyond reputeThad House has a reputation beyond reputeThad House has a reputation beyond reputeThad House has a reputation beyond reputeThad House has a reputation beyond reputeThad House has a reputation beyond repute
Re: Help getting c-rio and code working

You're using netbeans, so it seems like you have the proper libraries for the crio. Can you ping the ip address it is looking for the crio? And is it properly imaged with the 2014 image?
__________________
All statements made are my own and not the feelings of any of my affiliated teams.
Teams 1510 and 2898 - Student 2010-2012
Team 4488 - Mentor 2013-2016
Co-developer of RobotDotNet, a .NET port of the WPILib.
Reply With Quote
  #8   Spotlight this post!  
Unread 05-27-2018, 09:36 AM
Zem's Avatar
Zem Zem is offline
Registered User
AKA: Braeden
FRC #3461 (Operation P.E.A.C.C.E.)
Team Role: College Student
 
Join Date: May 2018
Rookie Year: 2010
Location: CT
Posts: 12
Zem is an unknown quantity at this point
Re: Help getting c-rio and code working

I am using NetBeans and i'm confident that I have all the correct old plugins. As for the correct version of Java i'm not sure. Although I can connect using the old driver station and enable.
Considering that, I do not see the need to ping it.
Reply With Quote
  #9   Spotlight this post!  
Unread 06-02-2018, 07:27 PM
Zem's Avatar
Zem Zem is offline
Registered User
AKA: Braeden
FRC #3461 (Operation P.E.A.C.C.E.)
Team Role: College Student
 
Join Date: May 2018
Rookie Year: 2010
Location: CT
Posts: 12
Zem is an unknown quantity at this point
Re: Help getting c-rio and code working

So I re-imaged the crio and now it all seems to be working. I think the image must have gotten corrupted or something. After all it the crio was sitting around for a while.
Reply With Quote
Reply


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:08 PM.

The Chief Delphi Forums are sponsored by Innovation First International, Inc.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright © Chief Delphi