Go to Post "Yes, I'd like to Super Size my speed controller combo and add a jumbo distribution block, please." "You want fries with that?" - Travis Hoffman [more]
Home
Go Back   Chief Delphi > Technical > Technical Discussion
CD-Media   CD-Spy  
portal register members calendar search Today's Posts Mark Forums Read FAQ rules

 
Reply
Thread Tools Rate Thread Display Modes
  #1   Spotlight this post!  
Unread 05-17-2018, 11:25 AM
Dacosta Dacosta is offline
Registered User
no team
 
Join Date: Oct 2017
Location: Dominican Republic
Posts: 47
Dacosta is an unknown quantity at this point
Disconnection

The robot is disconnecting, turning the lights red rapidly in the driver station and then it starts by itself.
Reply With Quote
  #2   Spotlight this post!  
Unread 05-17-2018, 11:27 AM
Mark McLeod's Avatar
Mark McLeod Mark McLeod is offline
Just Itinerant
AKA: Hey dad...Father...MARK
FRC #0358 (Robotic Eagles)
Team Role: Engineer
 
Join Date: Mar 2003
Rookie Year: 2002
Location: Hauppauge, Long Island, NY
Posts: 9,629
Mark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond repute
Re: Disconnection

Do you mean the Robot Code light in the Driver Station?
Like when the code crashes and restarts, crashes, restarts?
__________________
2018 Beta Testing Results

Reply With Quote
  #3   Spotlight this post!  
Unread 05-17-2018, 11:31 AM
Dacosta Dacosta is offline
Registered User
no team
 
Join Date: Oct 2017
Location: Dominican Republic
Posts: 47
Dacosta is an unknown quantity at this point
Re: Disconnection

The communication light
Reply With Quote
  #4   Spotlight this post!  
Unread 05-17-2018, 12:04 PM
Mark McLeod's Avatar
Mark McLeod Mark McLeod is offline
Just Itinerant
AKA: Hey dad...Father...MARK
FRC #0358 (Robotic Eagles)
Team Role: Engineer
 
Join Date: Mar 2003
Rookie Year: 2002
Location: Hauppauge, Long Island, NY
Posts: 9,629
Mark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond repute
Re: Disconnection

So the Communications light goes completely red, then completely green, then all red, all green, never settling down?
There is a half green state it can be in, but that's okay and doesn't affect normal operations.

Are the status lights on the roboRIO itself changing?
__________________
2018 Beta Testing Results

Reply With Quote
  #5   Spotlight this post!  
Unread 05-18-2018, 04:04 PM
Dacosta Dacosta is offline
Registered User
no team
 
Join Date: Oct 2017
Location: Dominican Republic
Posts: 47
Dacosta is an unknown quantity at this point
Re: Disconnection

yes it gets half red and green, dont know if the robo rio lights change. But when using the robot and moving the drivetrain foward, it stops and goes as the lights in the driver station change.
Reply With Quote
  #6   Spotlight this post!  
Unread 05-18-2018, 06:40 PM
alst alst is offline
Programming Mentor
AKA: Alan
FRC #0830 (RatPack)
Team Role: Mentor
 
Join Date: Jul 2015
Rookie Year: 1188
Location: MI
Posts: 27
alst is a jewel in the roughalst is a jewel in the roughalst is a jewel in the rough
Re: Disconnection

Quote:
Originally Posted by Mark McLeod View Post
There is a half green state it can be in, but that's okay and doesn't affect normal operations.
Well, the two halves of the comms light in the DS are for TCP and UDP, so half-red means that either TCP or UDP isn't working. I would usually expect that to be a firewall issue, but since control is working to an extent here, I'm not sure that it's the cause. Of course, the indicator could also be inconsistent - I don't remember exactly how it works.

Dacosta, a few more questions:
- What exactly does the communication light look like before you start driving, when the robot is moving, and when it's stopped?
- What's the battery voltage reported in the DS, both when you aren't moving and when the issue occurs? Do you see a brownout warning?
- You said you "don't know" what the RoboRIO status lights are doing - can you try to figure that out? Maybe put the robot on blocks or something if you can't get a good look at it when it's moving.
- Do the lights in the diagnostics tab (second tab down on the left) change when the issue happens?

If you can upload a driver station log file somewhere from when this happens, that might help. You can get to it with "view log file" under the gear icon, or https://wpilib.screenstepslive.com/s...-by-ni-labview
__________________
FiM CSA/FTAA/etc.
Reply With Quote
  #7   Spotlight this post!  
Unread 05-18-2018, 07:13 PM
Mark McLeod's Avatar
Mark McLeod Mark McLeod is offline
Just Itinerant
AKA: Hey dad...Father...MARK
FRC #0358 (Robotic Eagles)
Team Role: Engineer
 
Join Date: Mar 2003
Rookie Year: 2002
Location: Hauppauge, Long Island, NY
Posts: 9,629
Mark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond repute
Re: Disconnection

Does the battery voltage readout on the Driver Station app flicker red as well?


Is this with the laptop that was used during the regular competition season? Have you tested it with multiple different laptops?
(Both of these would help eliminate the PC as a cause)

Have you tested with a different battery?
(Eliminating the battery as a cause)

Have you checked the battery and all the power path connections from the battery/wires/terminals/PDP/roboRIO?
(Eliminating loose connections as the cause.)


For basic robot operation we only need the UDP half green.
TCP would be more important if FMS was connected.
__________________
2018 Beta Testing Results


Last edited by Mark McLeod : 05-18-2018 at 08:00 PM.
Reply With Quote
Reply


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:13 PM.

The Chief Delphi Forums are sponsored by Innovation First International, Inc.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright © Chief Delphi