OCCRA
Go to Post >wears zebra pants >calls people weird - PayneTrain [more]
Home
Go Back   Chief Delphi > Technical > Control System > FRC Control System
CD-Media   CD-Spy  
portal register members calendar search Today's Posts Mark Forums Read FAQ rules

 
Reply
Thread Tools Rate Thread Display Modes
  #1   Spotlight this post!  
Unread 05-08-2017, 10:46 AM
ylcc23 ylcc23 is offline
Registered User
no team
 
Join Date: May 2017
Location: Mississauga
Posts: 2
ylcc23 is an unknown quantity at this point
Unexpected error while imaging roborio

I'm attempting to image my roborio for the first time and any time I attempt to image it, I get the same error.

Unable to download image to target. Unable to complete operation because of unexpected error:nisyscfg.lvlib:Initialize (Helper).vi:3930001 <APPEND>

<b>Complete Call Chain</b>
nisyscfg.lvlib:Initialize (Helpler).vi:3930001
nisyscfg.lvlib:Session.vi:1230001
RoboRIOImagingTool.lvlib:Open Session.vi
RoboRIOImagingTool.lvlib:Reconfig Device.vi
RoboRIOImagingTool.lvlib:ImageManager.vi
RoboRIOImagingTool.lvlib:ImagingToolMain.vi


I have tried turning it off and back on again many times to no avail. The device is detected in NI Max. I'm using a USB connection for the imaging. Any help is greatly appreciated.
Reply With Quote
  #2   Spotlight this post!  
Unread 05-08-2017, 12:07 PM
Mark McLeod's Avatar
Mark McLeod Mark McLeod is offline
Just Itinerant
AKA: Hey dad...Father...MARK
FRC #0358 (Robotic Eagles)
Team Role: Engineer
 
Join Date: Mar 2003
Rookie Year: 2002
Location: Hauppauge, Long Island, NY
Posts: 9,639
Mark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond repute
Re: Unexpected error while imaging roborio

My first suspicion would be a network issue on your PC.

Have you tried a laptop with a different OS, e.g., the old Classmate is pretty trustworthy?
Did you Disable all other NICs on your PC and disable the firewall and anti-virus?
Have you tried booting the roboRIO in Safe Mode and loading the image?

If the imaging process gets interrupted partway through (loss of power or disconnected USB cable), then the roboRIO image can be corrupted.
If you've never been even partially successful with your particular PC, then it's not going to be this though.
This would require booting from a roboRIO Linus OS stick to recover.
__________________
We are what we repeatedly do. Excellence, then, is not an act, but a habit. -Aristotle

Last edited by Mark McLeod : 05-08-2017 at 12:32 PM.
Reply With Quote
  #3   Spotlight this post!  
Unread 05-08-2017, 02:29 PM
ylcc23 ylcc23 is offline
Registered User
no team
 
Join Date: May 2017
Location: Mississauga
Posts: 2
ylcc23 is an unknown quantity at this point
Re: Unexpected error while imaging roborio

I ended up using my coworker's laptop to image it and that worked. He had windows 10, the one I'm using runs 8.1 sadly. Our suspicion is that win 8 had something to do with it. It was already loaded in safe mode (orange LED blinking twice).s
Reply With Quote
Reply


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:01 AM.

The Chief Delphi Forums are sponsored by Innovation First International, Inc.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright © Chief Delphi