Go to Post "If a student CAN do it, a student SHOULD do it." - Mr. Lim [more]
Home
Go Back   Chief Delphi > Technical > Control System > FRC Control System
CD-Media   CD-Spy  
portal register members calendar search Today's Posts Mark Forums Read FAQ rules

 
Reply
Thread Tools Rate Thread Display Modes
  #1   Spotlight this post!  
Unread 05-09-2017, 12:41 PM
ylcc23 ylcc23 is offline
Registered User
no team
 
Join Date: May 2017
Location: Mississauga
Posts: 2
ylcc23 is an unknown quantity at this point
No Robot Communication with driver station

As the title implies, my robot is not communicating with the driver station and I can't figure out exactly what is causing the lack of communication. I am able to reach the rio when it's connected via USB, though I cannot reach it when I am connected to the radio. I have tried turning off the firewall, and that generated the error code -44019 mDNS slow to respond: check firewall settings. I have turned the firewall back on and I am still receiving the same error. I'm at a loss as to what the hell could be causing this. I have the OM5P-AC radio flashed and the rio imaged with the correct team number. Relevant screencaps:
Reply With Quote
  #2   Spotlight this post!  
Unread 01-26-2018, 07:38 PM
Bennett Bennett is offline
CSA/Scorekeeper/FTAA
FRC #2977 (Sir Lancer Bots)
Team Role: Mentor
 
Join Date: Jan 2012
Rookie Year: 2012
Location: Minnesota
Posts: 28
Bennett is an unknown quantity at this point
Re: No Robot Communication with driver station

Can you ping the radio? The address should be 10.TE.AM.1 (i.e. team 2977's IP would be 10.29.77.1). Definitely want your firewall to be disabled.
Reply With Quote
  #3   Spotlight this post!  
Unread 01-26-2018, 09:14 PM
Mark McLeod's Avatar
Mark McLeod Mark McLeod is offline
Just Itinerant
AKA: Hey dad...Father...MARK
FRC #0358 (Robotic Eagles)
Team Role: Engineer
 
Join Date: Mar 2003
Rookie Year: 2002
Location: Hauppauge, Long Island, NY
Posts: 9,629
Mark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond reputeMark McLeod has a reputation beyond repute
Re: No Robot Communication with driver station

Your Driver Station connects when using the USB connection.
Does it work if you connect directly to the roboRIO Ethernet port?

For general network troubleshooting:

- Check the diagnostic tab of the Driver Station to see what your PC has found:
https://www.chiefdelphi.com/forums/a...chmentid=22871
- Are you able to connect to the radio AP okay?

- For debugging I'd turn off your PC firewall to keep that out of the way.
- Turn off any anti-virus or other software that interferes or controls network connections.

Where you go next will depend on what you discover and what statuses you are getting.
__________________
2018 Beta Testing Results


Last edited by Mark McLeod : 01-26-2018 at 09:26 PM.
Reply With Quote
Reply


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:23 PM.

The Chief Delphi Forums are sponsored by Innovation First International, Inc.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright © Chief Delphi