OCCRA
Go to Post Surprise! There is no ideal alliance. As soon as you think you have a winning strategy, someone WILL figure out how to beat it. - Tom Bottiglieri [more]
Home
Go Back   Chief Delphi > Technical > Programming
CD-Media   CD-Spy  
portal register members calendar search Today's Posts Mark Forums Read FAQ rules

 
Closed Thread
Thread Tools Rate Thread Display Modes
  #1   Spotlight this post!  
Unread 01-17-2005, 09:07 PM
Hieb Hieb is offline
Registered User
no team
Team Role: Teacher
 
Join Date: Mar 2004
Rookie Year: 2004
Location: St. Louis, MO
Posts: 125
Hieb is a splendid one to beholdHieb is a splendid one to beholdHieb is a splendid one to beholdHieb is a splendid one to beholdHieb is a splendid one to beholdHieb is a splendid one to beholdHieb is a splendid one to behold
IFI Loader problems

I'm having trouble loading new programs onto the RC. I successfully updated the Master Code, but when I uploaded our program it installed but showed a code error on the OI. I then installed the default code successfully. After that my problems began. Since that time I have tried reloading our current code and also several other code packages, but each time it begins (erasing the old code) then abruptly stops with the status line reading "Not connected..." I get the same result when trying to load to the mini-RC. I'm not aware of any system changes between the successful and unsuccessful attempts, but my have a feeling it has something to do with the settings of the COM port. Any ideas? Thank you.
  #2   Spotlight this post!  
Unread 01-17-2005, 09:26 PM
steven114 steven114 is offline
Programming Wizard and Team Captain
AKA: Steven Schlansker
FRC #0114 (Eaglestrike)
Team Role: Programmer
 
Join Date: Feb 2004
Location: Los Altos, CA
Posts: 335
steven114 is a jewel in the roughsteven114 is a jewel in the roughsteven114 is a jewel in the rough
Send a message via AIM to steven114
Re: IFI Loader problems

Try holding the PROG button until the state goes to yellow before you download?
__________________
Shift to the left, shift to the right!
Pop up, push down, byte, byte, byte!
  #3   Spotlight this post!  
Unread 01-17-2005, 09:26 PM
devicenull devicenull is offline
Robot? We need a robot?
no team
 
Join Date: Sep 2004
Rookie Year: 1234
Location: n/a
Posts: 359
devicenull is just really nicedevicenull is just really nicedevicenull is just really nicedevicenull is just really nicedevicenull is just really nice
Re: IFI Loader problems

What lights are on on the RC? We ran into a problem somewhat like this before, and it was an easy fix (After we spent like an hour trying, it was in the doc's all the time). If the battery light is flashing, and the program light is red/orange then check out the doc's for the RC, it tells you how to fix it.
  #4   Spotlight this post!  
Unread 01-18-2005, 12:45 PM
Hieb Hieb is offline
Registered User
no team
Team Role: Teacher
 
Join Date: Mar 2004
Rookie Year: 2004
Location: St. Louis, MO
Posts: 125
Hieb is a splendid one to beholdHieb is a splendid one to beholdHieb is a splendid one to beholdHieb is a splendid one to beholdHieb is a splendid one to beholdHieb is a splendid one to beholdHieb is a splendid one to behold
Re: IFI Loader problems

Thanks for the help, but I'm still unable to download the program code. The program button has been pushed. Currently the RC lights are: Battery Power-green, Program-orange, radio modem-green, RC Hardware-green. For the RC Mode, it is either flashing green very faintly, or there is no light for RC Mode. I've read and reread the documentation for the RC, the OI, and Programming, but have been unable to find a solution. Thanks for any help.
Closed Thread


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Does the new IFI Loader work with the old Firmware? gnormhurst Programming 2 01-17-2005 07:11 PM
IFI Loader problems billstu Programming 22 03-23-2004 10:39 AM
IFI Loader Problems BrendaB Programming 3 01-24-2004 09:45 PM
IFI Loader Doc's Raven_Writer Programming 0 01-21-2004 04:53 PM
Bug in IFI Loader rwaliany Programming 2 01-06-2004 08:26 PM


All times are GMT -5. The time now is 06:30 AM.

The Chief Delphi Forums are sponsored by Innovation First International, Inc.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright © Chief Delphi