2002 r/c

i am trying to program a 2002 robot controller and dont kno how to do it, i have the stamp editor from first legacy but it says it cant read the device, i have the power on and everything, how do i do it???, o yea i am trying to upload the default code

It’s been a long time. Off the top of my head:

  • Make sure the editor is set up to use whatever com port you’re using.
  • Make sure the baud rate is set correctly. (9600, I think.)*]Try using a computer that doesn’t require a USB to Serial adapter.

Also make sure the jumper on the R/C is set to User mode. The legacy controller had a switch to specify User code vs. Default code. I believe the flash in default mode is read only, so you can only download code when it’s in User mode. Look towards the bottom by the team number dip switches.

The last year (maybe 2) of the BASIC Stamp RC allowed you to write to both banks, so it may or may not be a problem if the jumper is in the default position.

You cannot upload code. You can only download code.

Mike

True. But I knew what he meant, didn’t you? :wink:

I thought Mike gave a perfectly appropriate response. anon96464947 says he’s trying to read the device, not write to it.

For more help, anon96464947, http://www.ifirobotics.com/first-legacy.shtml has the default code you’re looking for, along with a guide to programming that should be extremely useful.

Point taken. OK, anon96464947, which is it? Are you trying to read the default program from the RC, or are you trying to write to the RC?

Greg, et al,

In the event he is trying to read, he should consult IFI. I know that we can upload a hex image (link) but that is only with the 2004/2005 controllers.

I had assumed that this was a “classic” case of one generation of students graduating and source code not being stored on permanent media (school server, CDROM, et cetera).

However, I might be wrong.

Regards,

Mike

i am trying to write code to the device
but now when i am in the basic stamp editor it detects the com port but not the r/c it says something like unable to locate basic stamp

What version of the BASIC Stamp Editor are you using? I recommend getting the latest version (2.2) from Parallax.

Are you using a USB to serial adapter? They are not all the same. They don’t all support all the signals needed by the editor for detecting and programming the BS2. If you have a computer available which has an old-school serial port, try using it.

When you apply power to the RC, what LEDs light up? There are various errors that will be indicated by the LEDs. The Robot Controller Reference describes the LEDs and those error conditions.

Good luck. :wink:

FYI, he was trying to download to the RC. The problem turned out to be his USB to serial adapter. He bought a new one from Radio Shack, and it is working now.