2010 346 Programming team problem log

This is a log of our problems we have encountered in the 2010 build season. The topics will remain open until a solution is found. At that time I will update the post with the solution. The hope is that if anyone has the same problem thay can use this as a refrance for their own problems or if someone has had one of our problems and they have a solution they can post it.

A) Problem: Dashboard will not show after update
Status: Closed
Solution: 1) Open C:\Documents and Settings\All Users\Shared Documents\FRC DS Data Storage.ini
2) Locate DashboardcmdLine=
3 change to DashboardcmdLine=“c:\program files\frc dashboard\dashboard.exe”

B) Problem: cRio will not update to v19 properly
Status: Open
Steps done so far: 1) Updated DS
2) Did Manditory Labview Update
3) used crossover cable (pink) opened image tool
4) selected Java. checked format. clicked apply
5) image tool indicated cRIO was in safe mode
6) shut down cRIO toggled safe mode switch and tried again
7) image tool indicated cRIO was in safe mode
8) repeated 6 and 7 several times
9) got frusterated
10) put cRIO in safe mode and allowed image tool to format
11) took cRIO out of safe mode and clicked java but NOT format
12) image tool said cRIO updated
13) cRIO’s status light blinks 3 times pauses and repeats

todo: take a break. register labview and try updating again

C)Problem: Netbeans not uploading code to cRIO
Note: may be related to (B) or (B) may be related to ©
Status: Open
Steps: 1) created new project in netbeans with the simple robot template
2) clicked build main project (basicly a blank program for the robot)
3) netbeans build error no rout to host 10.0.0.2
4) made sure DS set to team
5) netbeans came up with same error

EDIT (1/18/10 7:19est)

D) Problem: Driver station sometimes shows black screen when logging off from driver account
Status: Open
Steps: 1) research - probably a common windows problem
2) Possible solution http://support.microsoft.com/?kbid=328934
More to come and solutions hopefully sooner then later

Don’t use crossover cable

The 10.0.0.2 error occurs when you haven’t set your team number in the FRC Plugin options in NetBeans.

also, when imaging, did you set your Team #?

The one time I had to put it in safe mode to format, I also had to format the second time. Hopefully that works for you.

Make sure to set your team number in the the netbeans options. You won’t be able to successfully upload code until the cRIO is imaged.

We will try. it connects fine but the instructions say to use xover

The 10.0.0.2 error occurs when you haven’t set your team number in the FRC Plugin options in NetBeans.

Thanks I will look into that

also, when imaging, did you set your Team #?

Yes and device name to team346

when i went to image the second time the cRIO did show up with the ip as 10.3.46.2

So we still have no success with re-imaging. Followed the steps on http://delta.ni.com/content/message/3242.

Status light starts off with 3 flashes

  1. Do an IP Reset
    set the IP Reset DIP switch on the cRIO to ON
    push reset button on cRIO
    Set the IP Reset DIP switch on the cRIO to OFF

At this point the cRIO’s status light flashes once

  1. Power off the cRIO, then Power it back on
    2a. Turn off your computer’s firewall
  2. Connect to computer to the cRIO using the crossover cable
    IP Address on computer 10.0.0.6 SubNet 255.0.0.0
  3. Run MAX (Measurement and Automation) to reset IP address (it is now 0.0.0.0) on the cRIO
    Tools\NI-Serial\Ethernet Device Configuration
    This should find the cRIO and show the MAC address
  4. Click Properties and set the IP Address to 10.0.0.2 SubNet 255.0.0.0
  5. In MAX, click Remote Systems and then F5 to refresh and you should now see the cRIO.
  6. Expand the cRIO under Remote Systems,click on Software, and click on Add/Remove software
    Reload the NI-RIO 2.4.1 software

The software was NI-RIO 3. something. Figured it was part of upddate and reloaded anyway.

Afterwords we are back to one flash

  1. Flip the cRIO Safe Mod DIP switch into the ON position.

  2. Reset the cRIO so that it boots into safe mode.

  3. Disable safe mode by flipping the DIP switch to OFF.

  4. Using the FRC cRIO Imaging Tool, format the controller by checking the “Format Controller” checkbox. See the tutorial Using the FRC cRIO Imaging Tool for more information.

At this point in the imaging process we checked the format checkbox and filled in the rest of the information selecting the LABVIEW language.
The program starts by extracting the image then says connecting at which point the lan connection in the tray says cable disconnected. once it reconnects the image program says the cRIO is in safe mode. Power down switch to safe mode run the program again. we proceed with the format this time but even after 20 minutes it still says its formatting. Reset in safe mode off still having 3 flashes and go back to the image tool. try to image and it says its in safe mode.

HALP!!!

  1. The FRC cRIO should automatically reboot and then you will be off and running again.

We ran into this exact same issue when formatting ours earlier this week. The formatting tool does NOT error out when it cannot connect! I discovered that our firewall was blocking it. The program sat and said “formatting” for more than 30 minutes. When the students told me what was going on, I went over, took the Crio out of safe mode, turned off the programming computer’s firewall, and imaged the Crio with no problem.

Do you have ALL firewalls turned off on the programming computer?

I will check it again if all else fails we will also try the solution posted on http://decibel.ni.com/content/message/3360

Windows firewall is Off
in advanced it was checked for LAN now its unchecked
in advanced settings all services were unchecked now they are checked
same with ICMP
AVG webshield disabled
Internet properties local internet security set to low
Anything i missed???

Did I read it incorrectly, or have you not tried turning off safe mode and imaging?

i may not have been as clear as i thought.

first attempt safe mode was OFF.
—error popped up saying it was in safe mode
second attempt safe mode was ON
—error popped up saying it was in safe mode
third attempt safe mode was OFF
—still same error
fourth attempt safe mode was ON
—allowed it to format which never completed

Your detailed description of what you did made it sound like you just turned off the “safe mode” switch without rebooting. It’s hard to be sure what really happened from what you said.

Are you imaging using your own laptop, or by using the supplied Classmate PC?

We were unsuccessful getting it to reimage using my personal laptop - even with all AV and firewalls turned off. But on the first try using the Classmate via the supplied pink crossover cable, it worked fine.

we got it. apparently the safe mode switch was off its rocker (literally). we pushed down really hard while switching it and click its not in safe mode anymore. Imaged fine after a format through MAX. Now to get it to run linux jk jk… maybe later