2010 Wireless Setup

Does anyone know how to set up the 2010 classmate so it can communicate with the robot through wireless? I couldn’t find any documentation to set it up. And how would you set it up to work both with the driver account and the developer account?

Section 2 of the getting started manual has that information, chapter 2.10.4

router      robot wireless---cRIO
|    |
|    |
DS   |
  Dev Laptop

like last year, use same IP setup, just different DS

I tried to do this as well. After searching for settings, i realized the Classmates wireless card does not support wireless N.

The router supports both 802.11g and 802.11n, so you can use the classmate wirelessly - just make sure you have the router configured to accept both. If I recall correctly the setup instructions tell you to enable only 802.11n on the “main” SSID, so if you don’t want to change that just setup a second SSID enabled for 802.11g. The router lets you run two SSID’s at the same time.

For example, we setup our router with the main SSID (“2607”) on 802.11n only, and a second SSID (“2607-g”) on 802.11g only. We leave the main SSID just for the robot bridge to use, and connect programming laptops, etc to the second SSID to keep it clean.

  • Ron
    Team #2607 controls mentor

It’s the same as the old DS. Plug the classmate into the router through the Ethernet port. Make sure in the dashboard you have the team number setup properly as this becomes your IP. For us were were able just to swap the DS’s and everything worked fine. :slight_smile:

Is there a way to use the built in wireless of the Classmate? Not for competition purposes, but for testing purposes?

Unfortunately, the gaming adapter won’t connect to a AD-HOC network aka directly to a laptop. The wireless-n router can be swapped with the gaming adapter on your robot and then you can connect directly. I have done this many times for demos. Running 100% unplugged is great! :cool:

This is great to know. Any special configuration settings needed?

Nope, just plug the cRio into one of the 4 Ethernet Switch Ports. Don’t plug it into the Internet Port, it won’t break anything but it won’t communicate.

You also have to either have a laptop with Wireless-N, or you have to setup the router in mixed mode on the 2.4ghz band for the classmate to connect to it.

Hm… one of our team members “borrowed” the router to connect to the Internet, which has been quite a convenience so far because we only have one Internet computer otherwise.

I don’t know much about routers, but am I right in thinking that we’ll have to give up the Internet access to set up wireless with the robot?

… sorry if I’m kind of hijacking the thread. Maybe I should’ve made a new one.

We’re in the process of troubleshooting the issue with connecting wirelessly to the router from the classmate. When we searched for wireless networks we had the same problem others have had - the router wasn’t showing.

We enabled the 2.4 Ghz band and the classmate was able to see the router. We checked this with several laptops as well. It seems like only newer wireless cards will see the 5Ghz band.