2012 cRio 2 cannot be found

Hey guys,

My team (3926) is trying to setup our new cRio 2 and are having some issues where the imaging tool cannot find it. I am a first veteran (2 years) and I have run into similar issues with the old cRio that were easily resolved by flipping the ip reset dip switch. With the new cRio, I have no access to the switches because the imaging tool cannot find it. I have tried running it over crossover cable with A TON of different ip settings as well as trying to detect it with a router using dhcp. Am I missing something important? Is this happening to anyone else?

What are all of the IP addresses you’ve tried for the PC you’re connecting to the C-RIO? Are you connecting directory from the PC to the C-RIO?

PC to cRio (Crossover and Straight through cable tested)


Through Router:


Did you disable all network interfaces other than the one with the cRIO connection?

No, I will try that today. Thanks for the advice.

I am having the same issue with our new cRIO - FRC2. I have tried similar IP addresses and subnet masks using (cross over and straight through cables). I have disabled all other laptop internet ports and cannot find the cRIO using the cRIO Imaging tool. Here are other details that might be important

  • 15V supply
  • Tried locating the cRIO-FRC2 with and without modules populated
  • Status light blinks twice every 2.5 seconds

Do I need to reset the cRIO?

Thanks for any help!

I have also heard of a team who was able to connect (But not image) with the old imaging tool.

And to confirm, this is the EXACT problem we are having

After reviewing the cRIO II user manual, it appears that our cRIO chassis has detected an error in its software. Basically, the status LED blinking twice identifies this error.

cRIO II manual - pg15 to cross reference status LED modes

This usually occurs when an attempt to upgrade the software is interrupted. The work around is to “Reinstall software on the chassis. Refer to the Measurement & Automation Explorer Help for information about installing software on the chassis.”

Please let me know where to find these instructions to reinstall software for FRC cRIO II in “Measurement & Automation Explorer help”. I tried to cross reference cRIO-II help files in MAX but was unsuccessful.


I was finally able to find my cRIO II by turning off the windows firewall. I recommend you disable all firewalls when trying to detect cRIO devices.

Were you able to find and reimage, or just find?

I have windows firewall off but I will try again turning off Microsoft Security Essentials.

Alright, we finally fixed it. Here is what we did.

  1. Used another computer to detect the device
  2. Set the ip to detect automatically
  3. Formatted the cRio (This will set the ip but fail)
  4. Switched the ip address to 10.xx.yy.6
  5. Disabled all other network adapters (Through adapter settings NOT THROUGH A WIFI SWITCH)
  6. Imaged the cRio successfully:)

how do you switch the ip address? I am on a rookie team and have the same problem with the imager.

Which OS are you using?

  1. In windows 7, you click the network icon in the tray (Looks like this: http://www.iha.dk/files/billeder/itafd/helpdesk/netvaerkservices/wireless/Win7/WiFi1.jpg)
  2. Click Open network and sharing center
  3. Select ethernet (Or whatever network adapter you are using)
  4. Click Properties
  5. Click the option containing ipv4
  6. Enter your info
  7. Close out of all networking windows