2017 Dashboard USB Camera

Prior to installing the 2017 Update Suite, all we had to do was click the dropdown box and select which camera we wanted. We are using a Logitech USB Webcam. Now with the new Dashboard, when we click the arrow, nothing shows up at all. Can someone please tell us what we are doing wrong?

Try this sequence:

  1. Plug in camera, power up roboRIO & radio
  2. On the PC start the Driver Station
  3. Wait for Communications and Robot Code to go green
  4. Wait for camera 0 to appear as a camera selection (it will take a minute)
  5. After selecting camera 0, if the image remains blank, try hitting the Reset button on the roboRIO (or use the Driver Station Diagnostics tab to choose Restart Robot Code)
  6. Wait for everything to come back
    *]Wait a couple of minutes more for an image to appear.

Just wondering, does this mean it can support multiple cameras more easily than last year?

Easier in the sense that the default dashboard comes with two independent camera windows.
You still need to write (duplicate) code to send a second camera stream.
Bandwidth for two cameras still needs to be a consideration, especially with USB cameras.

Will keep in mind. Thanks for the explanation!

After doing all this, it still says, “No Camera Selection”

What language and user program are you running on the roboRIO?

Having the same problem here. We’re using Java. Wondering if anyone got around this.

Have you implemented an image server on the roboRIO?
The camera won’t work out of the box in Java without a little effort.

The LabVIEW default program includes a camera server, but C++ and Java require the user to add one themselves (it’s pretty easy).

Hi, Murphy from 4229 here! (shameless plug)We had the same issue, but I found a solution.

Try updating Eclipse and the FRC plugins. The FRC Update Suite updated the driver dashboard, but didn’t make the necessary updates to the FRC plugins used in eclipse. The CameraServer class has changed completely. It seems like they’re using cscore and opencv now instead of NIVision stuff. If cscore and opencv libraries aren’t included when you create a new Robot Java Project, you’re running an older version.

I just had to click on a little yellow rectangle that appeared and click “next” a few times to get the plugins up to date, but if you aren’t as lucky, you should be able to update it manually. This may help.

None of the vision examples will work with this update. Working example code can be found here.](https://wpilib.screenstepslive.com/s/4485/m/24194/l/669166-using-the-camera-server-on-the-roborio-2017)

Then I had to reimage the roboRIO and reinstall java on the roboRIO so that it was compatible with the new code.

Hopefully that helps.

Yes, my student had done that. I’m not sure what the root problem was, but he fixed it and wrote up a nice explanation and tried to post it here. Looks like the post didn’t make it. I can bug him to repost if anyone else is having the same issues.

Get him to post it.
It’s always good to get closure on a successfully resolved issue.
Someone will be searching for the same answer some day.

This is just a quick post after my other one apparently didn’t go through or something. I’ll fix it up later, but if you stumble upon this and have more questions, feel free to contact me.

Try updating Eclipse. The WPILib has been changed significantly this year.
They’ve stopped using NIVision in favor of OpenCV and CameraServer(cscore) libraries.
This means old code is no longer compatible with the 2017 driver station.
I have autoupdate on, so all I had to do was notice the little yellow box, click it, accept some license agreement of something, then click next a fewe times.
You may have to manually update. Information for that can be found here. (http://wpilib.screenstepslive.com/s/4485/m/13503/l/599670-installing-the-frc-2017-update-suite-all-languages)
Then you have to reimage the roborio and reinstall java on it. Those can be found here and here. (http://wpilib.screenstepslive.com/s/4485/m/13503/l/144984-imaging-your-roborio) (http://wpilib.screenstepslive.com/s/4485/m/13503/l/599747-installing-java-8-on-the-roborio-using-the-frc-roborio-java-installer-java-only)
Some info on the changes can be found here. (http://wpilib.screenstepslive.com/s/4485/m/13503/l/681378-new-for-2017)
None of the old example code works, but some can be found here. (https://wpilib.screenstepslive.com/s/4485/m/24194/l/669166-using-the-camera-server-on-the-roborio-2017)

We are having trouble getting a camera image on the 2017 Dashboard too. We are using C++ and have done everything listed in the above post. We downloaded the Intermediate Vision example to the roboRIO. On the dashboard the drop-down box lists both USB Camera 0 and Rectangle but neither of these produces any video. Any ideas?

Tonight we found out that the camera works fine when the driver station is run on our programming pic but not on the Classmate. The only change to the Classmate this year has been the FRCUpdateSuite 2017.0.0.

What is the minimum necessary to display two HD3000 USB cameras on the Dashboard using LabVIEW?