2017 FRC Update issues - missing DLLs when imaging or running DS

we are trying to get the team PCs updated with the new driver station, having interesting problems. We’re a Java shop, so we don’t have the entire Labview installed.

We have two PCs that had the 2016 Driver Station on them. We went through the deinstall of all NI stuff, then installed the new stuff from the .zip file. O

We had two other PCs that are brand new Windows 7 installs, no previous NI installs. Again, installed from the .zip file.

On all 4 PCs, we cannot run the roborio imaging tool; we get
“The program can’t start because api-ms-win-crt-runtime-l1-1-0.dll is missing from your computer. Try installing the program to fix that problem.”
Not positive that all 4 are calling out the same DLL.

On 3 of the PCs (the new installs and one of the recycled ones), running the driver station results in the same error message. Not positive that all 3 are calling out the same DLL.

We’ve done uninstalls and reinstalls on 2 of them, and the problem persists.\

Thoughts as to what we missed?

api-ms-win-crt-runtime-l1-1-0.dll comes from one of the optional Windows updates.
Keep running Update until the PC Windows is current and the error will go away.

I had this on one of my PCs and actually tracked down the required update, but it has since been rolled up into a later one.

While running updates, if you run into the issue where it take 3 days to just download the recognized updates, you can use this procedure to speed up the process.

from: http://superuser.com/questions/951960/windows-7-sp1-windows-update-stuck-checking-for-updates

(1) Download the following updates for windows 7:
for 32-bit

for 64-bit

(2) Stop ‘Windows Update’ from the Service Manager

Type 'services' in the windows start menu search box.
Launch 'services'
Find 'Windows Update' in the service list and stop it.

(3) Install Windows6.1-KB3020369 by running it to see if it is needed or not.

(4) If it was needed, after the reboot, do step (2) again.

(5) Install Windows6.1-KB3172605.

from: http://stackoverflow.com/questions/33265663/api-ms-win-crt-runtime-l1-1-0-dll-is-missing-when-opening-microsoft-office-file

(6) Run ‘windows update’, check for and install any important updates, repeat until there are none left.

(7) Run ‘Uninstall Programs’ from the Control Panel

select 'Microsoft Visual C++ 2015 Redistributable', x86 and x64 each and uninstall them

select 'National Instruments Software' and uninstall all products as well.

(8) Install Driver Station (C++/Java) or NI Labview

Mark, codedr, thanks. I suspected 'twas a missing update; we tried to run Windows update, but it would just hang, so we’ll use codedr’s procedure.

Will report in with results tomorrow.

Yea, the Update isn’t actually hung, but for some reason it has to be left alone in a corner to work for a couple of days sometimes (and disable power saving sleep), before it completes.

We’ll try hand installing the updates on one PC, and just letting Windows update cook on the other.

Windows update just didn’t show any progress on the progress bar, which made us think “hung”…

I went through the same thing at the start of Beta testing.
I kept stopping it after a few hours, until I finally let it go overnight and then decided to leave it alone for another day.
It finally came back…


I don’t know if the students hand applied the updates, or just let windows update cook for a while (I asked them to try the two different approaches on two PCs, but I saw windows update running on both at one point), but, in any case, after applying several hundred updates over several hours and multiple reboots, all is well.

Mark, codedr, thanks for the help.