2019 CAD Field

So basically, I am trying to access the fields that FIRST has posted on its website at:
https://www.firstinspires.org/robotics/frc/playing-field to try and get field measurements and the like.

When I try to use the SOLIDWORKS’ eDrawings Measurement at https://www.firstinspires.org/robotics/frc/playing-field#CADModels it does not work, it says “files have been surpressed”, either 5 or 7 depending on which assembly I try to access.

I have the most updated version of Solidworks, everything on that end is good. What could be causing this problem?


EDIT: We have given up on using the FIRST provided fields, we re using a GrabCAD version and opening it in Fusion. Thanks everyone for your help!

1 Like

Try opening in SW first, then suppressing missing components (Rocket nosecones). Field asm # is FE-00042 or something similar. GE-19116 Red/Blue and GE-19117 Red/Blue were the issues for me. Otherwise, I have no idea what SW is doing, not that that’s rare.
Good luck…

1 Like

It seems that the suppressed parts were provided as part files, but the assembly is looking for them as assemblies. The best option is probably to make an identically-named assembly with each of the problematic parts in it. Haven’t tried this personally, but I think it should :crossed_fingers: work. Probably going to try tomorrow, although we’re having issues as we only have one laptop with SW 2018.

1 Like

does anyone know if there is a CREO version of the field

1 Like

Does anyone have a link to a STEP file of the field? I’m running 2015 solidworks at home and can’t open these newer files. I tried this file but I keep getting errors when I try and open it.

1 Like

I’m trying to import files into Inventor, starting small with GE-19070 Cargo Ship Full Assembly. The translation report is saying it can’t find the files:
D:\SOLIDWORKS PDM\2019 Game Specific\Mechanical\GE-19079-Left-Blue.SLDASM
… Left-Red
… Right-Blue
… Right-Red
D:\SOLIDWORKS PDM\2019 Game Specific\Mechanical\GE-19080-Left-Blue.SLDASM, Left/Right Blue/Red
D:\SOLIDWORKS PDM\2019 Game Specific\Mechanical\GE-19082-Blue.SLDASM and Red

Looks like somehow they’re pointing to a hard-coded D:\ drive. Also, the SLDASM files aren’t there, but the SLDPRT ones are as GE-19079 and GE-19080 with appropriate vinyl coverings. I’m guessing the assembly is the lexan + vinyl.

I’ll add those in manually, hoping the position is easy to sort out.

I suspect there are a few little details that need to be ironed out with the CAD files.


I tried the same with Solidworks, but it did not work either. Try Fusion360.

The problems were with the files GE-19079, GE-19080, and GE-19082. For Inventor I had to import each individually and re-create the assemblies (plastic part and vinyl graphic using the decal function) then place them into the Cargo Ship assembly.


Also the part GE-19076 had issues. Importing the material from another part helped with the colour. Now to do the blue side…

1 Like

Same problem here. We get errors opening the STEP file on GrabCAD and the SolidWorks file on the FIRST site.

It’s frustrating because FIRST posted the KoP CAD files in a universal format (STEP) but their playing field CAD files will only open in the latest version of SolidWorks.

1 Like

I’ve started another thread including a simplified STEP file with all the important parts (including those that were throwing errors). Grand total only 1.4Mb.

I really appreciate all the work FIRST puts into the details (I like to do the same), but not everyone has a workstation.


Your simple model helped a lot. Thanks!