2019 Firmware Update failing


#1

We’re trying to update our RIOs to 2019 images, but keep getting this error when trying to update firmware:


We’re upgrading from 3.0.0f0 to 6.0.0, and have tried 2 different computers, 2 USB B cables, and 2 different RIOs (the other one is currently on 5.0.0f1 firmware). We can still access the web dashboard on both, and have tried the imaging on both static IP and DHCP. We also tried running the imaging tool as administrator, updating firmware via web dashboard, and booting the roboRIO into safe mode. Windows Defender Firewall is off.

We also tried formatting the RIO that’s on 5.0 and got a similar error. We’re going to call NI once they re-open tomorrow.


#2

Maybe check that there is no space after your team number ?


#3

Make certain you reboot your workstation after the NI install. We get bit by that all the time at CTRE. We’ve seen similar imager errors.


#4

Having the exact same issue. Performed a clean install of windows for kickoff and installed everything for 2019 and it occurs.

Edit: Issue weirdly resolved after the 3rd or 4th time trying. I rebooted, it fails a couple times and worked for no apparent reason.


#5

An update: we tried a third computer, this one using windows 7. It worked with the RIO that was on firmware version 5.0, but threw an error (though a different one this time - “miscellaneous operation failure”) on the 3.0 firmware RIO. We duplicated this on a second 3.0 firmware RIO.

We decided to try to go from 3.0 to 5.0, and then from 5.0 to 6.0. Unfortunately, the tool throws the same error when we try to use it to install the 5.0 firmware, as well, and updating the firmware to 5.0 via. the webdash doesn’t work. We may next try using a not-yet-updated computer to migrate to 5.0 with last year’s firmware update tool.

I’d like to express some displeasure at NI for releasing such a buggy mess of a tool, given that the release date is the start of build season. If this were a month or two earlier, it’d be different - but we need this time to develop actual functionality, and it is immensely frustrating to waste it dealing with this.


#6

I had a team encounter this issue at our kickoff event. We resolved their issue by changing the computer name to only contain alphanumeric characters (ie LAPTOP-01 -> LAPTOP01). However, renaming the computer forces a reboot, which may also solve the issue as mentioned above.


#8

Alas, we tried this already, to no avail.


#9

To upgrade firmware, I would recommend the following:

  1. Make sure you are running the roboRIO imaging tool as administrator
  2. Make sure there is no firewall or anti-virus in the computer that is blocking the network connection to the robot or denying access to the files (for examples, to the directory where the firmware is stored)
  3. Try setting the roboRIO in safe mode (hold the reset button until the STATUS LED lights up).
  4. As others have mentioned, try different computers
  5. If nothing else works, you can use NI MAX to Upgrade firmware: Upgrading Firmware on my NI Linux Real-Time Device. If you do not have NI MAX, please install: NI CompactRIO 18.5

Please let us know if this is still giving troubles and the steps above do not let you move forward with your robot.

Edit: Please try with the NI CompactRIO driver, not System Configuration.


#10

As stated earlier in the thread, we have done all of the things you’ve listed except number 5. We will try NI MAX tomorrow.


#11

When you are putting the roboRIO into Safe Mode (or really whenever it is failing the upload), is the status light continuously flashing or is it flashing a code (2 flashes then off for a period or 3 flashes and then off)? If continuous, then you’ll definitely need NI as that is a catastrophic issue that you probably won’t be correcting yourself.


#12

During the beta period, I found that I wasn’t able to upgrade from 3 -> 6 directly, but had to go 3 -> 5 -> 6.


#13

We have updated ours successfully with no problems from 3.0 to 6.0. Did you make sure to disable all other network adapters including Wifi and Bluetooth?


#14

In Alex’s case, the issue still occured, but +2 for working off of a clean install. In 2018 and 2019, after structuring our installation process more with internal documents detailing order, **(providing all is done on a clean install of windows, (**we have been able to install a development environment, all National Instruments software minus LabView (i.e. imaging tool, driver station) on the first try and have everything work.

+1, this was the only hiccup we found when updating firmware in the beta and after kickoff, but one should also consider we also had RIOs starting at versions higher than 3.0 and we had done clean installs onto laptops we had tested this on.

on a Windows 10 Pro Education (unactivated) clean install PC we found it unnecessary.


#16

NIMax does not appear to work.

Our next strategy will likely be to find a computer with last year’s updater still installed up on it, and use it to move to 5.0 as an intermediate step.

I would like to reiterate that I find this kind of unreliability unacceptable in such a crucial tool released at such a late time. NI is not doing very much to entice me (or anyone on my team, or many other teams) to become a future, willing customer.


#18

Please try with the NI CompactRIO driver, not System Configuration. I apologize the confusion.


#19

This worked on our remaining 3 RIOs. The full process I ended up using was as follows:

  1. Rename the desktop computer to have only letters in the name.
  2. Install NI System Configuration
  3. Install the CompactRIO drivers
  4. Turn off all network adapters except for the USBLAN driver
  5. Run NI MAX as administrator
  6. Boot the RIO into safe mode
  7. Follow the instructions here and upgrade the firmware to v5
  8. Reboot the RIO into safe mode
  9. Upgrade the firmware to v6
  10. Use the regular imaging tool to format the RIO to the correct image

For one of the remaining RIOs I didn’t have to boot into safe mode, turn off adapters, or run as administrator, but for the other two I just did all of those at once after it wasn’t working, so not all of those steps may be necessary.


#20

Thanks for the feedback and detailed steps @noah.gleason!

We have compiled a comprehensive guide with steps here: 2019 FRC Firmware Update Failing

I presume that bypassing the second should still show the same results, since NI CompactRIO installs NI MAX, too (my mistake in the original post) :slight_smile:


#21

this command: nisystemformat -f -t ubifs && nisystemformat -f -t ubifs -c
from this ni forum https://forums.ni.com/t5/FIRST-Robotics-Competition/Recovering-RoboRIO/td-p/3463615

helps resolved my roborio imaging problem


#22

We saw this error during beta but NI was unable to repeat the problem. We found a workaround at the time of installing labview even though we are a c++ team. So this might be worth trying.