2020 Field CAD for SW >2020?

Maybe I’m just overtired already or this is just the boomer in me or whatever, but has anyone found a link or source for a file for the field that will open in a version of SolidWorks that is not 2020 edition?

Somehow it is day 6 and I have still not been successful in opening a model of the entire field.

boomer https://grabcad.com/library/frc-2020-infinite-recharge-field-1

Annotation 2020-01-09 155556

Error message I get when I try to open this STEP file, and a pic of the import settings for STEP files.

Try exporting this and downloading: https://cad.onshape.com/documents/de32ed0509955166ad460f78/w/efa361711f349134c472ed6e/e/b2925ecc8e2a28b5cbc92558

I’m on 2018 and I was able to open the one I sent you.

Have you been able to open other STEP files?

Would a STEP (will download upon clicking) file work? IIRC SW already said a pre-2020 vers isint coming out, but i cant find it offhand.

The grabcad link I shared was for a STEP model of the field and he seems to be having issues importing it.

What version of SolidWorks do you have?

I can confirm that the main link on the playing field webpage will open in SW2019.

https://firstfrc.blob.core.windows.net/frc2020/PlayingField/INFINITERECHARGEField.zip

1 Like

Fixed it. This link is what solved the issue for me in case anyone else is having issues opening the STEP file. I have never had to do this when opening a STEP file before. My 3D Interconnect was already disabled.

EDIT: I am currently using SW 2018.

1 Like

this STEP file is from Autodesk, which i think* is different

*no basis for this, i just know its on a different site.

Odd since I’m on SW18 and I was able to open that STEP tile fine.

FYI, if you are ever having issues exporting and importing a STEP file into SolidWorks, use the Parasolid .x_t file format instead. The native .SLDPRT file format is based upon the Parasolid file format, so SolidWorks can usually open .x_t files with a lot fewer errors than STEP files.

2 Likes

Definitely agree with this. I’ve kind of ignored the 3D Interconnect stuff since it was added in 2017, and when I had an issue before in the past disabling that feature fixed the issue. I sent really read up on it until now. Apparently SW is supposed to be able open models from other software like Inventor without having to go to a neutral file type. Has anyone used this that could provide me any tips. Being able to open Inventor files straight up is something I would definitely use in the immediate future.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.