2020 Online Field Explorer with Measurement

I got tired of having to open a CAD model every time I wanted a simple measurement since NASA’s webapp lacks any gauge of distance or a way to view things from first person.

So I made my own. Here it is.

The model is from the original CAD, so all measurements should be accurate (Switchable between Metric and Imperial). In addition, you can set the height of your eyes, so you can view the field from your robot’s perspective.

I really like being able to just get numbers in arbitrary points in the field, especially for calculating cycle time with drivetrain simulations. I hope you guys have some use for it as well!

Changelog
1.01: Decreased movement jerkiness. Stopped Chrome from thinking I want your credit card.
1.02: Fixed metric to imperial conversion. Made it impossible to fall off the map (probably)

15 Likes

This is pretty cool!

Two things though: first, the acceleration when moving around the field is pretty large (it took me some time getting used to the velocity of me moving around the field), so it’d be nice if you could tone it down a bit. Second, the SSL certificate of the site isn’t active or something, since Chrome is giving me this alert:

Yeah, our certificate seems to have expired; I’m working on getting it back up right now.
I’ll be sure to make the movement a bit slower; I’m glad you enjoyed it!

2 Likes

SSL Certificate and slower movement are posted :smiley:

3 Likes

Sweet, this is awesome!

I fell off:

4 Likes

Neat! One problem I’m seeing is that switching the measurement between metric and imperial doesn’t actually convert the units, it just changes the label on the measurement (i.e. the measurement stays imperial, but it is labeled as “feet”.)

Yeah, seeing the same thing here. Here is an example of “far side” of the trench to the outer target - certainly more than 12 feet!

But - this is very cool - a great tool for planning! Thanks!

It is likely that the imperial/metric does not actually work. That distance is approximately 11.2meters. You would have to do the conversion yourself.

Super awesome resource though!

These are always really cool! You may want to join the Autodesk Synthesis team :slight_smile: . They have a very similar simulator, but also have some quirks to work out (like a robot that is always juuuuust slightly moving even with no controls applied).

1 Like

Yeah that was a simple error on my part. The unit conversion should be fixed now, and @gerthworm should be able to stop falling off the map :stuck_out_tongue:

2 Likes

This is really nice. One thing to note here is the frame rate. I’m running a GTX 1070 and still have issues with extreme stutter and the FPS dropping down to about 15fps. Might want to drop entities or the detail in which rendering happens. Otherwise, it’s a great tool!

Do you have hardware acceleration disabled? I am also running a 1070, and run at almost 60 fps.


Seems to be on. Just tried with edge as well. Tried turning off, dipped my fps to like 3. When I see how hard my 1070 is working it seems to not cross 20% like ever for some reason. CPU is at 50%. Unsure what problem it is on my side.

Still love this. One more issue I face:

Changing the height to .7 (trench bot), I lose the capability to move around the field. Seems like anything under .9 causes this. Sometimes when set below .9 the robot just starts moving on its own till it hits something. :slight_smile:
(Thanks again!)

You can bypass that by doing this:
When you are on the error, type on your keyboard
thisisunsafe

And it will proceed to the site.