2020 WpiLib

team 3218 is not one of the WPILib beta testers for 2020. We just downloaded the 2020 update suite from NI, but we can’t run our code now because we are missing the wpilibj2 package. Is it publicly available to teams yet?

Do you mean the new command based framework in the wpilib2 package? That has been made a vendor library in 2020. The JSON file is here: https://github.com/wpilibsuite/allwpilib/blob/master/wpilibNewCommands/WPILibNewCommands.json

Also isn’t the update suite encrypted before kickoff?

1 Like

No we just installed the 2020 Update suite and it gave us the roborio 2020 image, not 3 hours ago.

And it appears the new command based framework is what we do want.

Where exactly did you get this 2020 Update Suite from and how were you able to install it?
Edit: This is not expected to be public before kickoff, but oh well.


Looks like it’s here and renamed to “FRC Game Tools”. Don’t know if it’s intended to be public, but I’m checking it out right now since I highly doubt there’s anything game-sensitive. (and if there is, I’ll report it) https://www.ni.com/en-us/support/downloads/drivers/download.frc-game-tools.html#333285

1 Like

Were you able to go through the whole installation process?

I’m still in it right now. It doesn’t seem to need a license key like in previous years, so there’s no issues yet.

Edit: There’s a key prompt for the vision module, but it doesn’t seem to be locking me out of the rest of the install. Also, it automatically overwrote an old install, which is nice.

Edit 2: The field sounds are included and they’re still the same, for anyone concerned about that.


We were installing this year’s version of Labview and updates tonight as well. We are running into the problem that we cant’t the REV and CTRE palettes to install. The REV api are loading up into the 2018 Labview directory. We tried to copy them over to the 2019 directory and they still won’t show up.

You will need to wait for 2020 Vendor Libraries to be released by the vendors. 2019 libraries will not work correctly. I believe some internals changed causing even copying to not work anymore.

Any idea when the vendor libraries are due to be released?

I installed the update (that page is linked to a few clicks deep from ni.com/frc) and created a standard roboRIO project. I opened Robot Main.vi which has a good run arrow and then I did a build of the project which finished succussfully. I don’t have a roboRIO to test deploying though.

Yesterday I think it was (before I installed the FRC update) I was having trouble activating some components but I tried again now and it looks like it is all good.

I’m not by any means an official source of information, I didn’t know this update was coming early till I saw this post. But I would think that would be up to each individual vendor.

I will assume CTRE and REV will release a update before 2020 at the earliest and before kickoff at the latest. Worst case would be week 1 or 2 of build season.

That might explain some of the issues I had last night…

Are you sure it was the 2020 FRC update, and not the 2019 FRC update?
I was just there and you can install Labview 2019, but I could not find the 2020 FRC update.
If you found it, can you post the exact link?
Jack Gillespie

Looks like the documentation has been updated for 2020: https://docs.wpilib.org/en/latest/docs/getting-started/getting-started-frc-control-system/frc-game-tools.html

So, does this mean I can run 2020 WPILib on a roborio now? I have my 2020 WPILib fully configured with the 2020 vendorreps and everything, but if this install comes with the 2020 roborio image im set, right?

There is currently no release of WPILib that supports the v10 public image. The Beta 4 release (for beta teams) is only compatible with v9.

If I’m following correctly, the current wpilib release is Version 2020.1.1-beta-4 and it uses RoboRio image 2020v9, but the Game Tools installer listed here uses the 2020v10 image?

That is correct.