2CAN: not detecting CAN traffic

So my team has used CAN for 3+ years, but we’ve never used a 2CAN before. We recently decided to try one out and got a 2CAN 2.0, however when we installed it (hardware, firmware update, and plug-in) and tested CAN functionality with our unmodified code, we got a fast red strobe on the status light and the web dashboard indicated there was no CAN traffic.

We’re pretty sure this isn’t a wiring issue since we just added the 2CAN into our 2013 robot, which worked with the serial adapter.

We have:

  • 2CAN 2.0 (fw ver_2.28)(Plug-in was the default plug-in already on the cRIO)
  • Black Jaguars (pretty sure they are v107)
  • 4 Slot cRIO

Any help would be greatly appreciated!

Remember when switching from serial based CAN to the 2CAN, you have to go into the Imaging Tool and select the 2CAN plugin and select “Apply” (you do not need to reformat the controller). This will load the correct plugin to let the controller talk to the 2CAN.

I believe that the Imaging Tool loads with the 2CAN plugin by default, be sure to click apply just to make sure and power cycle the entire robot. I’d also make sure you have a termination resistor at the end of the chain.

Thanks! I’ll make sure to try this ASAP.

Just out of curiosity, does the Imaging tool do anything that adding the plugin through FTP(which is what the 2CAN manual says and what I did) doesn’t?

I’ve just always used the Imaging Tool to activate the plugin. I haven’t actually tried to use the FTP method since the first year the 2CAN was available.

Pretty sure it adds the plugin to the start-up ini file so that the plugin actually gets loaded.

Did you remove the serial can plugin when you modified the ini file? I assume they will conflict if both are loaded.

No I didn’t, and I’m pretty sure they do conflict since I tried to revert to serial CAN when the 2CAN wasn’t working and also got CAN errors.

I’ll re-image the cRIO with the imaging utility the next chance I can get access to the robot (prolly next Thurs) and update the thread with what happens.

Thanks, everyone, for all the help!

So I re imaged the cRio with the 2CAN plugin selected. However, after the cRio was rebooted and power cycled, the 2CAN still had a red strobe and indicated it could not detect CAN traffic.

Interestingly enough, when I accessed the web dashboard and changed the CAN bandwith to the lowest setting (125kb/s) the 2CAN status light turned green and the web dash indicated that CAN communication was good and error free. However, the web-dash didn’t indicate any data for any of the CAN nodes (ie temp, load, etc were all 0) and additionally when I tried to run our code, the cRio was returning CAN timeout and device not detected errors.

At this point I’m thoroughly confused, especially since after all this I reverted to the serial adapter configuration, and it worked perfectly. Does anyone have any insight as to what’s going on?

Yeah definitely leave the bitrate at 1Mbps. That’s what used in FIRST, the other bitrates are for non-FIRST uses and definitely won’t work. Also the RED led state will stay RED until 2CAN sees some CAN traffic regardless of the firmware level/ plugin, or presence of the cRIO. It does sound like a cabling issue which is strange since you mentioned you just swapped out connecting the RJ11 from a Jag to the RJ11 of the 2CAN.

Can you try this simple setup after setting the bitrate back to 1Mbps : take a powered 2CAN and a single powered jag and connect their RJ11s together. 2CAN will automatically poll for the Jag and will switch to orange LED if everything is well.

One difference between the 2CAN and serial gateway is the 2CAN has an internal 120 ohm termination - that way you only need to add 120ohm at the end. With serial gateway you have to terminate both ends. So you might want to remove one of the termination resistors.