40 amp draw at rest

If our robot is enabled but with zero input, there is a constant 40 amp draw. It is causing us to drain the battery extremely fast, causing brownouts due to low voltage as early as 30 seconds into the match. We suspected it was the PDB, but we’ve replaced the entire board and all the fuses and it’s still an issue.
We asked other teams at the same event (Bloomington) and there are two others with the same problem.

If anyone has had this problem and knows what it is or how to fix it that would be awesome as everyone here is completely stumped.

Start unplugging things until the draw stops. Then you’ll have it isolated and can replace or repair the fault.

Edit: I’d start with all of breakers, one at a time, because they’re easy. However if this happens with the robot disabled then it is unlikely to be a motor controller related problem.

3 Likes

Exactly this, pull the breakers from the PDP until the large draw stops. You can either start full and remove or start empty and add. Both will help identify the problem.

We have already tried this, and the draw didn’t stop. Any other suggestions?

We have already tried this, and the draw didn’t stop. Any other suggestions?

Have you done a continuity check between the components and the frame, etc? You should be reading open circuits between any electrical component and the frame. We had a short we discovered earlier this year between the PDP and the breaker. This would not show up by just removing breakers.

Yes, we have. There is no continuity between the PDP and the breakers.

Do your driver station logs show current draw on any of the channels? It should log even when disabled, but at worst it will log while enabled and sitting still.

1 Like

Make sure your PDP firmware is up-to-date. It should be on firmware version 1.40

Don’t just pull one breaker at a time, pull them all and add them back one by one. I’m suspicious of reverse polarity somewhere.

Also, 40A x 12v = almost 500W going somewhere. See if you can find what’s getting hot

4 Likes

So you’ve literally unplugged everything? Fuses, breakers, vrm, pcm, Rio, custom circuits cameras, lights, unbolt pcm, etc? If not that’s what you ought to do.

Given that no breakers are tripping, apparently, I’d start with main power wiring and throughly check that there are no stray conductors or damaged insulation.

1 Like

Update your PDP firmware. We had the same issue. The current draw was not real and it went away wit the update.

OP has identified physical symptoms: browning out really early in matches. Unlikely that it’s a firmware issue and another issue causing brown outs. But it is possible.

1 Like

If you’re still drawing current when EVERY breaker is pulled out then your PDP is either toast or there’s some kind of issue between the battery and the PDP, or some kind of ground fault where there shouldn’t be.

2 Likes

Are you measuring the 40A draw through PDP logs, or by using a clamp-on ammeter/multi meter? Given that Guy said they had a phantom draw that was fixed by updating PDP firmware, I would try to verify the current draw physically with a clamp-on ammeter. If it really exists, you can clamp on to wires one by one to see where the current is going.

While I don’t know much about the situation, multiple robots at bloomington had a similar issue.

My team has a similar phantom draw (though not 40A) shown in the PDP. We haven’t tried updating the PDP firmware though.

It’s possible that the brownouts are caused by something else, and it’s just coincidental that they noticed this 40A draw at the same time.

1 Like

To be clear. We also saw 40A draw being measured from the PDP when all breakers were removed. At that point we knew it had to a measurement error. Almost 500W of power going somewhere would be producing a lot of heat. The PDP update corrected the measurement error.

Not saying the OP’s robot does not have an actual high current draw issue when running but this 40A draw at rest error is in all likelihood a “phantom” measurement as ours was.