404 Error during robotpy-ctre, robotpy-rev wheel building

RobotPy throws a 404 error when installing robotpy-ctre and robotpy-rev on Windows (x64):
ERROR: Command errored out with exit status 1:
command: ‘c:\users\robotics\documents\github\2020-green\venv\scripts\python.exe’ ‘c:\users\robotics\documents\github\2020-green\venv\lib\site-packages\pip_vendor\pep517_in_process.py’ build_wheel ‘C:\Users\robotics\AppData\Local\Temp\tmp2_nrbvre’
cwd: C:\Users\robotics\AppData\Local\Temp\pip-install-su9h9u8l\robotpy-ctre
Complete output (8 lines):
running bdist_wheel
running build
running build_py
running build_gen
running build_dl
Downloading http://devsite.ctr-electronics.com/maven/release/com/ctre/phoenix/api-cpp/5.17.6/api-cpp-5.17.6-headers.zip
104%Downloading http://devsite.ctr-electronics.com/maven/release/com/ctre/phoenix/api-cpp/5.17.6/api-cpp-5.17.6-windowsx86static.zip
error: HTTP Error 404: Not Found
----------------------------------------
ERROR: Failed building wheel for robotpy-ctre
Building wheel for robotpy-rev (PEP 517) … error
ERROR: Command errored out with exit status 1:
command: ‘c:\users\robotics\documents\github\2020-green\venv\scripts\python.exe’ ‘c:\users\robotics\documents\github\2020-green\venv\lib\site-packages\pip_vendor\pep517_in_process.py’ build_wheel ‘C:\Users\robotics\AppData\Local\Temp\tmpoml56i2h’
cwd: C:\Users\robotics\AppData\Local\Temp\pip-install-su9h9u8l\robotpy-rev
Complete output (8 lines):
running bdist_wheel
running build
running build_py
running build_gen
running build_dl
Downloading http://www.revrobotics.com/content/sw/max/sdk/maven/com/revrobotics/frc/SparkMax-driver/1.5.1/SparkMax-driver-1.5.1-headers.zip
110%Downloading http://www.revrobotics.com/content/sw/max/sdk/maven/com/revrobotics/frc/SparkMax-driver/1.5.1/SparkMax-driver-1.5.1-windowsx86.zip
error: HTTP Error 404: Not Found
----------------------------------------
ERROR: Failed building wheel for robotpy-rev
Failed to build robotpy-ctre robotpy-rev
ERROR: Could not build wheels for robotpy-ctre, robotpy-rev which use PEP 517 and cannot be installed directly

As per the documentation, you need a 64-bit Python installed to install robotpy-ctre. Recommend uninstalling the 32-bit python you have, and installing a 64-bit one from the python website.

1 Like