A List of Problems

Okay so as of yesterday I installed the firmware update on the DS, I posted a thread and got the answers to fix it, however, after I updated the DS with the firmware I updated the DS with our team number. I then restarted the the DS and then looked at it the Victor 884 speed controllers and they were flashing an orange light, and they were working before I installed the firmware update, but now after, the Victors just flash, we tried the dongle and it doesn’t work on either enabled or disabled. So any suggestions on what to do?

Did you also update the firmware on the cRIO (V7)?
After the firmware update the DS won’t talk to the out-of-the-box cRIO.

No we didn’t update, so I’m guessing we do the update through the tether right? And we get the update from the FIRST site… I believe not sure :confused:

hold on where do you find the update for the cRIO?

You get the updates from the FIRST site.

The cRIO update is embedded in the latest LabVIEW Update 2.
After you’ve installed Update 2, start the “FRC cRIO Imaging Tool” (it’ll be on your desktop).

Choose “Format Controller”

Enter a Device Name of “FRC-cRIO-2429”
and enter your team #

It’ll take about 5 minutes to complete the update.

P.S. The directions are in the Control System manual section 5.1.2

Okay we updated LabView V2 on the computer, opened up CompactRIO Imaging and it says:

No CompactRIO devices were found. Verify the network connection.

We rescanned the drive, but stil same message, so what should we do?

Everything’s powered up - DS, cRIO?
Everything’s connected?
Your PC to the DS ETH2 port
The DS ETH1 port to the cRIO port 1

Your PC is set to an IP of
and subnet mask of

Firewalls need to be turned off on your PC.
If you have a network card that should be turned off too.
There are a bunch of PC things that block or obstruct network access.

Okay update of both cRIO, and DS is officially over with, yeah!
But now 1 more problem, I hope, and then I think we are good, I realized when I tried to download code, the code didn’t go on. To test this theory I flipped the autonomous switch, and the supposed prewritten autonomous didn’t run, so I know 100% it’s with the target or something, so do you have to set the target, how, and where to? Anything else we should know for downloading code?? TY for the help :smiley:

It depends first on what code you started with:
– LabVIEW Basic or Advanced or one of the examples?
– Wind River template or example?

When you switch to autonomous does the status light on the Digital Sidecar start to blink by any chance?

If you’re using a LabVIEW Basic/Advanced Framework then you set your Target IP when you first create your project. If you forgot to then you’ll see it in the Project Explorer as:
“RT CompactRIO Target (10.xx.yy.2)”

Okay we are using WindRiver, example, not template.
So I see on the top bar there is a target option, so I’m not sure what to do… can you help us?:confused:

Anyone know how to set the target, using Wind River example? :confused:

Take a look at the C Programming Guide for FRC.pdf to see if that helps you.
It’s located on your laptop at: C:\WindRiver\docs\extensions\FRC
Starting on page 13 it describes how to setup the environment and download a program.

An updated copy was installed with the latest Wind River update (http://www.usfirst.org/frccontrolsystem ).

One of the things you need to do is to go to Windows on the top menu bar and select Preferences.
Under Preferences you’ll see “FIRST Downloader Preferences” and in there you need to set your team number, and find the “.out” file that your example generates. You can locate it by drilling down through your project files in the Wind River Project Explorer in the upper left window.
The .out will be under whatever project directory you’ve made. Mine happens to be C:\WindRiver\2009. For instance, I have a Simple Template project and the .out is buried under: C:\WindRiver\2009\SimpleTemplate\PPC603gnu\SimpleTemplate\debug\SimpleTemplate.out

Which of the examples are you using? An FRC one or one of the others that runs a generic C++ program on your PC?

we are using an FRC template.

We have a problem.:yikes:

Okay, when I saw the problem I went through and made sure everything was connected, everything powered, the dongle in enabled, ect…

The problem is that when we turn on everything, with the DS on and tethered to the cRIO, the victor884s blink the orange light, yes the DS is enabled, and yes we have updated the firmware on the DS, and re-imaged the cRIO, and updated LabView on our comp, and set up the wireless bridge even. The PWM cables are in 1 & 2, ethernet in port 1 to port 1, ect… I was going to call FIRST tech service, but I wanted to come here, see if there were any suggestions on what might be wrong so if anyone can lend a suggestion to what the problem may be, please let us know, ty!

That sounds like you haven’t permanently downloaded a program using the top menu bar FIRST -> Download to put your program on the cRIO.

What you describe is what you get if the cRIO isn’t running a program.

You might have accidentally zapped your driver station and/or cRIO

Read this link:http://usfirst.org/uploadedFiles/Team%20Update%205.pdf