I’ve revised the scripting setup slightly so that the written scripts are slightly more readable (not what I eventually want, but better.)
Here’s the default script rewritten in this format:
BEGIN_SCRIPT(command_list)
GYRO_BIAS
WAIT_FOR_BUMP
WAIT(1000)
DRIVE(1500)
WAIT(4000)
TURN(-1500), 50)
WAIT(3000)
DRIVE(2400)
WAIT(4000)
TURN((PI_MRAD / 2), 50)
WAIT(4000)
DRIVE(2400)
WAIT(4000)
TURN((-1500), 50)
WAIT(1000)
DRIVE(0)
KEEP_HEADING(240000, 100)
JUMP(1)
END_SCRIPT
The argument to BEGIN_SCRIPT is the name of the script in code (must be “command_list” unless you modify robot.c )
I’ve attached the required header, and have posted it (or will if not already) to frcoder.
A few of the commands in the header are not in the default code. If you use them, it won’t compile.
[edit=2]The header and more usage notes are now at frcoder. I wrote this file entirely, so it is under LGPL like the rest of the site.[/edit]
Script.h.txt (1.52 KB)
Script.h.txt (1.52 KB)