A problem of FRC network firmware

l can’t load the firmware successfully. l have close my firewall and other network devices except the Ethernet . But when l click the “Load the Firmware” button in the FRC Radio Configuration Utility. It reminds me to “plug ……” (but the other settings was correct .) When l click the “Configure” button , it succeeds accidentally. After l have done this , l can see the robot’s Wi-Fi. But when l connect to it , the Driver station shows “There is no Robot communication”. (I have already open the services of NI mDNS).

So, what’s the problem?

Whenever I have had the Radio Configuration Utility not work it was because the ethernet cable was plugged into an ethernet-USB adapter. In my experience the cable needs to be plugged directly into an ethernet port.

No robot comms may come from a bad connection on the roboRio end?

Best bet is to plug into the Ethernet port closest to the power port. Power up and wait – the radio takes a long time to boot. If, after say 5 minutes, you are not finding the radio, you can reboot (power cycle it) and it should be found as it comes up through the bootloader.

But, if you are connected via Ethernet, seeing the radio, and not seeing “Robot Communication”, it probably is not the radio. It may be the Ethernet connection between the radio and the RIO, or it could be some issue with the RIO itself.

Maybe try the steps here? This is a good starting point, based on what you’ve said so far. If things are still not working, pictures of the wiring and a screenshot of the driver station status panel would be helpful. If you have the right USB cable, connecting directly to the RIO this way is often helpful. You can also connect the Ethernet cable directly to the RIO.

My laptop is Thinkpad X390, it only has one mini Ethernet port.Does it matters?

I have already tried these methods and they don’t work at all. The next time l will send you the screenshot

Looking it up, it seems that laptop does not have a dedicated ethernet port. I’m not a networking expert by any means, but the USB-to-Ethernet adaptors do not work in my experience.
Are you using something like this:


Try to find a computer with a traditional ethernet port, install the radio config utility, and see if it works.

We have used ethernet adapters in the past and they have worked. Sometimes you have to reset the AP by holding the reset button

I have already tried this but it doesn’t work at all. When l click the load firmware button, it still reports the same error.

I don’t use the the usb port , and it’s the mini-Ethernet type transformed into RJ 45 port

From what you have said, I would focus on the RIO – not the radio. If you have the right cable, this is the best way to ensure the RIO is healthy. I’ll look at the screenshot when you post it – this will be helpful.

Here are some steps you can take to troubleshoot this yourself, might cut down on the back-and-forth…

l can use the Ethernet but l can’t connect to my robot’s Wi-Fi.

If in doubt, use an USB cable to connect from your PC to the Rio’s USB Port (client port)

1 Like

This isn’t very helpful, because it doesn’t say exactly what you did to try to connect. That’s why a picture of the status panel I showed is so helpful – it was designed to help to isolate problems in this area and has a lot of very specific information in it. Without this kind of detailed information, it is very difficult to help.

Please confirm that you have followed this procedure to image the roboRIO and set your team number. If you have done this, you should be fine as far as firmware, because you seem to have set up the radio properly (but be sure you put in the right team number when you did this).

If you are getting to the radio (the screenshot would confirm this) and you have the roboRIO set up properly, the only other thing is a standard Ethernet cable between the radio and the roboRIO. This isn’t a likely source of trouble. Has this ever worked for you? There are some less likely possible problems, but the first things to do are to try imaging the roboRIO and send an image of the diagnostics tab.

And now the problem is this and how to solve it ?

While it may be useful for the future to figure out why this is failing, if pressing “Configure” succeeds in configuring the radio as you mentioned earlier, the radio firmware is up to date and this firmware flashing step shouldn’t really do anything to help.

If you had the radio configured and were able to connect to the robot network, your problem was somewhere else (radio team number not matching rio team number, rio not configured properly, computer adapter not configured properly, firewall on, etc.)

@mendax1234 Not sure if you’ve tried this already, but if I recall correctly you have to power cycle the radio during the firmware loading process otherwise it will fail. Hence the “Timeout flashing radio” message since it may be waiting for a power cycle. Also, ensure that you are using the most up-to-date radio configuration software, which right now is 20.0.0.

Hope this helps. :slightly_smiling_face:

1 Like

so, how to power recycle?

Simply remove the power cable from the radio, then plug it back in. It should tell you when to remove power, but if it doesn’t, it’s usually good to do it shortly after it says “Radio found. Flashing firmware.”

Thanks a lot,but l use the vrm to power my radio and can l shut down the robot to power cycle?

It’s usually simpler to unplug the cable from the radio, at the radio end of the cable. The fact that you’re powering the radio from the VRM makes no difference for unplugging cables from the radio. Unless you hotglued everything in… which isn’t exactly recommended for the radio itself.

You’ll need to pull the barrel connector out of its port on the radio. If that doesn’t power the radio off, you probably also set up the POE power option (which is good, except for this very specific case where it means an extra 2 seconds of work), and you’ll need to pull the Ethernet cable as well.

As far as shutting down the robot to power cycle: That will also work. As long as the rest of the robot’s electronics won’t mind being shut off (that is, you’re not doing other work that hasn’t been saved with the robot at the time), that’s an option.

1 Like