AAAUUUGGGHHH!!! RC NOT RUNNING!!!

:ahh: What does orange-green-orange-green mean for the program state LED?
:ahh: When I download my competition code with printf, I get that. When I download without, I get an infinate loop error. :ahh:
HELP?!?!? :confused:

And the default code works

[edit]I’m hitting refresh till i get a response! im frantic! i pnaicing! im not spellchacking! HELP!!! :ahh: [/edit]

I’m getting the same problem too, only for me, it runs without the autonomous code, it gives the code error thing when i load the default IR code, and does the flashy thingie when i put my autonomous code into it (even if i dont ever call it). So dont think you’re the only one.

-Kesich

I’m gonna kill my engineers; lets see if they take 6 weeks to build it next year…

try updating the firmware… or if you already did try hitting it with a hammer until it works

Already updated firmware. And i don’t use hammers on electronics

Say, There is a compile option for large/small space. Would that have to do with this?

Never heard of the error before, but you might want to try the hard reset as detailed in Team Update #7. G2G

I’ve done the hard reset, updated the firmware, everything. This sort of error is just not listed. And i also do not get a RAM dump before you ask.

first released an error in the default code where the variables were not initlized at the begening of autonomus mode. check to see if you have the latest version of the default code.

I’m running my own code, and Uer_Autonomous_Code() and Default_Routine() have been totally rewritten. (I call default_routine Map_IO()).

Sorry if this is overly obvious, but make absolutely sure that you have both a Getgata(&rxdata) and a Putdata(&txdata) function call in whatever loop you are executing. If the user doesn’t handle data properly it shuts itself down.

If your code (not data, meaning variables) is over 32k (I think. It might be 64k) in compiled size, you have to use the large memory model. Check the size of the .HEX file. If it is greater than 32k or 64k and you don’t have any large arrays or stuff like that, try the large model.

Try downloading the default code (sorry if you already tried this). It might be that somehow your code is entering an infinite loop/it takes too long to process something and the master processor shuts it down. We had this happen to us do to a hardware component malfunstioning and our code wasn’t built to handle the values it was recieving.

–EDIT–
That second error would be indicated by a flashing orange LED, so I don’t think that is it.

After e-mailing IFI about it, it turns out in Kevin’s interupt code, I accidently set timer1 to High Priority :yikes:. I would post it here, but I’d rather save it until after regional (maybe just Buck-eye, not West MI). I’ll test it tonight and tell you about it.

What about the other Problem? If I don’t include a #define, printf_lib doesn’t get compiled (My design), and I get a green-orange-green-orange I described in the first post. :confused: IFI says they can’t recreate it. Help?

I got the same error and fixed it by following these steps:
1)Press and hold the RESET and PROG buttons at the same time.
2)Release RESET; continue to hold PROG until the “Battery Power” light becomes a solid green
3)Release PROG
4)Hit Reset

I don’t know if this will help but it fixed the problem for me so i hope that it does for u too. :yikes:

tried and tried again. still nothing. and i never changed kevin’s timer interupt code, but ill check anyways.

I believe the timer initialization needs to be changed to enable them.

Aparently, that bug fixed both problems (Sort of, with printf() I get garbage)

Since nobody else has mentioned it on this thread, we would like to remind you that whenever you get a flashing red Program State LED indicating a code error, you can find out more information by using the Dashboard Viewer.

Make sure your OI and RC are linked via tether or radio, connect your PC’s serial port to the DASHBOARD port on your OI, make sure the OI/RC jumper is set to “RC”, and you will see details about the type of error which caused the flashing red LED at the bottom of the Dashboard Viewer window.

This is how we diagnosed Astronouth’s problem, and it may also help you, Kesich.

Regards,
The Firmware Team
Innovation First, Inc.

We tried covering ours with Loctite, and it made all our code problems go away. (Actually, it made all the plastic sides of the robot controller go away, and the code would no longer run…)

VIOLA…no more nasty code bugs! :ahh:

-Quentin

Cool. Didn’t know it did that. :slight_smile:

Im having the same problem at the moment with my program … heh , I think I might re-write the whole code, have you tried re-writing your program in the newest version of FR_code ?

I was having the same problem until I did the following

  1. update your firm ware

  2. translate all your code from the older default to the newest , dont just put your files in their , copy and paste everything you need

  3. keep the back up battery plugged in

I hope that helps you, that what fixed the problem with my RC :cool: