ADIS16470 Not Working While ADIS16448 **DOES**


#22

Thanks for the update y’all. We now get the initialized/calibration message! The problem we’re running into is that we get tons of cpu load and “Invaild Checksum” printed in the console now. Sometimes we’ll get one static angle in between the invalid checksum messages. There’s another local team that is using java running into the same issue. We tried running both reset and calibrate with no avail and we’ve tried running without reset and calibrate.

Any ideas?


#23

The Java implementation is known to have some nasty CPU usage. A good portion of that is the handoff between the C++ code underneath and the Java environment.

We were able to get a good bit of the CPU usage down and I think the library has been updated on github and on Maven with the fix.

How many CRC errors are you getting? It’s normal to get one every few seconds or so. This is just the library throwing out data that was corrupted, which is normal. If you’re seeing no good data at all, you might want to double check your connection between the board and the RIO.


#24

That’s where the “Invalid Checksum” errors were coming from!? This thing killed our robot at Kettering #2 and none of the CSA’s could figure out where the errors were coming from. I’ll try to figure out if we still get errors today at Gull Lake.

EDIT: I’m still getting Invalid checksums today. For now, I think I’ll switch to the ADIS16448 since I can do so legally (thanks for that by the way ^_^).


#25

@CardcaptorRLH85 and @Kusha make sure you have the absolute latest version of the IMU libraries. We posted an update to them just this morning which should fix the CPU usage issue, and might alleviate some of the Invalid Checksum messages.


#26

I don’t see this update on Github, where do I find it?


#27

Ah, my mistake, the CPU usage was fixed on the ADIS16448 but not on the ADIS16470 yet, sorry for the confusion. But, since you did swap to the ADIS16448 for now, I would still strongly recommend updating to the latest library for that one since it will fix the CPU usage issue for that IMU.

I’ve included both release pages below, which will always list the latest available version for the libraries.


#28

Thanks for all the information! I am also trying to use the ADIS16740 with my team, do you have an idea when the CPU usage update will be available for that library?


#29

I don’t have an exact time frame for the fix for the 470 library but I will definitely post here and other places when that fix is available.