Air Compressor not turning off.

Maybe some of you experience team out there has this issue.

We have a pneumatic setup everything work except that the
compressor is not turning off. The manual indicate somewhere that this year we do not need to include compressor control in the programming, the PCM should handle that.

Veteran teams out using pneumatics, what do you find to be true?
Is our problem a programming issue?

Do you have a pressure switch wired in?

Did you plumb and wire the pressure switch correctly? Does the compressor continue to run after the pressure significantly exceeds 120 psi (ie 130+ psi?). Is the compressor and pressure switch wired to the PCM?

It’s almost certainly not a programming issue. Something may be wrong with the pressure switch. Have you verified it’s functioning properly.

Can we get a picture of the setup of the wiring and everything else. We may be able to spot issues.

We ran the sample code and tested the cylinder and work fine. But we noticed the compressor is not turning off. The pressure switch and compressor are both wired in PCM.

How do we wire the pressure switch correctly? I understand that it is not polarized.

I will try to get in a pic for you. Any of you using pneumatics this year?

Yeah it was about 135 psi and didnt turn off.

We plan to be, but we probably won’t have the system in a testable state for about a week.

Do you have a gauge to check the pressure? If it is over 120 something is wrong. If you have a leak it might never get to 120. Or if you have a rediculous amount of storage it would take a while to reach full pressure.

Ours ran, filled up, and shut off just as it should

Edit: try another pressure switch or double check the connections on the pressure switch. If wires are shorted it will continue running. Look for loose strands at the PCM connections.

We haven’t decided yet. We were about to get pneumatics working today but we couldn’t connect to the robot to test.:mad:

I second the request for wiring pictures. Did you try a difference pressure switch?

Your system should never allow you to get that high. Where was your emergency relief valve?

1 Like

The relief valve commonly doesn’t bleed air until 130-135 anyway.

1 Like

We had the exact same issue today. Swapped out the pressure switch, triple-checked everything and it still didn’t turn off. We finally tried a different PCM that hadn’t been updated and it worked! Compressor switched off as expected. The firmware version of the working PCM was 1.60 and the version that did not work was the newer 1.62.

It’s required by the rules to bleed at 125 psi. If yours doesn’t, you need to adjust it.

We had this same problem today. We discovered that the newest version of the firmware causes this problem. We reflashed back to the previous version and the pressure shutoff switch now works properly again.

To troubleshoot, completely disconnect the pressure switch from the pneumatics module. This should cause the compressor to shut off. (Fail safe) If it keeps running, it’s not the switch, it’s the firmware.

Ours is updated but we haven’t tested it yet; I’ll hook a compressor up it tomorrow and see what happens.

Also, has anyone from FIRST seen this thread, it looks like this might be a major problem.

Sorry to hear that. What seems to be the issue?

Were not entirely sure. I haven’t had a ton of time to dive into all of the documentation so I have been going off prior knowledge.

We have set up our control system and router correctly (we think). But when we try to connect to the D-link the computer says it is connected to the network but the driver station says it isn’t.

I have a feeling if I look at the documentation I may figure out what I’m missing.

This is a picture of our test. Hopefully you can make out the controls.
We might try swapping the pcm and see what happens

We swapped the pressure switch and found the same issue. We will try to
swap the pcm now and see what happens.

I will let you know tomorrow.