All CAN Devices Stopped Working

Hi everyone,
Everything on our can bus stopped working today. Everything worked roughly 2 hours ago when we were testing our bot, but now we get no connection with anything on the can bus. The bus is complete; all the Victor SPXs are blinking orange. I tried running phoenix tuner (connected to the RIO over USB), but it fails: Is Diagnostic Server Installed and RIO boot complete? Connecting to http://172.22.11.2:1250. We tried updating the RIO but that didn’t work either. Here’s the full log from the tuner:

Connecting to roboRIO... (03/06/2020 4:10 PM)
Connected sucessfully.
Writing files...
Written file: /home/lvuser/PhoenixDiagnosticsProgram (PhoenixDiagnosticsProgram)
Written file: /tmp/frcdebug (frcdebug)
Written file: /home/lvuser/robotDebugCommand (robotDebugCommand)
Starting Temporary Diagnostics Server
. /etc/profile.d/natinst-path.sh; /usr/local/frc/bin/frcKillRobot.sh -t 2> /dev/null @ /home/lvuser
Updating File Write Permissions
Syncing filesystem to ensure files are on the flash
Starting Temporary Diagnostics Server
. /etc/profile.d/natinst-path.sh; /usr/local/frc/bin/frcKillRobot.sh -t -r 2> /dev/null @ /home/lvuser

Duration: 00:00:04.31

Looks like you are deploying the temporary diag server. Which is fine, although if you have a deployed app you shouldn’t need to.

Please confirm the version of Phoenix you are using (particulary that you are not using the kickoff version)
https://phoenix-documentation.readthedocs.io/en/latest/ch21_Errata.html#kickoff-temporary-diagnostic-server-may-not-work

This sounds specifically like the roboRIO’s CAN connector is not connected to the rest of the devices.
I would start there after confirming you are using a recent version of Phoenix.

1 Like

Yep, apparently there was a loose connection. Thank you so much

Nevermind, identical issue. Phoenix tuner is the newest version as well.