Always timing out while flashing our radios

ive tried it a couple of times to reflash the firmware on our radios and each time it times out on me. The way im doing it right now is I’ve got 1 cable from the laptop into the 802 port, ill hit the load firmware button, ill plug in the power when it tells me to(we are using a poe injector which is pluged into the 18-24) , and then itll say radio found, flashing firmware. it’ll stay on that screen while the lights will cycle on the radio. Mainly, the power button will start flashing and then stop, and then the other ones will come on, and then itll time out a while later. I can send pictures of the setup if needed. Does anyone have any ideas how to fix this?
Thank you in advance

Use the port you have your POE plugged in (18-24vPOE) to flash the radio, i.e., go through the POE connection.

The radio lights you describe mean the radio is simply booting, not updating the firmware.

do you mean like this? When I tried it like this, it couldn’t find the radio and timed out just the same.

Yes that’s the way to do it.
Click on Firmware, then (disconnect if already connected) and reconnect the POE when prompted (as shown on your screen).

Did you temporarily Disable all the other network adapters on the PC, leaving just the Ethernet port?
Control Panel->Network and Sharing Center → Change adapter settings
Probably WiFi is the only adapter you need to Disable.
Sometimes extra networks obscure where the radio is.

I successfully flashed and configured the radio into 2.4 ghz mode, but now the ip in driver station is mismatched. Our driverstation has 10.44.18.2 but from cmd we can only ping 10.44.18.1. Is there a way to change the ip in driverstation or change the last digit?

I don’t understand what you don’t like.

10.44.18.1 is the network address of the radio.
That’s what you should be able to ping from the PC.

10.44.18.2 is the usual IP for your PC and is assigned by the radio DHCP.

You can see the normal IPs used in the robot network here:

what im saying is that the radio has an ip of 10.44.18.1, but in driverstation the ip 10.44.18.2 is listed like so:


I wanted to know if there is some way of changing either of them so they are the same. This is my first year of frc so maybe im missing something obvious.

10.44.18.2 is the assigned address of your roboRIO (robot).

That isn’t an assignable value in this tab. It’s there for information only because it changes based on circumstances.
The Driver Station actually attempts a series of DNS and IP addresses for the roboRIO.

It does look like your PC is blocked from the Radio though-that’s the ping for radio (above the robot).
It looks like you’ve disconnected the Ethernet from the PC.
Have you connected the PC to the radio by selecting it through WiFi?

Two of your Firewalls are on (Dom, Prv) and can be blocking you from the radio.
I’d try turning off all the Firewalls to see if that lets the ping through.

I’ve had it connected to the radio by wifi since I pinged the radio through cmd.
Here is a screenshot of what my DS looks like right now when im on the radio’s wifi network:

however, i noticed that in the dropdown next to the team number there is this option:

I’m wondering what this is and why it works. In the dropdown next to the name it also had an ip of something like 10.44.18.79 which im confused to the origin of and how this option is different than just typing in 4418 into the team number box.
Thank you

It appears that you haven’t set the roboRIO team number in the imaging tool.

That status looks good.
If you connect a roboRIO to the radio you should see that appear green as well.
If your roboRIO is already connected and just not being detected then, as Joe said, you want to check that it has the team number set there.

The Team Number field is used to try different ways to connect to the roboRIO, which is not recognized as belong to your team right now, so it’s trying some things that you won’t normally see when you are actually connected to a roboRIO with your team number.

Putting a team number in that field uses it to construct the normal (10.TE.AM.2) IP address to check as well as the normal dns address ( roboRIO-4418-FRC.local).
We can put any IP address in that field and it will be used instead.
It seems to be showing a roboRIO device id, meaning it found a roboRIO but it wasn’t assigned to your team.

10.44.18.79 is an IP address that would get assigned by the radio DHCP as just a random device on the network when it doesn’t recognize the roboRIO as being assigned to your team.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.