Anderson PowerPole for 18AWG cables

We’ve noticed a strange malfunction concerning anderson powerpole connectors that we bought via AndyMark. When we used the connectors on 18AWG cables the contacts seemed to crimp well, but when we connected two powerpoles together the connection was unstable i.e. the housings fit together well but the contacts inside did not. From our experiance this happens only with 18AWG cables (the contacts crimped on 16,14 and 12AWG cables worked well). The problem might have been caused by using the wrong port of the crimping tool but we’re pretty sure most of the cables were crimped right. We are aware that the specific contacts supplied by AndyMark are supposed to be suitable for 10-16AWG cables but they looked ok after we crimped them.
Has anyone else seen this kind of problem and knows how to deal with it?

Link to the connectors we bought:

Noticed the same issue with some AndyMark branded PowerPoles I bought from MicroCenter on clearance.

Fixed it by removing the pin from the plastic housing, bending such that it would ride higher in the plastic housing and engage the opposite side harder and by bending up the little piece of metal (is it spring steel?) in the bottom of the plastic housing.

Worked fine for me after.

Those are PP45 crimps, meant for 10 gage wire. For 16 and 18 gage, you need the PP15 crimps. The housing is the same.

Here is the link for the PP15 terminals Knufire mentioned.

As he stated regardless how you crimp them you will not get a good crimp on your smaller gauge wire with the PP45’s.

We stock PP15 for 16&18awg PP30 for our 12 gauge and PP45 for our 10gauge (usually only for drive motors or other very high current motors.)
You can see them all here

We ran into the same issue with all of the new internal lugs we bought this year. We wound up removing all of the lugs from the casings and very slightly bending the ends up to make better contact just like techhellpbb said. Worked great after that. Also are using the XT60 connectors, and those are amazing. No issues of connectivity there.