Any one figure out the Driversystem error "Can not find script file"

So I just updated my NI stuff and I have always been able to run my SmartDashboard off of the Driver Station. Yet after this new update, I get this error "Can not find script file “C:\Users<my username>\Desktop%PUBLIC%\frc2019\tools\SmartDashboard.vbs”. I have tried the change the NI file but it won’t save and still gives me the error, I’m lazy and don’t want to go to my desktop every time. Does anyone have any ideas?

Brayden Coyer

Team 4381

Getting the same thing but with Shuffleboard.

1 Like

Yeah I noticed that

This is a known issue with no current solution or workaround. NI may release an update at some point to fix it, but for now you’ll just need to live with not being able to start it from the DS. You can set the dashboard to “remote” to avoid starting any dashboard at startup.

1 Like

I knew it was a know issue, hoping, someone had a fix lol.


Well, as it turns out, I figured out a workaround, but it’s a real hack.

Create a folder called literally “%PUBLIC%” on your desktop, create a folder in it called “frc2019”, then create a folder in frc2019 called “tools”. Copy the SmartDashboard.vbs file from C:\Users\Public\frc2019\tools into the new tools folder, then edit that copy and change the toolsFolder= line to read toolsFolder = "C:\\Users\\Public\\frc2019\\tools". When you’re done, double-clicking that .vbs file should run SmartDashboard. The DS option for SmartDashboard will then work.

This same workaround works for Shuffleboard.vbs.

Note this workaround only works if you start the DS from the Desktop shortcut. Basically the DS looks in the current directory from where it started from. So if e.g. you start the DS from the start menu instead, you’ll need to put the %PUBLIC% folder in a different location. The error message the DS gives you will tell you where to put it.

How do you change the toolsfolder line to read that?

When you installed the VSCode package from WPI, you should have also gotten 3 desktop shortcuts: FRC VS Code 2019, FRC SmartDashboard, and FRC Shuffleboard. If you double click the shortcut for FRC SmartDashboard, the SmartDashboard should come up. As Peter_Johnson said, there is a known issue with trying to open SmartDashboard from the Driver Station. An alternative is to go to “C:\Users\Public\frc2019\tools” and run “SmartDashboard.vbs”. Both of these are workarounds to the problem.

I made a simple .bat file to open the DS and SmartDashboard simultaneously:

@echo off
cd "C:\Program Files (x86)\FRC Driver Station"
start DriverStation.exe

cd "C:\Users\Public\frc2019\tools"
start SmartDashboard.vbs


Just paste this into a .txt and save it as a .bat to your Desktop. The one downside is you can’t pin it to your taskbar, but it does save those 0.5 seconds it takes for me to open each individually.

EDIT: I also set the batch file icon to %ProgramFiles(x86)%\FRC Driver Station\DriverStation.exe so it looks like the DS

I know this is an old topic now but you could create a shortcut to your .bat file and then pin that to the taskbar.

NI fixed it in the subsequent version of the NI Update Suite, so just be sure to update.