Autonomous not working

Our auto mode is programed in but it wont start. Its based on time, like from the object that gives match time. I dont know if that would cause it? But parts of it that have nothing to do with match time dont work either. Is there anything special I have to pit in the auto int case?

Could you post your code? People can only help and find errors if we can see it.

like from the object that gives match time

what object?

Match info. The codes in the classmate locked in our tookbox at the moment.

Sounds like you’re using Labview, is this correct?

I’m not sure if they changed this from last year or not, but that “Autonomous Elapsed Seconds” part of the cluster in the default Auto Iterative code was in milliseconds last year not seconds. Had to find that out by probing it while trying to fix a similar issue last year.

Still, we have a motor that should run at a set speed that has nothing to do with the time at all. Its just when auto starts, motor should turns and not stop.

I would double check that you have set the proper Autonomous to execute in Begin.VI. The default is Autonomous Independent if I recall correctly.

Also, make sure that you are feeding the watchdog appropriately in Autonomous mode.

The best way to debug what’s going on is going to be by running your Autonomous on the practice field. Look for errors on the driver station Diagnostics tab. If you don’t see any and Autonomous is still not do anything, run your code from a computer instead of deploying it, this will allow you to use probes to see what is happening in your code.

Ill stick it on blocks in the pit.

Now wait a sec, were supposed to tell auto to execute in begin.vi? THATS news to me.

How does one do this?

At the top of Begin.VI is a selector for whether you are using Autonomous Independent or Autonomous Iterative. You need to set this enum to match the mode you put your code in.

I have circled the setting you need to change to use Autonomous Iterative in red in the attached picture. You DO NOT need to modify the two things I have crossed out in blue





Thanks a ton. If I cant get it working I’ll ask someone there.

Thanks, thats exactly what was wrong. Changed it and ran it and the robot almost ran away

Fantastic! Glad I could help, and glad you got your issues ironed out.

we the palmy home bots have a better solution just do this:
//When channel 5 down the below code runs
//When channel 5 down the below code runs
if(vexRT(Ch5) > -100)
{
motor[LTrack] = motor[RTrack] = 0;
motor[LMotors] = 127;
motor[RMotors] = 127;
wait10Msec(400);
motor[LMotors] = 0;
motor[RMotors] = 0;
motor[LTrack] = motor[RTrack] = 127;
wait10Msec(1600);
motor[LTrack] = motor[RTrack] = 0;
}

but you may have a different robot

The OP was programming in LV for the cRIO, your code is C for the VEX controller =P

They both work, but porting this code over is more difficult than just re-writing it. (Just a side note, motor power is -1 to 1 now, not 0 to 255 anymore).